Jump to content
Mark Ingram

Affinity Photo Customer Beta - 1.5.1.46

Recommended Posts

Click here to download the latest beta

Status: Customer Beta
Purpose: Performance and stability
Requirements: A valid product key, issued when Windows Affinity Photo version 1.5 was purchased.

As this is a beta release, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Added several performance improvements
  • Improved application start time
  • Fixed crash when using cursor keys to feather a selection
  • Fixed Selection Brush resize shortcuts not updating the context toolbar values
  • Fixed mouse wheel on opacity edit not applying
  • Fixed Retina Rendering Performance Preference (it was always doing a two-pass render for the high quality only option)
  • Fixed Layers panel not updating when switching documents with a live filter open
  • Fixed Unlinked / Separate Grid line and Subdivision line colours are not remembered
  • Fixed being unable to re-apply the last applied snapshot
  • Changed "Save With History" to prevent silent save back to JPEG, etc
  • Fixed crash when clicking the swatch in Edit > Matte
  • Fixed crashes when opening SVGs with no bounding boxes
  • Fixed Help search results not displaying if temp path contains non-ASCII characters
  • Distinguish between beta and normal builds in Explorer's "Open With" menu
  • Fixed failing to select a word when right-clicking on the text caret
  • Fixed being unable to interact with Transform panel when you draw out a marquee
  • Fixed Colour Chooser not retaining the last type you were on
  • Fixed Grid and Axis Manager not reflecting the currently selected artboard
  • Improved support for badly formed PSD files
  • Fixed Remove button on New Stack Document dialog not working
  • Pixel width and height not updating in the Resize Document dialog, when changing the resolution with 'Resample' unticked
  • Fixed Macro panel can appear off bottom of the screen
  • Fixed Move Up/Down for Library categories are in the wrong order
  • Fixed crash when changing the order of categories in the Library panel
  • Fixed lens correction failing to work due to wrong lens look up
  • Fixed crash when attempting to use undo brush when there is no history
  • Fixed frequency separation crashing 32-bit documents when the bilateral is used
  • Fixed cancelling macros import displaying an error message
  • Fixed macro parameters appearing with empty tooltips
  • Added scroll to macro parameters flyout
  • Fixed changing dimensions before DPI in Resize Document dialog resizing out of aspect
  • Fixed deleting a develop snapshot applies the first snapshot
  • Fixed being unable to use keyboard shortcuts in FFT Denoise dialog
  • Fixed Sources panel sources only showing with Clone brush active
  • Fixed Sources panel toggle source preview icon doesn't change
  • Improved performance of previewing a clone source

Share this post


Link to post
Share on other sites

I appreciate very much your good work. The performance improvment in this new beta is noticable, the app starts faster and files load a little faster. I don't know if you worked on the tablet support bur my Wacom pen has never worked so well.

 

But I found a bug, here are the steps to reproduce it (at least on my system):

  • Open a jpg file
  • Use a Level Filter
  • Unsharp Mask filter
  • And then a Denoise Filter. When using this filter the "Level Filter" layer was selected by mistake, so I couldn't make the Denoise filter work and I played a little with the slider and then noticed the selected layer. As soon as I click on the "Background" layer to select it, while the Denoise filter box is still open, AP crash with the error shown below.

post-32421-0-36418600-1481637163_thumb.jpg


Window 10 - 16 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites

Well done - great to see the consistent and constant working to improve and fix bugs in the software. :)


Windows 10 64bit ¤ AMD A10-6700 APU ¤ AMD Radeon HD8670D + R7 240 2GB Dual Graphics ¤ 16GB DDR3 Ram

Share this post


Link to post
Share on other sites

Yes, faster start and little more fast load.  :)


OS: windows 10 home 64 bits
Lenovo core I7 6700HQ
8Gb Ram
Nvidia GTX 950 4 gb Memory

SSD 256Gb

HD 1TB 5400 rpm

Share this post


Link to post
Share on other sites

The performance improvment in this new beta is noticable, the app starts faster and files load a little faster. I don't know if you worked on the tablet support bur my Wacom pen has never worked so well.

 

 

Yes, the performance improvements were designed to improve the brushing experience with Wacom (and similar) tablets, as well as application start time, and general application usage.

 

We are still working on performance and stability, so expect more improvements to come.

Share this post


Link to post
Share on other sites

Will have to test it today :)

 

EDIT: I just tested the start time and after installation it take 1min to load the app :( same thing when I start my pc, second start is around 16sec.

 

5400rpm hdd tho... Still I belive these times can be a bit better.

Share this post


Link to post
Share on other sites

I thought this new Beta would check that the full release version of Photo is installed and then allow its own installation to continue, as happened with the Customer Beta(s) of Designer.

 

But no, apparently I must dig around in my emails OR open my Affinity account page in order to find my product key.  Is that correct?

 

If so, why?


Win 10 Pro, i7 6700K, 32Gb RAM, AMD Radeon R7 360 and Intel HD530 Graphics

 

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher.

Share this post


Link to post
Share on other sites

Nice one guys, loads a little faster now! Excellent stuff. Just a quick question do I need to save a backup of Affinity should I ever have disk problems or will it always be available for download?.

thanks

Steve

Share this post


Link to post
Share on other sites

Will have to test it today :)

 

EDIT: I just tested the start time and after installation it take 1min to load the app :( same thing when I start my pc, second start is around 16sec.

 

5400rpm hdd tho... Still I belive these times can be a bit better.

 

The only thing that could slow it down is a slow machine, or lots of fonts or ICC profiles. Could this apply to you?

Share this post


Link to post
Share on other sites

I thought this new Beta would check that the full release version of Photo is installed and then allow its own installation to continue, as happened with the Customer Beta(s) of Designer.

 

But no, apparently I must dig around in my emails OR open my Affinity account page in order to find my product key.  Is that correct?

 

If so, why?

 

If you currently have Affinity Photo installed, it should find the product key from that. When I tested it this morning I didn't have to enter my product key.

Share this post


Link to post
Share on other sites

Some language bugs in german still there ("Copy flattened"; 2 x "90° im Uhrzeigersinn drehen")

 

Nice: though the beta was installed in a new directory as "consumer beta" it preserved the workspace-settings from the "public beta"

Share this post


Link to post
Share on other sites

The only thing that could slow it down is a slow machine, or lots of fonts or ICC profiles. Could this apply to you?

fonts - no

slow machine - yes

icc profile - no

 

I'm testing this beta on girlfriends laptop - a youtube/facebook 300€ machine, like I said 5400rpm hdd.

Anyways the loading times are better that in previous beta but still takes 6sec to close even tho there's nothing open in AP.

 

1 question Mark: Like I said I'm testing this beta on my gf laptop, will I be able to install and transfer my licence on my new pc when I get it next year?

Share this post


Link to post
Share on other sites

If you currently have Affinity Photo installed, it should find the product key from that. When I tested it this morning I didn't have to enter my product key.

I do, and it didn't!  I had to re-enter all my product key/registration details.

 

However, I use D:\ as the dedicated HDD where most of my programs are installed to and run from, including Affinity Photo (release version).  Could that be the reason for this anomaly, which I have not previously seen with the customer beta of AD?


Win 10 Pro, i7 6700K, 32Gb RAM, AMD Radeon R7 360 and Intel HD530 Graphics

 

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher.

Share this post


Link to post
Share on other sites

I do, and it didn't!  I had to re-enter all my product key/registration details.

 

However, I use D:\ as the dedicated HDD where most of my programs are installed to and run from, including Affinity Photo (release version).  Could that be the reason for this anomaly, which I have not previously seen with the customer beta of AD?

 

Possibly, yes. I'll ask the install engineer to take a look and see if he can reproduce this. He might want to get a couple of values out of your registry to confirm the issue.

Share this post


Link to post
Share on other sites

1 question Mark: Like I said I'm testing this beta on my gf laptop, will I be able to install and transfer my licence on my new pc when I get it next year?

 

Yes, if you use it for non-commercial purposes (I can't remember what the licence says, I have a feeling it says 3 computers - but don't take my word for it, make sure you check). If you use it for commercial reasons (i.e. your job or business requires it) then you need a licence per machine.

Share this post


Link to post
Share on other sites

Possibly, yes. I'll ask the install engineer to take a look and see if he can reproduce this. He might want to get a couple of values out of your registry to confirm the issue.

Thanks Mark.  Happy to supply any further information needed.


Win 10 Pro, i7 6700K, 32Gb RAM, AMD Radeon R7 360 and Intel HD530 Graphics

 

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher.

Share this post


Link to post
Share on other sites

Yes, if you use it for non-commercial purposes (I can't remember what the licence says, I have a feeling it says 3 computers - but don't take my word for it, make sure you check). If you use it for commercial reasons (i.e. your job or business requires it) then you need a licence per machine.

But I can still transfer it even if I use it for commercial reasons? I'm not gonna have it on this pc when I get me a new one.

Share this post


Link to post
Share on other sites

Yes, if you use it for non-commercial purposes (I can't remember what the licence says, I have a feeling it says 3 computers - but don't take my word for it, make sure you check). If you use it for commercial reasons (i.e. your job or business requires it) then you need a licence per machine.

 

If the Windows licence is the same as the MAS one (which I thought it was supposed to be) then you can use it for non-commercial purposes on any machine that you own or control.

 

But I can still transfer it even if I use it for commercial reasons? I'm not gonna have it on this pc when I get me a new one.

 

The licence is tied to the user, not the machine. As long as you have one licence for each machine on which it's simultaneously installed, it doesn't matter which particular machine(s) you're using it on.

 

Back on topic, it's a nice update but I hope we'll see the text tools cursor visibility issue fixed soon. And we still can't 'scrub' the Fill Opacity in the Effects panel (unlike the global Opacity control in the Layers panel, which scrubs as expected).


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iOS 12.4.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Good improvement in opening speed and jpegs also faster.

It would be great to have them open as fast as afphoto files. Is that possible?

Well done to the team.

 

ps It found my product key with no problems and I find I have 2 Affinity Photo apps installed the purchase 1.5 and the beta so I can choose which to use and compare. Great!


"You never get a second chance to make a first impression"

Dell Inspiron 5570 i5-8250u | 8gb | SSD.m2 | Win 10 Pro 64

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.