Jump to content

Recommended Posts

It's OK, I've found the problem - on Windows 7 (and maybe also Windows 8), you'll need to copy some more files:

 

api-ms-win-*.dll

ucrtbase.dll

 

Alternatively you could just install the Visual C++ Redistributable for Visual Studio 2015: 

https://www.microsoft.com/en-gb/download/details.aspx?id=48145

 

Thanks,

Jon

 

I work with Windows 7 and I already have in affinity > Common all the files you mentioned, but still I see only the Affinity Logo and the file name.

Share this post


Link to post
Share on other sites

Daniele, your screenshot of the Affinity>Common Files folder does not appear to include one of the four files which Jon W listed, specifically ucrtbase.dll.  I don't know if that is what is causing the problem for you?


Win 10 Pro, i7 6700K, 32Gb RAM, AMD Radeon R7 360 and Intel HD530 Graphics

 

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher.

Share this post


Link to post
Share on other sites

The first 2 additional files are all that's needed on Windows 10, but on 8.1 & 7 you also need lots of other files as John explained when he said you need

 

- api-ms-win-*.dll

- ucrtbase.dll

 

That first line means ALL the files that start api-ms-win-??????.dll from the same folder as Affinity Designer EXE.

 

Then one more file called ucrtbase.dll.

Or instead the Visual Studio Runtime library install would put all those in your system folder and the thumbnail provider will have all it needs for your OS.

 

Have you tried installing the latest Affinity Photo for Windows beta? It does all this for you.... (see the 2nd last point on the release notes)

 

https://forum.affinity.serif.com/index.php?/topic/30345-affinity-photo-public-beta-15043-windows/

 

As does the latest Affinity Designer Customer beta

 

https://forum.affinity.serif.com/index.php?/topic/30346-affinity-designer-customer-beta-15143/

 

So really this should not be a problem anymore for anyone.


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites

The first 2 additional files are all that's needed on Windows 10, but on 8.1 & 7 you also need lots of other files as John explained when he said you need

 

- api-ms-win-*.dll

- ucrtbase.dll

 

That first line means ALL the files that start api-ms-win-??????.dll from the same folder as Affinity Designer EXE.

 

Then one more file called ucrtbase.dll.

Or instead the Visual Studio Runtime library install would put all those in your system folder and the thumbnail provider will have all it needs for your OS.

 

Have you tried installing the latest Affinity Photo for Windows beta? It does all this for you.... (see the 2nd last point on the release notes)

 

https://forum.affinity.serif.com/index.php?/topic/30345-affinity-photo-public-beta-15043-windows/

 

As does the latest Affinity Designer Customer beta

 

https://forum.affinity.serif.com/index.php?/topic/30346-affinity-designer-customer-beta-15143/

 

So really this should not be a problem anymore for anyone.

 

I attach  a screen-shot with the list of files I have now, after the last AP 43 release. As you can see they are all there.

To be sure, I have also restarted the PC, but nothing has changed at all.

post-37112-0-87512200-1480784341_thumb.jpg

Share this post


Link to post
Share on other sites

The first 2 additional files are all that's needed on Windows 10, but on 8.1 & 7 you also need lots of other files as John explained when he said you need

 

- api-ms-win-*.dll

- ucrtbase.dll

 

That first line means ALL the files that start api-ms-win-??????.dll from the same folder as Affinity Designer EXE.

 

Then one more file called ucrtbase.dll.

Or instead the Visual Studio Runtime library install would put all those in your system folder and the thumbnail provider will have all it needs for your OS.

 

Have you tried installing the latest Affinity Photo for Windows beta? It does all this for you.... (see the 2nd last point on the release notes)

 

https://forum.affinity.serif.com/index.php?/topic/30345-affinity-photo-public-beta-15043-windows/

 

As does the latest Affinity Designer Customer beta

 

https://forum.affinity.serif.com/index.php?/topic/30346-affinity-designer-customer-beta-15143/

 

So really this should not be a problem anymore for anyone.

 

I already installed since over a month all the files you mentioned (i.e. the same as in AD are in the Common Folder), but still I cannot see the file image (only the file name and the affinity logos appear).

I have both AD & AP with the official release (no more Beta).

Share this post


Link to post
Share on other sites

@Daniele Salvatore: I don't know if it the same for Windows but on Macs, for both AD & AP there is a "Save Thumbnails with documents" option in Preferences > General that must be enabled (checked) to see document previews instead of the Affinity logos.

 

If you have that option in the Windows versions, make sure it is enabled.


Affinity Photo 1.8.3, Affinity Designer 1.8.3, Affinity Publisher 1.8.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 
1.8.3.180 & Affinity Designer 1.8.3.2 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites

@Daniele Salvatore: I don't know if it the same for Windows but on Macs, for both AD & AP there is a "Save Thumbnails with documents" option in Preferences > General that must be enabled (checked) to see document previews instead of the Affinity logos.

 

If you have that option in the Windows versions, make sure it is enabled.

 

It has always been like that since the very beginning; I enclose the screen-shot to show as it is. I do not know anymore what to do.

post-37112-0-27538800-1483380128_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Kathryn, this is the forum for the Windows beta, you may have more luck with your thumbnail issue in the General forums :)

 

I do not understand; the title of this topic is File Icons on Windows 7.

I also was supponing that Affinity Icons and Affinity Thumbnails have the same meaning. Therefore this should be the right forum.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.