Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Crash when I create or open a project


Recommended Posts

Hello,

 

I have a small problem with Affinity Photo in its BETA version under Windows. As the title says, the application starts well but as soon as I create an empty project or I load, the application freezes for a while, windows emits a small  sound error message without displaying anything and for Finish, the application ends up closing automatically.

 

No errors during installation. My system:

 

I7 3770k 32 gb RAM

980 TI

Windows 10 64-bit

 

I tested in compatibility mode (win7) and in administrator, same problem.

 

Does anyone have an idea on how to fix this problem?

Thank you.

Link to comment
Share on other sites

  • Moderators

Hey Bodhi,

Welcome to the Affinity Forums :)

Can you try grabbing the recent beta from here if you haven't already.

I'd also appreciate it if you can attach a recent crash report so we can take a look. You can find them in:
%AppData%\Affinity\Photo\1.0 (Beta)\CrashReports\

 

Thanks

Link to comment
Share on other sites

  • Moderators

Hey Bodhi,

 

If build .39 still has the crash chances are the issue wasn't identified before we pushed the newer version. Unique isssues like these can take a bit more time to fix when we cannot reproduce it. I'll see if development have had chance to take a look at it yet and report back. Thanks. 

Link to comment
Share on other sites

  • Moderators

Hey Bodhi,

 

Development have looked into it and it looks as though the crash is happening in Direct3D. We believe we have seen this before caused by either bad drivers or conflicting software such as screen recording software. Do you use any kind of recording software at all? If not, it might be worth sending me a list of your running apps from Task Manager to see if there is anything that stands out.

Thanks 

Link to comment
Share on other sites

I use several video capture software :

 

- Mirrilis Action

- D3DGear

- GameCaptr

- Bandicam

- A old version of camtasia

- ShadowPlay

 

They are installed but are not launched at system startup, so theoretically, not in memory.
 
I do not think I've seen any process related to one of these softs in the list. However I will try to uninstall all of these software to see if actually this is the problem.
 
I'll keep you informed.
Thanks.
Link to comment
Share on other sites

Ok, after the uninstall of action, d3dgear and gamecaptr. Affinity Photo starts and does not crash when opening a project or loading an image.

 

I started reinstalling my capture software and testing affinity between each installation. No problem to report, the software does not crash.

 

Once reinstalled everything, I rebooted the machine, and the same, it does not crash.

 

I hope this will hold, but yes the problem seems to be that.

 

Thanks in any case, If ever I have any worries, I would contact you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.