Jump to content

Recommended Posts

Hi,

 

I just bought Affinity Designer (version 1.5.0.36) for Windows. I have the following error:

 

An error occurred while exporting to:
C:\Users\Luko\Desktop\Untitled.pdf
The file could not be created.

 

I've tested this on a Windows 10 pc and a Windows 7 pc.

 

Please advise. Thank you.

 

Share this post


Link to post
Share on other sites

Welcome to the Affinity Forums, Luko. :)

 

There's no reason that I know of why you shouldn't be able to put a PDF file directly on your Desktop, but try creating a folder to put it in. If it still doesn't work, please attach your *.afdesign file here: press the 'More Reply Options' button to display a page which includes the Attachments feature, browse to the file and then press 'Attach This File'.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iOS 12.4.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

I can't reproduce the problem here on Windows 10 Home. All seven presets worked for me from this admin account, and when I switched to an ordinary user account and tried a couple more times I still didn't get any error messages.

 

Are you using a non-English UI setting in AD? Are you using a non-English version of Windows?


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iOS 12.4.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Running English in AD and English for Windows. Do you think if I download it again and install it might solve the problem? Thank you.

Share this post


Link to post
Share on other sites

No I don't think so, a clean install won't change this. Have you had any successful exports? Is that file perhaps still open in another PDF reader program?

 

Is the path as you typed it or are any of the characters in your Windows username accented?


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites

Hi Luko - unfortunately we're still unable to reproduce the issue. Would you be able to post a screenshot of all the PDF Export settings you are using please (don't forget to click 'More' to expand them all). Have you tried using any of the other Export Presets? Also I presume you're exporting from File > Export and not the Export Persona?

Share this post


Link to post
Share on other sites

Hi Sean,

 

Attached two screens shots. I have tried all the presets without altering any settings, all with the same error.I am indeed using File > Export and NOT the Export Persona.

 

I know this might be a stupid question, but Anti-Virus will not have any effect with an export like this? I  have tried this export on 3 different pc's all with the same error. Two of them running Windows 7 and one running Windows 10. On similarity I can think about is that all have Bitdefender Anti-Virus installed.

 

Also when exporting in the Export Setting screen at the bottom it reads: "Estimated File Size: Calculating..."

 

Thank you.

 

 

post-42430-0-29956800-1479805109_thumb.jpg

post-42430-0-62826200-1479805113_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Luko,

Thanks for the screenshots - unfortunately i'm still unable to reproduce it.

I've tried it using the PDF (For Print) profile shown in the screenshot and also with Bitdefender Free Version installed and unfortunately still cannot reproduce this. In your screenshot you've got 'Document Properties' shown in the History tab - what did you change in there? Are all the documents that are failing set to use a specific colour profile at all?

Share this post


Link to post
Share on other sites

I cannot rememer what I changed in Document Properties. Please see attached document which I used.

I did not assign any color profile. Used the software as is after install.

 

Is there a newer version which I can download which might resolve this. Thank you for your help.

Affinity.afdesign

Share this post


Link to post
Share on other sites

Still no luck with that file :( I presume you've tried exporting to a different drive or folder that isn't on your desktop? Windows Permissions might be stopping it!

 

Failing that would you be able to go to %AppData%\Affinity\Designer\1.0\ and zip up the contents of that folder and upload it here please.

 

Once you've done that could you try holding down Ctrl and then launching the application. This will display the Clear User Data dialog - if you tick all the boxes and click OK it will clear any customization you've made or any presets, brushes etc you've added and get you back to a 'like new' starting point. See if that helps!

Regarding a newer build there currently isn't one of Designer yet however you could try opening your file up in the Photo Beta (which is marginally ahead) and see if that gives the same error on export.

 

Share this post


Link to post
Share on other sites

I tried the reset, selected all and reset it. Still no change. I also tried opening with Affinity Photo Beta, also the same error. Very weird. I uploaded the zip. The file is very small?

See screenshot attached for location where I zipped it.

post-42430-0-17944600-1479813028_thumb.jpg

Share this post


Link to post
Share on other sites

Hi

 

I'm having the same trouble. I'm running Windows 10 Home. The document I'm playing around with isn't special just some text and pictures.

 

Any help?

 

Philip

Share this post


Link to post
Share on other sites

I am having the same problem. I can export other files to pdf just not that specific file. I think there is some object that is causing the error.

I have tried using Mac retail and windows beta and both have the same problem. I have also tried export to svg and eps which work but look terrible. Exporting to PSD works well and will use that for now. 

 

A few things you might want to try to help narrow down the problem.

Try export a blank document to pdf and see if that work?

Start deleting stuff from the file your trying to export to figure out what is causing the problem

 

Would like to know your results

Share this post


Link to post
Share on other sites

I'm having this problem on a document A4 size with one word typed on it. So I do not think its an object causing the problem. Also a blank document gives the same message.

Share this post


Link to post
Share on other sites

I have figured it out !!!! :D The problem is the color format. RGB/32 does not export to PDF for some reason so you need to convert it.

 

Go to File->Document setup-> Color tab -> Change colour format drop down

Change to RGB/16 for digital or CMYK/8 for print

(This messes up the colors and you can fix manually)

 

There may be a way to keep RGB/32 but I don't know how.

Hopfully this is helpful

Share this post


Link to post
Share on other sites

Yes, switching profile to CMYK solves the problem for me as well.   Not really what I want to do for web-based design files though - especially export to PSD.

Ryan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.