Jump to content
Sign in to follow this  
KoBu

APwin „New from clipboard“ selection with strange behaviour

Recommended Posts

When I open a picture by „file open“, I can make a selection of a part of the picture, copy and paste this. Then I get a new layer with only this selection.

 

When I open a picture by „New from clipboard“, I can make a selection of a part of the picture, too. But when I copy and paste this selection, I get a new layer with the complete picture (and not only with the selection). I think, that is a small bug.

 

KoBu


Win10 HP i7 - AD (Win), AP (Win), APub beta (Win), AD (iPad), AP (iPad),
Affinity Photo for iPad Pro - the best app I ever had
excuse my bad English

Share this post


Link to post
Share on other sites

Hi KoBu,

That's because the layer you're copying the selection from (in the second case) is an (Image) layer type. You can check this looking at the label between parenthesis after the layer's name if there's one. Right-click on it in the Layers panel first and select Rasterise... from the contextual menu to convert it to a (Pixel) layer type. Then you can select and copy just the selected part to a new layer. Only Pixel layer's type lets you edit them at a pixel level. (Image) layer's type are considered objects and can only be transformed globally (scale, rotate, skew etc) but you cannot change their content (pixels).

Share this post


Link to post
Share on other sites

Thank you Miguel for your quick response.

That simplifies working for me.

 

KoBu


Win10 HP i7 - AD (Win), AP (Win), APub beta (Win), AD (iPad), AP (iPad),
Affinity Photo for iPad Pro - the best app I ever had
excuse my bad English

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×