Jump to content
Sign in to follow this  

[Duplicate] Issues between Designer and Photo

Recommended Posts

Hello everyone!

I just needed to add some Japanese text to an image, which older versions of Affinity Designer / Affinity Photo didn't support. So I updated both of them.

Afterwards, I tried to add the text in Affinity Photo, which resulted in weird letters.

In Affinity Designer, however, it worked.

Then I noticed that in Designer, 'File -> Edit in Photo' is greyed out.

I thought this may have something to do with the Japanese letters which aren't supported by Photo yet.

So I tried to drag and drop the file directly from Finder to Photo, which gave me an error saying the file version isn't supported by this Affinity version.

But even after deleting the Japanese text in Designer, I wasn't able to open the file in Photo anymore.

Any ideas what's happening?


By the way, even when creating new files, I am not able to jump back and forth from Designer and Photo anymore using 'File -> Edit in Photo' or 'File -> Edit in Designer'.

Also, even creating new files in Designer will not let me drag and drop the files to Photo (same error about not supported by this Affinity version).

It is, however, possible to drag and drop new files created in Photo to Designer ONCE.

After making changes to that file and saving, I cannot drag and drop it to Photo anymore.


Versions used:

Affinity Designer: 1.5.1

Affinity Photo: 1.4.3



- Affinity Designer and Affinity Photo file versions are not fully compatible anymore.

- Jumping back and forth between Designer and Photo functionality ('File -> Edit in [Designer / Photo]') is broken.


Best wishes,





Just for reference, back in April I already posted about one of these issues here:


(3rd issue there)

I wasn't able to jump from Photo to Designer. Now I can't do that, nor can I jump from Designer to Photo. So this problem has even been made worse.

Share this post

Link to post
Share on other sites

Hi shushustorm,

Welcome to Affinity Forums :)

We are aware of this issue. Currently Affinity Designer uses and updated version of our native file format which is not compatible with Photo 1.4.3. So if you create or save files in Designer 1.5 you cannot open them or send them to Affinity Photo (1.4.3). As soon as Photo 1.5 is out everything will work as expected again since both programs will be using the improved file format.

I'm marking/closing this thread as a Duplicate.

Thanks for your report.

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.