Jump to content
Jeffjn

Dictionaries and spell check

Recommended Posts

4 hours ago, mykee said:

Ok, I tested and works! Add hyphenation dictionary too, and program can change to my language, but no use! I see red lines everywhere, and no hyphen on my pasted text in textbox, but Auto hyphenation is on...

I download directories from here:

https://github.com/LibreOffice/dictionaries

Can you show us a screenshot of your Program Files\Affinity\Publisher Public Beta\Resources\Dictionaries\hu_HU directory?
Also, in the Paragraph panel, in the Hyphenation section, can we see a screenshot of the settings you've specified?


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Here is my folder structure and I left Hyphenation by default. Folder renamed from hu-HU to hu_HU, but no helped. I renamed back to hu-HU, this correct folder name what see all Affinity program.

Hyphenation and spelling folder.jpg

 

 

Update: spell check working now. I downloaded FULL HunSpell pack, and unpack files manually, and replaced files. But hyphenation not working yet. :(

I see these lines in hyph_hu_HU.dic file:
COMPOUNDLEFTHYPHENMIN 3
COMPOUNDRIGHTHYPHENMIN 3


Set I Minimum prefix and Minimum suffix to 3? I changed but nothing happened.

What I tried:

  • set hyph_hu_HU.dic encoding from UTF-8 to ISO8859-2 in file and header
  • change text in text frame to Justify Left
  • change hyphenation settings (all parameters) to other numbers (see preview)
  • all language settings to hungarian (magyar)

No helped. :( 

 

Hyphenation 2.jpg

Share this post


Link to post
Share on other sites

Ok, I tested with other language:

  • working with English, and Spanish, others not
  • en-US is better like en-GB, nearest to hungarian hyphenation

I testing more...

 

Update: I copied hu-HU folder to base install location (C:\Program Files\Affinity\Publisher Public Beta\Resources\Dictionaries) and rename old folder. After start program, hyphenation is working. Delete folder from base path and set folder name back on ProgramData path, and hyphanation working too. Hmmm... An I use these settings now, but I select on a pic a wrong hyphenation. Good is fel-a-jánl-ko-zik. (here is hungarian hyphenation site: https://helyesiras.mta.hu/helyesiras/default/hyph)

 

 

Hyphenation jo.jpg

Share this post


Link to post
Share on other sites

Where do I need to put the hunspell dictionary files on OSX?

I have set up OSX with German, English US, English UK, English but still do not get US English in Affinity Designer, so I assume the languages are not taken from OSX but from somewhere else...

Share this post


Link to post
Share on other sites
5 hours ago, p10n said:

Where do I need to put the hunspell dictionary files on OSX?

I am fairly certain we can't use them on OSX. When you say "I have set up OSX with German, English US, English UK, English ..." do you mean in the OS System Preferences > Language and Region pane? That is the only way I know of to have multiple languages available.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites
6 minutes ago, Old Bruce said:

I am fairly certain we can't use them on OSX. When you say "I have set up OSX with German, English US, English UK, English ..." do you mean in the OS System Preferences > Language and Region pane? That is the only way I know of to have multiple languages available.

Yes exactly in that pane. I read somewhere that AD would automatically use the languages/dictionaries that are chosen here, but this does not seem to be the case currently...

Share this post


Link to post
Share on other sites
11 minutes ago, p10n said:

Yes exactly in that pane. I read somewhere that AD would automatically use the languages/dictionaries that are chosen here, but this does not seem to be the case currently...

Unfortunately, it is more complicated than that. Affinity comes with built-in support for 10 languages: UK English, US English, German, French, Spanish, Portuguese (Brazilian), Japanese, Italian, Chinese (Simplified), & Russian. You can set this to any of those languages or to the default system language in Affinity's Preferences > General.

In addition, the Character Studio panel offers separate choices for spelling, hyphenation, & 2 typography related options, which can be set separately for different text runs within each text block. But it seems that the Character Studio Spelling choice in the Mac versions depends in part on what language is set in Preferences > General, & is limited to a sub-set of the above in some way I don't understand, other than with my General preference set to US English I only get None, English (which is US English), & English (United Kingdom).

Wish I could be of more help with this (& understand it better for my own benefit, too). :(


Affinity Photo 1.7.1, Affinity Designer 1.7.1, Affinity Publisher 1.7.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.1.143 & Affinity Designer 1.7.1.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites

OK, thank you. Yes it looks weird!

I have now changed the UI language to US and back to German, and now when I choose "English" in the Characters panel, it seems to be applying US spelling rules ("optimize" is ok while "optimise" is underlined red). --> So, now I got what I wanted, but I don't know how it worked... :-)

Share this post


Link to post
Share on other sites

Hi. For me the hyphenation does not work. What am I doing wrong? Slovak language on osx

F13572A2-B5CD-4EDB-A6A5-B90A5D2F29D4.png

9B0C4666-122E-47DB-BEA1-19C144CB0BDC.png

BFB594CA-AF41-4161-9870-5E26CD9680B5.png

Share this post


Link to post
Share on other sites
11 hours ago, Jaro said:

For me the hyphenation does not work. What am I doing wrong? Slovak language on osx

Welcome to the Serif Affinity forums, Jaro.

  1. Have you enabled auto-hyphenation in the Paragraph Panel or in the Paragraph Style for the text that you want hyphenated?
  2. Have you set the hyphenation options (word length, etc.) in those same locations to appropriate values for your language?

Here's what it looks like in the Paragraph Panel. There are similar settings when editing Paragraph Styles.

image.png.d86b1f97c4f848724ab8c4ebea217141.png

 


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

When you look on the screenshots I provided, you could see auto-hypenation is checked to my language (Slovak/ Slovenčina), but words just do not break at the end of the lines...

hyphenation options  are set to the same values I use in InDesign

Share this post


Link to post
Share on other sites

Try, at least, these parametres:

hyph.png


Best regards,

Petar Petrenko
Typesetter, Graphic Designer, Photographer
Skopje, Makedonija

Windows 10 x64 Pro
Dell Inspiron 7559 i7
Intel Core i7-6700HQ (3.50 GHz, 6M )
16GB Dual Channel DDR3L 1600MHz (8GBx2)
1TB HDD + 128 GB SSD Hard drive
UHD (3840 x 2160) Truelife LED- Backlit Touch Display
NVIDIA GeForce GTX 960M 4GB GDDR5

Share this post


Link to post
Share on other sites

When I open the text style again after I set the hyphenation language, it is replaced by "No Change". I don't know if it is a bug or it should work like this.


Best regards,

Petar Petrenko
Typesetter, Graphic Designer, Photographer
Skopje, Makedonija

Windows 10 x64 Pro
Dell Inspiron 7559 i7
Intel Core i7-6700HQ (3.50 GHz, 6M )
16GB Dual Channel DDR3L 1600MHz (8GBx2)
1TB HDD + 128 GB SSD Hard drive
UHD (3840 x 2160) Truelife LED- Backlit Touch Display
NVIDIA GeForce GTX 960M 4GB GDDR5

Share this post


Link to post
Share on other sites
46 minutes ago, Jaro said:

When you look on the screenshots I provided, you could see auto-hypenation is checked to my language (Slovak/ Slovenčina), but words just do not break at the end of the lines..

Sorry, I missed that panel in your post.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

I added Russian hyphenation dictionary very easily BUT on Windows. I don't know how to do it on Mac, sorry.


Best regards,

Petar Petrenko
Typesetter, Graphic Designer, Photographer
Skopje, Makedonija

Windows 10 x64 Pro
Dell Inspiron 7559 i7
Intel Core i7-6700HQ (3.50 GHz, 6M )
16GB Dual Channel DDR3L 1600MHz (8GBx2)
1TB HDD + 128 GB SSD Hard drive
UHD (3840 x 2160) Truelife LED- Backlit Touch Display
NVIDIA GeForce GTX 960M 4GB GDDR5

Share this post


Link to post
Share on other sites

Anybody who was able to install hyphenation (out of the default languages installed) on MAC?

Share this post


Link to post
Share on other sites

Did you also tried with setting the Score to 1, as they told there?


☛ Affinity Designer 1.7.1 ◆ Affinity Photo 1.7.1 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×