Jump to content
Mark Ingram

Affinity Designer Public Beta (RC3) - 1.5.0.27 (Windows)

Recommended Posts

Click here to download the latest beta

 

Status: Release Candidate 3

Purpose: Stability

Requirements: None

 

As this is a beta release, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is worth noting that files created in Affinity Designer 1.5 cannot be opened in Affinity Photo 1.4, which means that although files created with the Windows beta can be opened in the Mac AppStore version of Designer (currently on 1.5.1) they cannot be opened in the latest Mac App Store versions Affinity Photo, instead you will need the latest macOS 1.5 beta.

 

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.
 
If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

 

Fixes

 

  • Fixed Clone Brush tool toast message saying |TERTIARY| instead of ALT
  • Fixed Export Persona Revert to Auto Sized (and it's indicator) being broken on resize
  • Fixed Export Persona Slice Presets not updating on remove
  • Fixed Global colour not being recoloured using sliders
  • Fixed Noise slider/Colour Wheel being slow when adjusting swatch fill
  • Fixed Ctrl runup not resetting the marquee Mode
  • Changed Export Slices 'Select Folder' button name to 'Export'
  • Fixed Toggling 'Show Grid' with Ctrl + ' not toggling the checkbox in the Grid and Snapping Axis Manager
  • Fixed Reset Selection Box not updating the values in the Transform Panel
  • Fixed Hex colour codes not copied to the clipboard correctly
  • Fixed Text Styles: 'Show in both panels' option not remaining enabled/applied
  • Fixed keyboard preferences, changing Persona doesn't update category
  • Fixed clicking 'Reset' in the Preferences, keyboard Shortcuts only works per session
  • Fixed being unable to select a font by typing more than the first character
  • Fixed Export Persona Layers Panel 'Make item visible in export' option not hiding the page
  • Fixed floating panels getting resizing incorrectly
  • Fixed Character Panel resizing incorrectly
  • Fixed Character and Paragraph panels becoming stretched after starting app with panels open
  • Fixed switching Persona's when you have floating docked panels causes minor UI problems
  • Fixed Selection Brush size can't be bigger than 1024 px
  • Fixed Export Persona 'Export Slices' button doesn't disable/enable until selection changes
  • Improved 32bit support (now has a dedicated 32bit colour profile)
  • Fixed crash when using Refine Selection, New Layer with Mask on a Vector Cropped object
  • Fixed some font names not displaying correctly (e.g. Pe-icon-7-stroke)
  • Fixed missing string for OCIO Adjustment name in Layer menu
     

Share this post


Link to post
Share on other sites

Paragraph styling is broken.

Pressing a line braking Enter in any paragraph that has a style applied, automatically switches back to [No Style]

 

And im automatically switching back to .26 :)

Share this post


Link to post
Share on other sites

Hey Highvoltage,

 

What do you have set as the next style in the Edit Text Style settings? Are you pressing Shift+Enter?

 

We'd like to encourage you to stay on the current beta if possible as this is the very purpose of having a beta. You might not find current issues or may report fixed issues if you go back - This is of course your choice, though.

Thanks

Share this post


Link to post
Share on other sites

Hey Highvoltage,

 

What do you have set as the next style in the Edit Text Style settings? Are you pressing Shift+Enter?

 

We'd like to encourage you to stay on the current beta if possible as this is the very purpose of having a beta. You might not find current issues or may report fixed issues if you go back - This is of course your choice, though.

 

Thanks

 

Next style is Same style.

 

Attached a file. Just press enter anywhere.

It even reverts to no style when you just want to continue typing at the end fo line

BUG - paragraph.afdesign

Share this post


Link to post
Share on other sites

Next style is Same style.

 

Attached a file. Just press enter anywhere.

It even reverts to no style when you just want to continue typing at the end fo line

Thanks. Reproduced and logged with development. 

Share this post


Link to post
Share on other sites

Here are all of the files in the folder

 

Thanks for that. It looks like you have an ICC profile installed which is causing problems. I think I can fix the problem, but it would be useful if you could identify which profile is causing the crash, and send it over? That way we can verify the fix.

Share this post


Link to post
Share on other sites

Thanks for the new build! I'm experiencing very slow text input now, but can't remember if it was present in the build before.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Thank You for the new build.

I noticed that in the case if one of the layers is locked, one can still select it and f.eg. just draw any elements on it which seems to be a bug.

Share this post


Link to post
Share on other sites

Today I was writing some text in polish langauge into AD.

Every program is set that right ALT is modifer to set up a specific letter, in polish these are: ą, ę, ć, ź, ż, ł, ó and we can get it by combine as follows: alt + a, alt + e, alt + c, alt + x, alt + z, alt + l, alt + o.

But in AD clicking each combination we end up in menu, eg. alt + e = edit menu, alt + l = layer menu, etc. And this should only perform left ALT :)

Hope its help you a bit ;)

Share this post


Link to post
Share on other sites

Today I was writing some text in polish langauge into AD.

Every program is set that right ALT is modifer to set up a specific letter, in polish these are: ą, ę, ć, ź, ż, ł, ó and we can get it by combine as follows: alt + a, alt + e, alt + c, alt + x, alt + z, alt + l, alt + o.

But in AD clicking each combination we end up in menu, eg. alt + e = edit menu, alt + l = layer menu, etc. And this should only perform left ALT :)

Hope its help you a bit ;)

 

Hi, thanks for the report. I'm sure it used to work this way in previous versions - I'll have a look if someone has changed.

Share this post


Link to post
Share on other sites

I am getting the same problem as Depcore.  I installed RC3 this morning and Designer will not boot, same error code:

 

Unhandled Exception

An Unhandled Exception has occurred and the application cannot continue.

The Crash Reference dialog will be displayed when the application is restarted.

Code: 0x80004003

 

Noting your response, I have attached the zipped CrashReports.

 

CrashReports.zip


Affinity Photo (1.7.3.481 & Beta 1.8.0.486); Sketchup

Windows 10 Pro, 64-bit; Ver. 1909 (OS Build 18363.476);

Intel i7-4790, 4 GHz; 16GB; Asus R9 280.

Share this post


Link to post
Share on other sites

I am getting the same problem as Depcore.  

 

Thanks for the crash reports, I've had a look and yes, it's exactly the same crash as Depcore. I've put a fix in place for the next release, but it would be really useful if we could identify the ICC profile that is causing the problem. Can you get a list of ICC profiles that are installed on your system? What about if you go to "Colour Management" in Windows and see what your current profile is set to?

Share this post


Link to post
Share on other sites

Being a photographer there are a lot but will do as you ask.


Affinity Photo (1.7.3.481 & Beta 1.8.0.486); Sketchup

Windows 10 Pro, 64-bit; Ver. 1909 (OS Build 18363.476);

Intel i7-4790, 4 GHz; 16GB; Asus R9 280.

Share this post


Link to post
Share on other sites

Hi, thanks for the report. I'm sure it used to work this way in previous versions - I'll have a look if someone has changed.

Mark, 

I am not so sure. I usually did not use Polish diacritical signs on whatever graphics created but ALT did not work in the previous versions.

Share this post


Link to post
Share on other sites

My monitor color profile is "dell u2410 color profile, D6500", "U2410.icm" 

Default device color profile is "sRGB IEC61966-2.1" if this helps


code and design studio www.depcore.pl

Share this post


Link to post
Share on other sites

Thanks for the crash reports, I've had a look and yes, it's exactly the same crash as Depcore. I've put a fix in place for the next release, but it would be really useful if we could identify the ICC profile that is causing the problem. Can you get a list of ICC profiles that are installed on your system? What about if you go to "Colour Management" in Windows and see what your current profile is set to?

 

Hi Mark,

 

Attached screen copies of requested files, let me know if I can help further.

 

Regards

AD Profiles.zip


Affinity Photo (1.7.3.481 & Beta 1.8.0.486); Sketchup

Windows 10 Pro, 64-bit; Ver. 1909 (OS Build 18363.476);

Intel i7-4790, 4 GHz; 16GB; Asus R9 280.

Share this post


Link to post
Share on other sites

Hers how to list all the ICC profiles via command prompt

 

menu start cmd,

in the command line

cd  c:\windows\system32\spool\drivers\color

 

then

 

dir *.* >> icc.txt

 

This will save the directory listing to the file called icc.txt (if there's a problem run this in the admin console)

icc.txt


code and design studio www.depcore.pl

Share this post


Link to post
Share on other sites

I've checked the reports, and they are the same crashes as Depcore, and Woodkopf. Again, if you could list any ICC profiles you have installed, that would be super helpful. There will be a fix available in the next release.

 

Here's the list of my ICC Profiles.

I've highlighted the profile of my display.

 

post-39657-0-21446400-1477482873_thumb.png

Share this post


Link to post
Share on other sites

Ahhh yeah! With RC3, the countdown to the full launch of the Windows version for Affinity Designer nears its conclusion! Business is about to pick up!  :D

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.