Jump to content
Andy Somerfield

Affinity Photo Customer Beta (1.5 - Beta 6)

Recommended Posts

As always, it is probably me but help with these two queries would be really appreciated.

 

Firstly, on the Beta, Macros will not record although the included library items do run. Secondly. a simple click and selection of a layer brings up a small dialogue. Can I turn it off and revert to the simple click and select that I am so used to?

 

Apologies if these questions are trivial and have been answered before but I really want to get into the Beta and are a little frustrated as Affinity Photo (1.4) is presently a wonderful program that I use all the time.

Thanks

Share this post


Link to post
Share on other sites

Hi demimaderek,

Welcome to Affinity Forums :)

Are you sure they are not recording? Currently the record button doesn't give any feedback (if it's on or not) but it should be recording. Have you tried to perform a few actions? They should appear listed in the Macros panel as you record them.

Regarding the small dialogue: can you please take a screenshot of it or write its contents here? I'm not sure what this could be...

Share this post


Link to post
Share on other sites

Dear MEB

 

Many thanks for the reply.

 

In regard to the recording of a macro that is probably the answer. Thanks

 

In regard to the clicking on a layer to say duplicate it that seems to be ok now that I have reloaded program. However, when it did produce the dialogue it was a small box with various options to select a layer - above below etc.. Perhaps I turned on something I did not need.

 

Anyway thanks again for your help and the great work you are all doing.

Share this post


Link to post
Share on other sites

Dear MEB

 

The dialogue box appears when I am trying to record a macro. It selects a layer but will not duplicate it etc.. Sometimes there is a note appearing saying macro cannot record action but I though duplication was a pretty basic operation. I do not know if this screen shot will help? Probably it is all down to me not getting things right.

 

Again thanks for all you do

 

 

 

 

Share this post


Link to post
Share on other sites

Hi demimaderek,

Thanks for the additional info. That dialog is expected and its related with the macros/recording as you discovered.

Note that not all actions can be recorded at this point. This is a feature that's still being worked on/implemented in the Beta so some things may not work yet as expected.

 

You're welcome  ^_^

Share this post


Link to post
Share on other sites

I'm not sure about running them from the command line...

But I would look into integrating Automator workflows with Affinity. I haven't tried it but might be possible since Serif uses so many native MacOS technologies...

 

 

Yeah probably. <_<  Automator is very cumbersome though for that sort of thing and that workflow breaks a lot since you have to do extra scripts to invoke an Automator task. It's not reliable at all when you have hundreds of files to process. Then it jams and throws errors you can't catch when you're not in front of the screen and you end up with a bunch of files in a sequence not being processed. 

 

It'd be great to be able to tie the Affinity Engine into workflows that span multiple apps. That way you could have a FileOut node from one app, attach a script that routes the image/frame through Affinity, upon new file creation the FileIn node picks up the new file/frame and can process it further. That rarely fails and when it does, the process quits for good and you have a decent error log most of the time.

Share this post


Link to post
Share on other sites

Yeah I see what you mean... it sounds like a GREAT feature for the forth-coming Affinity DAM app... Batch processing, scripting, and macro functionality logically resides in a DAM app much more than in individual apps like AD, AP or APub, although obviously all apps ought to support such backend hooks for mass processing of files and assets... This might be something to post in the Feature Requests forum...

 

Yeah probably. <_<  Automator is very cumbersome though for that sort of thing and that workflow breaks a lot since you have to do extra scripts to invoke an Automator task. It's not reliable at all when you have hundreds of files to process. Then it jams and throws errors you can't catch when you're not in front of the screen and you end up with a bunch of files in a sequence not being processed. 

 

It'd be great to be able to tie the Affinity Engine into workflows that span multiple apps. That way you could have a FileOut node from one app, attach a script that routes the image/frame through Affinity, upon new file creation the FileIn node picks up the new file/frame and can process it further. That rarely fails and when it does, the process quits for good and you have a decent error log most of the time.


2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS High Sierra

Share this post


Link to post
Share on other sites

Yeah probably. <_<  Automator is very cumbersome though for that sort of thing and that workflow breaks a lot since you have to do extra scripts to invoke an Automator task. It's not reliable at all when you have hundreds of files to process. Then it jams and throws errors you can't catch when you're not in front of the screen and you end up with a bunch of files in a sequence not being processed. 

 

It'd be great to be able to tie the Affinity Engine into workflows that span multiple apps. That way you could have a FileOut node from one app, attach a script that routes the image/frame through Affinity, upon new file creation the FileIn node picks up the new file/frame and can process it further. That rarely fails and when it does, the process quits for good and you have a decent error log most of the time.

 

 

AndyS in an old post told us that Affinity engine relies on a node-based paradigm, and added that they could expose this in the future... 

Well... I don't know what you think, but the very best place where I'd love to find a node-ui is a DAM environment.


The white dog, making tools for artists, illustrators and doodlers

Share this post


Link to post
Share on other sites

Thank you guys for this beta. It just goes on getting better!

 

One request. When the polygonal lasso is implemented can we please have an open curve? The closed lasso can get confusing and drives me up up the wall sometimes!! Just my little two cents worth .........  ;)

 

Yes, please keep the open curve


------------------------

Fernando Velarde

www.velarde.com

Share this post


Link to post
Share on other sites

Nevermind this post I think I got it to work except for the part about the pointer tool not turning into the selected tool when clicked on. I successfully got the tool to function though although I am not very good at using it.

 

Old post: It looks like the patch tool isn't working for me. When I click on the tool it still remains a pointer. I can draw around an item but then I can't do anything to select to the new area that I want to sample from. I don't think this is a user error because it seems like I have tried this tool before in Affinity.

Edited by KipV

Share this post


Link to post
Share on other sites

There is a bug when mixing CMYK color for new pixel layer. Editing CMYK values by keyboard and moving with TAB key between fields always results 0 in the field, result is always gray (not 0-0-0-0 as displayed), not 95-84-3-70 as intended :-/

See attached video

 

Editing color for rectangle layer works fine.

color-mixing-bug.mov

Share this post


Link to post
Share on other sites

Ok thanks! Meanwhile, congrats for Designer, I completely switched to it from AI CC. Maybe something missing but much more intuitive and productive...


Unmanned Systems Manager with passion for UX and UI

 

Apple user since 1988

Share this post


Link to post
Share on other sites

This may have been noted already in which case apologies but I just noticed that APB.6 is still having issues with lens metadata on NEF files.  This is a non cpu lens on a D7000 but displays are fine in AP1.42

 

post-6559-0-82271000-1476666591_thumb.png post-6559-0-45215800-1476666564_thumb.png AP1.4.2 post-6559-0-40108200-1476667246_thumb.png

 

Share this post


Link to post
Share on other sites

OCIO Bug: Transforms are persistent even when converted to 16-Bit.

 

Steps:

 

  1. Take any image, convert it to 32-Bit.
  2. Set the Display Transform to any OCIO Transform
  3. Convert to 16-Bit
  4. Now the transform sticks and can't be edited unless you go back to 32-Bit
  5. Paste something from another file or place a file
  6. Colours seem to get a gamma reversal of their own gamma values. They look washed out.

 

Expectation: OCIO should either remain editable or exit to regular ICC when going from 32-Bit to 16-Bit or below.

Share this post


Link to post
Share on other sites

Batch job settings

 

It would be nice if Affinity Photo would remember custom batch job settings, at least the rendering setting (nearest neighbor method may not be always the most wanted option) as well as the output file type. Also, it would be great to be able to save custom batch job settings, including output image sizes and more.

Share this post


Link to post
Share on other sites

Batch job settings

 

It would be nice if Affinity Photo would remember custom batch job settings, at least the rendering setting (nearest neighbor method may not be always the most wanted option) as well as the output file type. Also, it would be great to be able to save custom batch job settings, including output image sizes and more.

Totally agree. Is batch renaming operational in the latest beta? 

Share this post


Link to post
Share on other sites

Incase it was not seen previously, or just was not done for this beta, I will repost here some bugs from my previous thread.

---

All of these are in reference to the sources panel:

-No progress bar when switching images in the source panel when "toggle source preview" button is enabled

 

-When "toggle source preview" is not enabled, a newly selected source will not load until the mouse cursor hovers over the canvas

 

-Selected sources will not load unless a layer is selected. 

 

-Source image will not show on screen when "toggle source preview" is enabled unless a layer is selected

 

Also, for the patch tool it breaks when using the transform function on it. 

-Create a patch and click to set area. Then shrink the patch size with the transform handles. Deselect and then create a new patch. The new patch will be scaled based on the previous image. Often times the transform handles will be smaller than the size of the patch and are unselectable. 

 

 

 

really looking forward to knowledgable people reporting on the progress of focus stacking, I think I already heard that it was superior to PS?

It certainly is, by a very large margin. It is faster, produces a better output, and you can easily retouch from your input frames.(in photoshop, it is basically impossible to retouch from the input frames...so theres that...;) )

Share this post


Link to post
Share on other sites

I also forgot to mention from my previous post about a possible memory leak which I mentioned in the other thread, when closing documents. 

 

I was just doing some tests again and here is what I found(see the other thread for my previous numbers)

 

For me, a fresh start of APB6 launches using about 100mb of ram. 

-After performing 3 focus stacks, closing the previous document in between, APB6 used 6.8gb of ram with no document open.

-Then I performed a panorama, saved, and closed the document. APB6 was then using 7.44gb ram

-I did one final panorama, saved and closed the document. APB6 used 8.07gb ram.

 

So as I said in the other thread, either this is just an appearance of ram usage from how OSX wires memory, or there maybe a memory leak related to closing documents.

 

Hope this helps. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×