Jump to content
woosaj

Huge performance issues on macOS Sierra - AD

Recommended Posts

Hello, I have huge problems, i just installed fresh version of macOS Sierra and performance is very poor (more details in video) in Affinity Designer, are there any options to fix this issues?

 

My specs are:

 

MacBook Pro (Retina, 13-inch, Late 2013)

CPU: 2,4 GHz Intel Core i5

MEMORY: 8 GB 1600 MHz DDR3

GRAPHICS: Intel Iris 1536 MB

 

 

test.mov

Share this post


Link to post
Share on other sites

Ok I just downloaded latest Beta version and performance is way better, so I'll be using beta version until you fix this issue.

 

EDIT:

 

After 10 mins I got same laggy response in Beta after moving object arounds. I'm going back to El Capitan :)

Share this post


Link to post
Share on other sites

Hi woosaj,

 

Sorry to hear you're having trouble with Sierra. Have you gone back to El Capitan? Have you noticed a performance increase in doing so?

 

We've logged a few unique issues against Sierra however I don't believe any of them have been related to performance. We have one logged against selection boxes flashing when dragging but this was a Sierra issue which I believe was fixed by a recent update.

 

Cheers

Share this post


Link to post
Share on other sites

Hi woosaj,

 

Sorry to hear you're having trouble with Sierra. Have you gone back to El Capitan? Have you noticed a performance increase in doing so?

 

We've logged a few unique issues against Sierra however I don't believe any of them have been related to performance. We have one logged against selection boxes flashing when dragging but this was a Sierra issue which I believe was fixed by a recent update.

 

Cheers

 

Recent update, you mean, of Sierra? I think only the GM has been released.

 

I get plenty of flashing and my selection boxes often disappear while an object is still selected.

This is very annoying.

 

Retina 5K iMac, running mac OS 10.12

 

post-12118-0-37069000-1477068796_thumb.png


mfsignature.jpg

Share this post


Link to post
Share on other sites

I get plenty of flashing and my selection boxes often disappear while an object is still selected.

This is very annoying.

 

Maybe this helps you to avoid the problem till the next Sierra release. Had the same problem, till I changed the color profile.

Share this post


Link to post
Share on other sites

I'm very disappointed to have just downloaded the latest beta, and I'm having laggy problems with Sierra, too. The white arrow will suddenly just stop selecting my points, or even make them appear, so I can't do anything with them. Very frustrating. Is there some way I can fix this? 

Share this post


Link to post
Share on other sites

I'm very disappointed to have just downloaded the latest beta, and I'm having laggy problems with Sierra, too. The white arrow will suddenly just stop selecting my points, or even make them appear, so I can't do anything with them. Very frustrating. Is there some way I can fix this? 

Have you made the latest update to macOS 10.12.1? The problems should be gone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.