Jump to content
preahkumpii

Khmer script rendering incorrectly in AP/AD

Recommended Posts

Hello there,

 

I want to report a potential bug in the rendering of Khmer script in AP/AD.

 

Using some Khmer fonts, AP/AD render the text incorrectly. Using other fonts, AP/AD render the text correctly.

 

The example below is taken from a screen grab on MacOS in Affinity Photo using an offending font.

incorrectly-rendered-in-ap.png

 

This screen grab is the same font in Pages on MacOS. It renders correctly:

correctly-rendered.png

 

This screen grab is a different Khmer font in Affinity Photo, which renders correctly.

correctly-rendered-in-ap.png

 

Lastly, here are both fonts, both the one that renders incorrectly, and another that renders correctly:

 

http://preahkumpii.com/preahkumpii/misc/ap-khmer-issue/renders-incorrectly-in-ap.ttf

http://preahkumpii.com/preahkumpii/misc/ap-khmer-issue/renders-correctly-in-ap.ttf

 

Thanks for your help in looking into this issue.

 

Adam

post-5078-0-40682700-1475325152_thumb.png

post-5078-0-84882800-1475325165_thumb.png

post-5078-0-05718800-1475325183_thumb.png

Share this post


Link to post
Share on other sites

Hey Adam,

 

It looks like we have had a similar issue with this reported a while back. I have bumped the bug report to see if we can get some movement on it.

Thanks for your time.

Share this post


Link to post
Share on other sites

Hey Adam,

 

It looks like we have had a similar issue with this reported a while back. I have bumped the bug report to see if we can get some movement on it.

 

Thanks for your time.

 

Thank you for your work on it.

Share this post


Link to post
Share on other sites

I was curious if this problem has been identified and corrected in the up-and-coming versions of AP/AD.

 

Also, I found out more information about this font rendering issue. I tried out some tests with these fonts in a web environment with various browsers. I discovered that on MacOS every browser (Chrome, Opera, and Firefox) renders the text with these fonts correctly—except Safari. I'm not sure what this means exactly. Maybe Safari is using the same rendering engine as the OS, and the other browsers are not.

 

For me, this is a big problem with MacOS in general because I use Khmer script so frequently.

 

I do appreciate the work you guys put into making this better.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×