Jump to content
Highvoltage

1px Stroke with pen tool displaying as 2px aliased

Recommended Posts

Hi Highvoltage,

The line is probably placed between two pixel rows. Affinity draws the stroke centered so you have each half filling one pixel row thus it's not pixel aligned.

You can check this enabling the grid and setting it up so it shows the pixel grid (Spacing: 10px, Divisions: 10 for example).

Share this post


Link to post
Share on other sites

Yes, it's true, but this is not acceptable when designing for screen.

You mean i have to manually edit the line and add a 0.5px offset every single time? And if i move the whole block, do it again?

 

In fireworks lines always snapped to half pixels. Or at least there was an option.

 

An elegant solution could be located at the Stroke/Align options.

Maybe if i set it to align outside or inside it could snap to half pixels like it does when you draw a recrangle for example.

And only snaps to whole pixel if centered .

Share this post


Link to post
Share on other sites

Yes, it's true, but this is not acceptable when designing for screen.

You mean i have to manually edit the line and add a 0.5px offset every single time? And if i move the whole block, do it again?

 

In fireworks lines always snapped to half pixels. Or at least there was an option.

 

An elegant solution could be located at the Stroke/Align options.

Maybe if i set it to align outside or inside it could snap to half pixels like it does when you draw a recrangle for example.

And only snaps to whole pixel if centered .

 

 

We are adding a snap to 0.5px so this should help soon.

Share this post


Link to post
Share on other sites

Hi Highvoltage,

Set the following settings to align/snap to both pixels and half pixels simultaneously:

 

In View ▸ Grid and Axis Manager...

- enable Use automatic grid

 

In View ▸ Snapping Manager...

- make sure Snap to grid is checked

- disable Force pixel alignment

 

Also enable the grid (menu View ▸ Show Grid).

 

Draw a rectangle or a path. You should be able to start/snap to both whole pixels and half pixels now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×