Jump to content
sinbad

Non-destructive Add problem in AD 1.4.2

Recommended Posts

I recently bought AD and have v1.4.2. I'm following the tutorials but the Non-destructive Add step in the Beginners Too video doesn't work as it should. Clicking Add without holding Alt works as expected, but holding Alt results in a corrupted shape. I recorded a gif to demonstrate:

 

post-36455-0-60950900-1473347344_thumb.gif

 

Seems like a bug to me, both shapes are created exactly as in the tutorial.

Share this post


Link to post
Share on other sites

Hi sinbad,

This is due to a bug with smart nodes in Affinity. To work around this and continue the tutorial do the following:

Select all the nodes of the main shape (the bigger one) dragging a marquee selection around them all with the Node Tool and convert them to Smooth nodes, clicking on the Smooth icon from the Convert section in the context toolbar. Then perform the non-destructive boolean operation as indicated in the tutorial. It should work correctly.

Let me know if you still have trouble.

Share this post


Link to post
Share on other sites

That works, thanks. It's a bit awkward though especially as the smart tool is so convenient, presumably this is going to be fixed in a future update?

Share this post


Link to post
Share on other sites

Hi @MEB and @sinbad 

 

On 08/09/2016 at 5:10 PM, MEB said:

Hi sinbad,

This is due to a bug with smart nodes in Affinity. To work around this and continue the tutorial do the following:

Select all the nodes of the main shape (the bigger one) dragging a marquee selection around them all with the Node Tool and convert them to Smooth nodes, clicking on the Smooth icon from the Convert section in the context toolbar. Then perform the non-destructive boolean operation as indicated in the tutorial. It should work correctly.

Let me know if you still have trouble.

 

Looks like we still have the same issue peeps.

 

I was doing the same thing as Sinbad but for AD 1.6.1 Beta: That's December 2017 ... oh merry Christmas and a happy new year by the way :-D

 

I have the same issue so I am glad I found Sinbad's report so we can at least keep these related issues together.

 

I was following the beginners tutorial as Sinbad was and came up with the same issue .... Yes using the work around worked;  that is, converting the nodes to Smooth nodes did work. Indeed a bit awkward and you wouldn't twig the solution by intuition either.

 

However, still a bug?

 

I'm happy to share files with full history saved if it helps.

 

Regards

Reggie

 

 

smart_nodes_issue_AD_1_6_1_beta.thumb.png.aad8f53a310d29a3405215ed6275243f.png


Please don't mistake my opinion for expert comment :) for no way no how am I an expert on anything. However I am curious and willing to learn. 

 

Affinity Photo (latest I promise)

Affinity Photo Beta (I have a lot of time on my hands)

Affinity Designer (Also the latest; promise)

Affinity Designer Beta (Because I like new things)

I need to get out more - Yes :)

Share this post


Link to post
Share on other sites

@MEB Wow quick response :-D

 

No probs MEB as long as it's still logged. I feared it might have been a fix that has over time been unfixed by such things as the magic of software configuration management or some such machination of software development ... yep been there .... small team and a zillion demands with prioritisation always keeping lower impact issues under the radar. 

You are doing a great job, thank you.


Please don't mistake my opinion for expert comment :) for no way no how am I an expert on anything. However I am curious and willing to learn. 

 

Affinity Photo (latest I promise)

Affinity Photo Beta (I have a lot of time on my hands)

Affinity Designer (Also the latest; promise)

Affinity Designer Beta (Because I like new things)

I need to get out more - Yes :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×