Jump to content
Sign in to follow this  
JerryLin

Ghost line & Export area can't match the object.

Recommended Posts

I found a ___ bugs.

It all found from 1.4.2 and also in Beta 12.

 

1.Ghost Line

 

 

if it just only show the white line in AD, it's great! (help me know there is no outline)

But, it also keep the white line in export file, whatever it's svg or jpg.

http://imgur.com/tIQ6QIE

 

 

2.Export area can't match the object.

My all objects are 50x50

http://imgur.com/ppAOkDM

 

but use auto slice will...

http://imgur.com/H7swSZP

 

It also come with Artboard, like 1024x768 will give me 1025x768.

http://imgur.com/Lbt4yH8

 

And, thanks for your work, I really love Affinity!!!

Share this post


Link to post
Share on other sites

Hi JerryLin,

Welcome to Affinity Forums :)

Can you please upload the .afdesign file so we can check this out?

If you don't want to post it publicly you can PM me the link or use this one to upload it directly to my Dropbox account.

All files will be deleted after being inspected.

Thanks.

Share this post


Link to post
Share on other sites

Hi JerryLin,

Thanks for the file.

The "ghost lines" are a side effect of the way Affinity and other software renders objects on screen when their edges overlap. Please take a look at MattP's post for more details.

To work around this you can place a rectangle with a colour (gradient) similar to the foreground just to hide the "hairlines". Alternatively you can also add a thin stroke to each one of the bands with the same colour as the fill to hide them.

 

Regarding the slices, the coordinates (X,Y) of each rectangle below the number/symbol of the calculator (and eventually other elements in your design) for example are not integer values. The iPhone artboard coordinates (X,Y) also presents same issue (Y=178.5px). You can check this in the Transform panel on the bottom right of the interface. That's is why the slices generated automatically don't have the correct sizes. You must ensure their coordinates and dimensions all use integer values. When creating UI projects make sure you have Force Pixel Alignment enabled in the Snapping Manager (menu View ▸ Snapping Manager...) to avoid those problems. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×