Jump to content
jackamus

Saving files

Recommended Posts

Everytime I try to save a file I'm told the 'Save failed' it is asking me if it already exists and marked read only?

 

What is going on?


Mac OS X El Capitan Version 10.11.6

AD version 1.6.0

Share this post


Link to post
Share on other sites

Some users have reported similar problems. Can you detail in which circumstances is this happening?

Creating and saving new files, saving previously created files... in which folders (local, network), operating system and version you're using (beta, retail)...

 

[EDIT] You've reported this previously. Have you tried the latest beta (1.0.19988)? Does the problem still persist?

Share this post


Link to post
Share on other sites

I purchased Affinity Designer from the Apple App Store today, and am unable to save files. I have run Disk Utility and repaired permissions (twice), and restarted with no luck. I have tried saving a new file to the desktop (fails to save), to a document folder (fails to save), copied and pasted artwork from one document to a new one (fails to save). Each time I get the error message "Failed to save document. Save failed because the file could not be created. Does the file already exist and is marked as read only?" 

 

I've been working in the same document folder all day, saving files from Adobe Illustrator without issue, so this is an inexplicable — and frustrating — glitch.

 

Please let me know how to resolve this issue.

 

Best,
Clint

Share this post


Link to post
Share on other sites

Hi Clint,

 

Are you running OS X 10.7.x by any chance? You need at least 10.7.5. I'm sure we can get to the bottom of this, just need to know a few things about your system first :)

 

Thanks!

Matt

Share this post


Link to post
Share on other sites

Hi Clint,

 

Are you running OS X 10.7.x by any chance? You need at least 10.7.5. I'm sure we can get to the bottom of this, just need to know a few things about your system first :)

 

Thanks!

Matt

Hi, I'm running 10.9.5.

 

Today I downloaded the new beta (01/03/2015) and it opens and saves files without a problem. The issue mentioned above seems specific to the App Store version. Is there any way to install your software (ie non-beta releases) without using the App Store? I'm thinking there might be some sandboxing issue with the App Store version that is preventing me from saving files.

 

Best,
Clint

Share this post


Link to post
Share on other sites

 

I purchased Affinity Designer from the Apple App Store today, and am unable to save files. I have run Disk Utility and repaired permissions (twice), and restarted with no luck. I have tried saving a new file to the desktop (fails to save), to a document folder (fails to save), copied and pasted artwork from one document to a new one (fails to save). Each time I get the error message "Failed to save document. Save failed because the file could not be created. Does the file already exist and is marked as read only?" 

 

I've been working in the same document folder all day, saving files from Adobe Illustrator without issue, so this is an inexplicable — and frustrating — glitch.

 

Please let me know how to resolve this issue.

 

Best,
Clint

 

 

 

Hi Clint,

 

With the Mac App Store version can you try saving to your Picture folder and let me know if it succeeds or not? What is the error message that you get?

 

Thanks.

Share this post


Link to post
Share on other sites

I'm also getting issues with saves. First it says the file has errors and it can't save the file and then promptly closes the file without saving - which is annoying because you can copy everything and paste it into a new file. Then if I try to open the file again, it tells me it can't open the file because it's in use by another application (which it isn't). Then if I quit AD and then open the file, it opens it but gives me the the error message, 'Your file has errors. It was possible to open it, but you are advised to take a copy of this file and report this error.'

 

This has happened twice working with grouped groups - only in a specific file and with a specific set of graphics created in the file. There are also some photos in the file - but otherwise there's nothing there that would suggest the file should be all hinky.

 

2016 iMac, latest system, latest version of AD.

Share this post


Link to post
Share on other sites

Had another problem with Saving a file, "Save failed because the file was missing data required to build the document. Please contact the development team immediately.

The document must now be closed."

 

This was a different file from yesterday. I am assuming on of the elements in the file is corrupt and brings the same problems with it from one file to the next.

 

This is bad. I keep losing work when this happens. It's never happened before. What's going on?

Share this post


Link to post
Share on other sites

Yeah - it turns out it was a specific element that contained errors that was causing this. I exported the problematic element to an SVG, deleted the original and brought the SVG back in. Now the files save without issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.