Jump to content
ronnyb

[Fixed] BUG: Incorrect behavior while editing Layer names

Recommended Posts

When renaming Layers, AD ignores standard MacOS text editing conventions, mainly, passing Opt key + Forward or Back Arrows should move the cursor to the next or previous word, respectively. What seems to happen now is that AD's Kerning command intercepts the keystroke and attempts to increase or decrease letterspacing, which of course is an irrelevant behavior for renaming a Layer. Interestingly, Cmd + Forward or Back Arrows works as expected, taking the cursor to the end or beginning of the line, respectively.

 

Basically, all text editing behavior within the UI should respect MacOS keyboard equivalents. Editing text inside container or blocks should respect AD or the user's custom keyboard equivalents.

 

Thanks for all the hard work; the latest betas are coming along VERY nicely!


2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS High Sierra

Share this post


Link to post
Share on other sites

Hi ronnyb,

 

Interestingly, if you create a layer yourself it works fine. If I start a new doc and drop a shape and rename the layer with the shape on, I get the behaviour you describe. I'll get this logged for you.

Thanks :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×