Jump to content

Recommended Posts

A contributor to the Apple Discussion forums has discovered a problem with five of the fonts included with the OS X 10.11 (El Capitan) distribution. They are:

 

Athelas.ttc
Charter.ttc
Marion.ttc
Seravek.ttc
SuperClarendon.ttc

 

The problem is each of them is in the Library/Fonts folder, but none of them appear in Font Book or in font lists like in Affinity. This apparently is caused by an error Apple made in how the "SIP" (System Integrity Protection) feature, new in El Capitan, determines if these fonts are safe to use.

 

Each font installed with EL Capitan has two name matched files in an obscure System/Library folder (at path /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Resources/FontInfo). In some undetermined way SIP uses these files for this, & for these five fonts the files apparently were not updated correctly for El Capitan. The result is the OS will not allow any app to access them.

 

The Apple forum contributor has suggested two ways to fix this, both of which require disabling SIP, at least temporarily. They are:

 

1. Rename these five fonts in the Library/Fonts folder. It does not matter how they are renamed; for example just changing Athelas.ttc to Athelas1.ttc will work. This somehow causes SIP to see these files as different from the ones in the FontsInfo folder, & to consider them the same as files users can install in the Library/Fonts folder.

 

2. Delete the two name matched files in the FontsInfo folder for each of the five fonts. For example, for the Athelas font, you would delete the .ATSD and .fontinfo files whose names begin with "Athelas.ttc"

 

I am not keen on the idea of disabling SIP, so I came up with another slightly more complicated way to do this that does not require that:

 

1. Use Finder's duplicate command to duplicate each of the five files in place in the Library/Fonts folder. For example, this will produce an "Athelas copy.ttc" file.

 

2. In Finder, move each of the original files to the Trash.

 

3a. Using Get Info or a Terminal command, change permissions on each of these files in the Trash to give your admin user account read/write privileges.

 

3b. Use "delete immediately" to delete these files from the Trash.

 

3c. Restart your Mac.

 

I am not sure steps 3a & 3b are necessary, or even if step 2 is. It may be enough to duplicate the files in place in Library/Fonts, but I have only tested the above procedure.

 

Disclaimer: This is presented as is, with no guarantees that it will not cause some undiscovered problems with your system. It has not with mine, but if you want to try it, I strongly suggest you back up everything beforehand, ideally to a bootable clone, so that if anything goes wrong you can restore the system to its former state quickly & easily.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.