Jump to content
Sign in to follow this  
Marcus L

Is there a bug in the RAW import/engines [Affinity Photo 1.4.2]?

Recommended Posts

I'm using Affinity 1.4.2 on my MacBook Pro (13-inch, Mid 2009) with Yosemite 10.10.5, 4 GB of RAM.


 


When I open the attached raw file (created by the camera Panasonic DMC-TZ70) in Affinity Photo the image have lens distorsions (the distorsions look almost like the edges of the photo lens on the camera). See the RAW file (a zip file) and the exported JPEG image from Affinity (when the image is distorted and when it's not), compared to the exported JPEG image from Photos (v1.01), attached to this post.


 


The above happens quite often even though the RAW Engine: Apple (Core Image RAW) has been selected in Affinity Photo.


 


When I have the RAW file opened in Photos, and then open the same RAW file in Affinity Photo, the image has been corrected the same way as in Photos when the RAW Engine: Apple (Core Image RAW) is active when opening the RAW file in Affinity Photo. This lens correction is not applied when using the RAW Engine: Serif Labs; the image is not cropped and the dimensions of the image (in pixels) are larger.


 


Is there a bug in Affinity Photo 1.4.2 when using the RAW import/engines?


 


I know that the RAW image file is cropped automatically by Photos (and also by Preview) so that the lens distorsion is removed. The same correction is made in DxO OpticsPro 11 Elite - Trial version for this RAW file.


 


Thanks in advance :)


RAW_File.zip

post-35117-0-13938200-1470650803_thumb.jpg

post-35117-0-01780500-1470650892_thumb.jpg

post-35117-0-59798300-1470650915_thumb.jpg

Share this post


Link to post
Share on other sites

Hi sucRAM_75-Lan,

Welcome to Affinity Forums :)

Currently the Serif Labs RAW engine doesn't crop the image to remove the distorted/unusable parts of the image (thus the slightly bigger pixel size), neither apply any lens correction to the Image, exposing it exactly as it was taken by the camera. Apple (Core Image RAW) does perform those operations, that's why you are seeing the differences you described.

Share this post


Link to post
Share on other sites

Hi MEB,

Thank you, and thank you for your reply  :)

I have one more question. Why does the correction not always work (for the attached RAW file for instance) when using the engine Apple (Core Image RAW) in Affinity Photo? Is there a setting in Preferences where one can choose which RAW Engine to use before opening the RAW image in Affinity Photo?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.