Jump to content
Sign in to follow this  
Harster13

Not all installed fonts are recognized

Recommended Posts

I have the latest version of Designer and I found that not all of my installed fonts are recognized.  I closed the program and re-opened it just to make sure.  Nope, some fonts are missing.

Share this post


Link to post
Share on other sites

Sorry, I don't have a clue what type 1 fonts are, but I do know that DrawPlus recognizes ALL my installed fonts and Affinity does not.  To me, this is an issue.  BTW, I have the latest version of the beta, ver. 1.5.0.10 on Win 10 Pro, 64 bit.

Thanks

Share this post


Link to post
Share on other sites

In the Font Face dropdown list in DrawPlus, do they show 'A', 'O' or 'TT' next to the name? If they show 'TT' or 'O' then they are TrueType or OpenType fonts (respectively) but if they show a red 'A' then they are PostScript Type 1 fonts and Affinity Designer cannot use them.

Share this post


Link to post
Share on other sites

Hi Alfred, all .TTF fonts are 'true type fonts' ?  These are the only sort of Japanese and Indic fonts installed on my iMac.  They look perfect in e.g. Word, but AD does NOT show them correctly.  Quite small errors, but serious enough to make the text un-usable.  Therefore, this is NOT a ttf issue.  It's something in AD.  I work with non-Roman fonts a lot, so fixes in this area would be VERY helpful.  Thank you.

Share this post


Link to post
Share on other sites

This thread is about fonts which are not recognized at all (i.e. not included in the list of available fonts in Affinity Designer). I don't know anything about Japanese or Indic fonts, but their failure to display correctly is a completely different issue which should be discussed in a separate thread.

Share this post


Link to post
Share on other sites

Not able to activate OpenType Font Frutiger LT Pro. If a text with this font is copied from InDesign the font is available but not applicable on new text. I tried to reactivate the font family in FontExplorerX Pro but to no avail - after a restart of Affinity Designer the font family was still not available. Affinity Designer 1.4.2 on OS X 10.9.5

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.