Jump to content
MattP

Affinity Designer Customer Beta (1.5 - Beta 8)

Recommended Posts

Status: Beta Release

Purpose: New features, fixes

Requirements: Purchased Affinity Designer

Mac App Store: Not Submitted

Download: Here

 

This is an early beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it should be considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.5 cannot be opened in 1.4 so always make a copy of your important documents before opening them in 1.5 to ensure you do not accidentally overwrite them and are unable to open them in your 1.4 version.

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

Fixes/Improvements:

  • Fix for macOS Sierra display issues
  • Fix for pasting text from the clipboard
  • New 'Accumulation' dynamic for pixel brushes - take note Paolo Limoncelli! (this is the same as Opacity variance in other editors)
  • Fix for moving an item into a symbol with syncing turned off actually syncing to all instances when it shouldn't
  • Added new 'Create palette from Image' option to the Swatches panel's menu. This allows you to specify a source image and how many colours you would like and their destination palette.
  • Fix for deleting the first/last node of a curve inadvertently causing the shape to change
  • Pen Tool now shows the nodes of the current selection smaller when you start to draw a new curve out, to signify the new state you are entering
  • Added EXR and HDR import/export formats
  • Pressing Escape during guide creation or object transforming now cancels correctly
  • Creating assets with constraints should now function predictably if you dragged the item into the Assets panel (its position was wrong, previously)
  • Fix export of vector stroke brushes to vector formats
  • Fix for Undo/Redo of artboard positioning when used from the History panel
  • Fix for marching ants incorrect behaviour when zoomed in past 100% in Pixel view mode
  • Assets will warn when they are used if they contain fonts the user does not have installed.
  • Solo mode now remains in force when doing simple things to the object (changing its curves, adjusting its fill nodes, etc)
  • Text Styles now allow the user to 'update' any style from the current selection, not just the current style.
  • Fix for NFS issues and some file writing problems
  • Miscellaneous Symbol and Asset fixes
  • Fix for transforming a multi-selection of objects always causing the tool's box to be re-normalised after each drag incorrectly
  • Retina rendering mode in Preferences now works properly - allows for 2-pass retina, 1-pass standard or 1-pass retina rendering. This is actually really useful for Astropad users as forcing it to either of the 1-pass options makes Astropad appear to show less artefacts in its draw

Share this post


Link to post
Share on other sites

Hi, thanks for another beta update!! Coming fast and furious.

 

Two questions:

1). I know it says not for production use... I've created a print design in MAS release. Would it be harmful to open it in 1.5 and Export the PDF for the printer? Or would there even be any benefit, ie better PDF creation?

 

2). When I hit the Close menu or the "hard-to-see" close box on an AD document, if it's not been saved it asks to be Saved, I do so, and expect it then to Close. Except it doesn;t, I have to select Close again. Is this the intended behavior?

 

Thanks - Timber

Share this post


Link to post
Share on other sites

Thanks for the next beta.

 

Leading appears to be still broken unfortunately.  :)

 

I mean, the manual leading is still broken. If one defines a Style that works.

 

Regards

Share this post


Link to post
Share on other sites

Hi, thanks for another beta update!! Coming fast and furious.

 

Two questions:

1). I know it says not for production use... I've created a print design in MAS release. Would it be harmful to open it in 1.5 and Export the PDF for the printer? Or would there even be any benefit, ie better PDF creation?

 

2). When I hit the Close menu or the "hard-to-see" close box on an AD document, if it's not been saved it asks to be Saved, I do so, and expect it then to Close. Except it doesn;t, I have to select Close again. Is this the intended behavior?

 

Thanks - Timber

Hi Timber,

 

You can definitely open your file and hit Export and everything will be fine - hopefully the PDF export will be improved :)  Just don't overwrite your original .afdesign file as it won't be possible to open it again in the App Store version

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

And to celebrate, I finally thought of a daft use for symbols. Hopefully no one has done this yet

 

https://youtu.be/CFJVyL5a0UI

That's cool Ash, what's happening behind the scene with that?  

Share this post


Link to post
Share on other sites

And to celebrate, I finally thought of a daft use for symbols. Hopefully no one has done this yet

 

https://youtu.be/CFJVyL5a0UI

That's insane in the membrane! Got an excuse to play around more with the beta... haven't touched symbols yet. 


2014 iMac, 3.5 Ghz Intel Core i7, Secondary Samsung SyncMaster B2430 display, 16GB RAM, MacOS10.12 || Magic keyboard w/numeric keypad, wireless trackpad, Kengsington Edge Trackball, Wacom Pro Large tablet || Flux Capacitor in a secure location

---

I encourage kids to go ahead and play on my lawn. I mean, how else can I make sure the death-traps work?

Share this post


Link to post
Share on other sites

I have something odd going on with the geometry tools.

 

In the MAS version (1.4.2) if I have a simple shape I can divide its elements:

 

Screen%20Shot%202016-08-05%20at%2003.18.

 

 

But in the Beta, this option is greyed out and not available:

 

Screen%20Shot%202016-08-05%20at%2003.18.

 

In this example I even copy pasted the curve from Beta to MAS. So it works in MAS but not in Beta at all.

Share this post


Link to post
Share on other sites

I have something odd going on with the geometry tools.

 

In the MAS version (1.4.2) if I have a simple shape I can divide its elements:

 

[...]

 

But in the Beta, this option is greyed out and not available:

 

[...]

 

In this example I even copy pasted the curve from Beta to MAS. So it works in MAS but not in Beta at all.

Sorry about this - I think it was mentioned in one of the earlier betas that someone must have accidentally disabled it again (this has happened before too!)

 

It will get sorted for the next beta :)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Sorry about this - I think it was mentioned in one of the earlier betas that someone must have accidentally disabled it again (this has happened before too!)

 

It will get sorted for the next beta :)

 

Thanks,

Matt

 

thanks Matt.

While I have you here, I really, really hope that a vector erase tool comes soon. I manage by using any shape above the layer I want to amend and subtracting. But clearly this is a little ... well, crazy. But I still love you guys, and AD!

Share this post


Link to post
Share on other sites

Sorry about this - I think it was mentioned in one of the earlier betas that someone must have accidentally disabled it again (this has happened before too!)

I think the Divide operation has been disabled for curves layers in at least the last two previous Mac 1.5 betas -- I know I have seen this in versions 6 & 7.

 

What I have been doing as a workaround is to duplicate the curves layer as many times as it has individual curves (so for Ian's example that would be five copies total) & then with the node tool delete everything except one curve's nodes in each of them. It isn't ideal, but for curves layers with just a few individual curves in it it isn't too bad, particularly if the individual curves don't have a lot of nodes.


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

That's cool Ash, what's happening behind the scene with that?  

make circles, make a symbol based on it

move + enlarge and then power dublicate

- if you then move one circle (you have to decollapse the symbol and select one of the circles itself, not the symbol, all circles move in relative increments to their size

 

+macOS visual fixes work as far as I see

+rendering performance seems to be improved yet again? I mean there are some issues left which I´ll report but for now this is really improving very well!!!

 

- not only curves end point modifications and bevel profiles are broken but blend ranges sliders are also broken 

- one still can´t drag the "opacity" label to change the opacity of layers     :wacko: (like it works for brush size e.g.)

​- when you have a brushes mod panel opened and press the v key, the controls are not editable anymore

 

+ dropping stuff into assets and symbol panels

+ might we get the docking of two columns of tool panels to the right (and left) side like possible in AD for Windows?
+ Bleed preview, linked bleed values
 
 thanks for the update! (mostly looking forward to AP 1.5 though  :lol:)
Edited by MBd

 

 

Share this post


Link to post
Share on other sites

An old bug but not fixed yet. Whenever I Cmd + Drag copy something, nudge it with the arrows some distance, and attempt to copy it again with CMD +Drag, the nudge will vanish and first copy will move back to it’s original position.

 

Matt, please fix :(


UI Designer, CG Artist

 

Macbook Pro 15" 2014

2.5 Ghz, 750M

 

https://www.behance.net/VladMafteiuScai

Share this post


Link to post
Share on other sites

Thanks for the update, but...

 

When in the move tool I used to be able to resize an object around the center by holding the cmd key down and moving the handle.  Now when I hold down the cmd key the handles all disappear to show distances.  Which used to happen when the opt key was pressed.  Is this intentional?  Yes I can work around it by moving the handle then pressing cmd.  This is awkward and a function I use a lot.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

Big fan. Love the beta.

 

There are some extremely annoying consequences when moving a canvas/artboard to a non-pixel aligned position (like 50.3): when exporting the artboard the image will not have the correct pixel dimensions, and there will be visible edge/clipping artefacts. When I have enabled "Force Pixel Alignment" and "Move by Whole Pixels" I keep expecting that even the artboard should be forced to the pixel grid.

 

Put another way: I don't get why the position of an artboard affects how the content is rendered? Internally the artboard pixel grid and elements within the artboard are perfectly pixel aligned - why will the output use the global meta-offset that in theory shouldn't even exist? I mean, between the artboards - there are no actual pixels.. Shouldn't the output just be relative to the artboard bounds?

Share this post


Link to post
Share on other sites

There are some extremely annoying consequences when moving a canvas/artboard ...

 

I've also been having problems duplicating and moving artboards. It's hard to describe exactly, but on some complex artboards with many layers, if I duplicate and move things have gone out of alignment and even "jumped" to places far left or right of the artboard or even the original artboard. I've had similar problems copying and pasting content from one artboard to another.

Share this post


Link to post
Share on other sites

What happens when it expires

Either there will be a new beta or, once beta testing is complete, a new retail version upgrade available for download at the Mac App Store.

 

The Windows beta is different, but since this is the Affinity Designer on Mac Beta forum, this pertains only to that.


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

Great job with the new beta release guys! 

 

However, the PDF export bug seems to persist. Transparent background in PDFs is always exported as solid white. Applies for slices, whole document and selected objects with the "Selection without background" export mode picked.

 

EDIT: Ignore my babbling please. Turns out the issue was completely unrelated to Affinity but a bug in the software I used my PDFs with. Sorry for any confusion caused.

Edited by Goner__

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.