I'm new to Affinity Photo (coming from years of Photoshop use) and I ran into a simple issue which drove me crazy and would like some clarification.   I wanted to add a png image of a logo to a currently open document in Affinity Photo so I did a drag/drop from my Finder. The image was a brown logo with a white background.  I wanted to remove the white background.  So I chose the Flood Select Tool (as I would've used the Magic Wand in Photoshop) and with the layer selected when I clicked on it...I would get no selection.  This drove me nuts.   Next, I simply opened the image from Affinity's File ---> Open dialogue to open the image in its own document.  When I used the flood select tool here, it worked exactly as I expected as I was able to single click the white area, hit delete and my white background was gone.   So I looked at both documents to see what the difference was.  I discovered that the drag/drop into an existing document version had the text "(Image)" appended to the end of the layer name.  In the stand alone document the text "(Pixel)" was appended to the end of the layer name.   That said, I went back to the existing document version, selected my logo layer (Image) and from the Layer menu chose Rasterize.  The layer then changed the appended text "(Image)" to "(Pixel)" and the Flood Select tool now worked as I expected in this document.   I'm not used to PNG files (which I consider already rasterized) being in a "unrasterized" state. Can someone explain clarify what Affinity Photo considers an Image Layer and a Pixel Layer and the reasoning behind a PNG file (or any rasterized file) needing to first be rasterized?   I'm not complaining, just trying to understand so I know the procedure I need to use when working with images.   Thanks, Ben