Jump to content
MattP

Affinity Designer Customer Beta (1.5 - Beta 6)

Recommended Posts

Just because...

 

Yep too much time on my hand. I blame Matt P.

 

attachicon.gifStars.mov

Hey, don't blame me - it's Alex's fault! His movie made me think about what would be possible... I reckon with enough time and inclination you could actually do something pretty insane! I was trying to figure out if I could detach syncing for symbols then alter the size of the gear symbol to be smaller and then reduce the number of teeth and change their parameters so I could get a smaller meshing gear? Lost patience trying last night... maybe one day when I'm not bug-hunting... (that may be a while away!)

Share this post


Link to post
Share on other sites

I am seeing an odd problem with both of the two SVG file attachments in https://forum.affinity.serif.com/index.php?/topic/22837-svg-how-to-separateextract-nodesfrom-singleobject/ posted by af-user.

 

Both files open OK in 1.5-Beta 6 (or Beta 5 before I replaced it yesterday) with a single "Curves" object in the Layers panel. The problem is selecting that in the Layers panel does not activate the "Divide" operation, so it can't be split into its individual curves.

 

However, if I open the files in the retail 1.4.2 version of Designer & select the layer, the Divide operation is active & splits the Curves object into its parts as expected.


Affinity Photo 1.8.2, Affinity Designer 1.8.2, Affinity Publisher 1.8.2; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 
1.8.2.174 & Affinity Designer 1.8.2.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites

I am seeing an odd problem with both of the two SVG file attachments in https://forum.affinity.serif.com/index.php?/topic/22837-svg-how-to-separateextract-nodesfrom-singleobject/ posted by af-user.

 

Both files open OK in 1.5-Beta 6 (or Beta 5 before I replaced it yesterday) with a single "Curves" object in the Layers panel. The problem is selecting that in the Layers panel does not activate the "Divide" operation, so it can't be split into its individual curves.

 

However, if I open the files in the retail 1.4.2 version of Designer & select the layer, the Divide operation is active & splits the Curves object into its parts as expected.

We've had this problem before - and fixed it - yet it has crept back in again! I'll have to sort it out again :)

Share this post


Link to post
Share on other sites

Improvements to Node tool will be done at some point.


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

Hi,

just a little observation on creating new documents in designer:

New document form is different from Document setup form, doesnt make to much sense to have two dialog forms for the same operation, does it?

To set up bleed You need to enter the settings two times (as bleeding is not included in New document setting

And new document created as an artboard ignores the margin settings from new document window, so You need to set up the document twice again. A bit annoying.

This should get some attention too, I guess.

Otherwise, new beta seems pretty stable to me. No crashes so far!

Share this post


Link to post
Share on other sites

In export module I miss the ability to create slices automatically, i.e. 100 slices in a row of 64*64 each. 

With a duplication method on a hotkey (duplicate to right/down) this could be implented intuitively.

Share this post


Link to post
Share on other sites

Hi Alex,

 

You got me thinking... I wonder what the most complicated misuse of Symbols could be?... (maybe that should be a challenge!)

 

attachicon.gifgears.mov

 

I'm sure someone must be able to think of something crazy!?!

Matt

 

If only AD would have a frame animation persona - maybe something like Hype 3 ;)


UI Designer, CG Artist

 

Macbook Pro 15" 2014

2.5 Ghz, 750M

 

https://www.behance.net/VladMafteiuScai

Share this post


Link to post
Share on other sites

Hi team,

 

Still having an issue with the export persona, exportSelected button (exporting ticked slices) being greyed out when slices are selected. (See attachment below). Can't send a file because re-opening resolves the issue! 

 

Also having occasional issues with the app not releasing a file properly after being closed. If you try to open it again, it will offer to 'open a recovery' file - even though it was closed properly without a crash. If you say OK it says the 'recovery file can't be re-opened because it's in use'. 

 

Also had a crash after saving a file... crash log attached incase it's of use. 

 

Cheers.

post-6493-0-76395000-1469524701_thumb.png

beta6_crash.rtf

Share this post


Link to post
Share on other sites

Thanks for that, Malcolm :)

 

I've also had the problem with the 'recovery file' when trying to open a document I had already saved and closed.... I've asked Ben to look into it and see what he can find :)

 

Matt

Share this post


Link to post
Share on other sites

Hi Team,

 

I have a bit of a problem with PDF import;  I'll use https://archive.org/download/delineatorvol2424unse/delineatorvol2424unse.pdfas an example.

 

First, though, thank You for nicer import than Affinity Photo: artboards on multiple lines, this helps a lot.

 

Then the problems (also present in AP 1.4.2):

 

1) It takes >30s of beach ball of death to get the dialog. Nearly a second / page to count them? Maybe put the other processing to a background thread and show the dialog right away?

 

2) If I accept the default options (i.e. all pages) there is no indication of anything happnening until 50s later the artboards appear. After that the red thingys still blink for a few seconds so something at least was backgrounded. It would be nice if the artboards would appear right away, even when empty, You know how many at this point already. It would be even nicer to have a progress indicator, like 37 of 40 pages done. Still nicer if the artboard would render when about ready. I only have 12 cpu threads so the first one should be ready by c. 20s at the latest, right? (I'm running BOINC but that's supposedly not interfering with foreground jobs.)

 

3) If you look at pages 4 & 5 there is no way to get them to look as intended (c.f. Preview) and they seem to render wrong but differently.

 

That's all, folks!

 

Zaq

Share this post


Link to post
Share on other sites

zaqzaq:

 

I think that Affinity Designer in not the best tool to create a multipage document with 40 pages and export the document as a PDF.

 

In Mac OS with Preview or Acrobat Pro and another apps in another OSs you can join images to create a multipage PDF.

 

Or wait to Affinity Publisher!!!


Graphic designer from Bilbao (Spain) FreeHand forever. Affinity Designer rocks! - Diseñador gráfico de Bilbao (España). FreeHand forever. Affinity Designer ¡mola!

Share this post


Link to post
Share on other sites

zaqzaq:

 

I think that Affinity Designer in not the best tool to create a multipage document with 40 pages and export the document as a PDF.

 

[...]

krollian:

 

Not create, there were the magic words import and image. Not the best way to get the images to AD or AP currently, especially as it doesn't work. If there is a product & design decision that it never will, I'll be ok with that, it's just not communicated to the user.

 

Incidentally, if I drag the two pages out of Preview so Preview creates a two page document (adding OCR text data and reorganizing stuff) AD imports it nicely and quickly enough that I'm not interested in timing it. AD even does spell checking for the OCR text.

 

cheers,

Zaq

Share this post


Link to post
Share on other sites

1) It takes >30s of beach ball of death to get the dialog. Nearly a second / page to count them? Maybe put the other processing to a background thread and show the dialog right away?

Thanks. This will be fixed in next week's beta. It was loading all the bitmaps before it needed to.

 

2) If I accept the default options (i.e. all pages) there is no indication of anything happnening until 50s later the artboards appear. After that the red thingys still blink for a few seconds so something at least was backgrounded. It would be nice if the artboards would appear right away, even when empty, You know how many at this point already. It would be even nicer to have a progress indicator, like 37 of 40 pages done. Still nicer if the artboard would render when about ready. I only have 12 cpu threads so the first one should be ready by c. 20s at the latest, right? (I'm running BOINC but that's supposedly not interfering with foreground jobs.)

I think it's interpreting the PDF that is slow, not the rendering. More feedback while loading would be good. Our own documents tend to be fast enough not to need it, but it will matter more for multi-page Publisher documents.

 

3) If you look at pages 4 & 5 there is no way to get them to look as intended (c.f. Preview) and they seem to render wrong but differently.

Unfortunately these pages use JBig2 compression, which we don't currently support.

Share this post


Link to post
Share on other sites

Hi Team,

 

Got a crash when I access the asserts panel and select my personal assets :(

Crashes even when there is no document open so I'm pretty sure it's my assets which have got screwed up somehow!

I have them saved out so I guess I could do a reset on start up and then load the saved assets back in. 

 

Here is the crash log incase it is of use. 

crashLog.rtf

Share this post


Link to post
Share on other sites

Hi Team,

 

Got a crash when I access the asserts panel and select my personal assets :(

Crashes even when there is no document open so I'm pretty sure it's my assets which have got screwed up somehow!

I have them saved out so I guess I could do a reset on start up and then load the saved assets back in. 

 

Here is the crash log incase it is of use. 

 

Hi Malcolm,

 

The problem is apparently down to an asset that contains a raster fill layer... I'll check that out here and see if there's something lurking - thanks! :)

 

Matt

Share this post


Link to post
Share on other sites

Unfortunately these pages use JBig2 compression, which we don't currently support.

 

Is that likely to change in the foreseeable future, Dave? I recall JBig2 compression being mentioned a few times during the PagePlus years, but (as far as I'm aware) support for it was never actually added.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Hi,

 

Zoom SPACE+CMD+Drag in 1.4.2 zooming canvas to mouse pointer.. Latest beta zoom is different. Zoom not centered to mouse pointer. This is issue or new feature?


Creative & Design • Game Development

affinity-designer_84646.png?width=64&hei affinity-photo_84647.png?width=64&height

Share this post


Link to post
Share on other sites

Hi Meb, seems to me that it's doing a "marquee zoom" when you press Space + ⌥ (option/alt) from any tool and it's showing the magnifying glass icon with a minus sign in it, should be a plus sign, no?... at least that's what is happening in my version of beta 8.

 

...and the scrubby zoom doesn't seem like it's zooming from under my mouse. It's not quite "on" target...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.