Jump to content
TonyB

Windows Install FAQ

Recommended Posts

  • Poping op "DirectX 10 (Shader Model 4.0) hardware not found" in the beginning. Have tried reinstall again and again.

I'm sure my graphics card support DirectX 10. Any advice?

 

 

Graphics card: Geforce 310M (w/ latest driver)

 

Share this post


Link to post
Share on other sites

 

  • Poping op "DirectX 10 (Shader Model 4.0) hardware not found" in the beginning. Have tried reinstall again and again.

I'm sure my graphics card support DirectX 10. Any advice?

 

 

Graphics card: Geforce 310M (w/ latest driver)

 

 

Hi Chien, looking at http://www.nvidia.co.uk/object/product_geforce_310m_uk.html it seems that your card does support DirectX 10. What OS are you on?

Share this post


Link to post
Share on other sites

@chien

 

if you have a Intel cpu, it might be necessary to either disabling the intel apu(Intel HD Graphics) via the Bios
or to go into the NVIDIA Control Panel and to assign the gpu to Affinity Designer (and all other programs which should use the GPU)

Share this post


Link to post
Share on other sites

Thanks everybody.

 

# not find Intel HD Graphics option in bios, so assigning NVIDIA to AD in Control Panel

# disable and uninstall Intel HD Graphics in Device Manager

# reboot many times

 

But AD still says it require DirectX10 compatible graphics card in order to run. 

 

Again, any advice...?

Share this post


Link to post
Share on other sites

Chien, what graphics card, CPU and motherboard do you have?

 

[solved]

 

ASUS U36JC

Intel M480 i5, Geforce 310M

 

Thanks Mark and everyone. I referred this https://youtu.be/w9sDl4KpdV4

Not telling guys to play Ryze...I follow the guide, download windows dev SDK, manually add AD to the list, and it works!!!

 

That is,

if anyone see "DirectX 10 (Shader Model 4.0) hardware not found" error message, please download windows dev SDK and follow the steps in the video.

 

Go for AD!

:)

Share this post


Link to post
Share on other sites

Nice one Chien, it looks like the guide just forces WARP10 compatibility (which is the software emulation layer), so it might not be as fast as it should be! 

I've just looked into the code which does the checking at startup and it seems like we've got a slight problem where the app should let you run it with WARP10 software emulation, but it's failing with the error message that you've seen.

It still doesn't explain why your card fails the DirectX 10 check though.

Share this post


Link to post
Share on other sites

Hi,

 

I have Windows 7, SP1, 64 bit and during the installation I have an error message:

"Windows 7 Service Pack Platform Update not found (KB 2670838)"

 

What can be the problem?

Thanks!

Share this post


Link to post
Share on other sites

Wow... it's been a struggle to even get into the forum :)

 

OK, I try to install but it asks for Microsoft .NET Framework 4.6.2 which hangs at this point: http://prntscr.com/bw5trrthen fails.

 

I'm using Windows10.

 

Anyone else had this issue?

 

Cheers

 

Andy

Share this post


Link to post
Share on other sites

ASUS U36JC

Intel M480 i5, Geforce 310M

 

...

 

Go for AD!

:)

 

Hi Chien, just to let you know, we bought a laptop with a GeForce 310M for testing, and found that it works OK. We're thinking it might be another problem such as a Windows Update, or driver version etc. Do you happen to know what your driver version is?

Share this post


Link to post
Share on other sites

The installation says I need a Windows Service pack. I also followed and used the Microsoft download link. But when installing service pack it says that this pack is already installed. But the affinity setup don't find this service pack so I can not install...

 

Please help

Share this post


Link to post
Share on other sites

Hi! I get the following message when trying to install Affinity Designer Public Beta on Windows 10

 


Affinity Designer requires the following items, which will now be installed:

Microsoft .NET Framework 4.6.2 Preview

 

-> clicked OK

then it uses a few moments extracting a .cab file, then stops with the following message:

 


Item installation failed: Microsoft .NET Framework 4.6.2 Preview
Setup will now exit.

 

 

Is there anything i can do to fix this?


 

Share this post


Link to post
Share on other sites

The installation says I need a Windows Service pack. I also followed and used the Microsoft download link. But when installing service pack it says that this pack is already installed. But the affinity setup don't find this service pack so I can not install...

 

Please help

 

Hi, it's probably referring to the Platform Update for SP1. You will need to install this:

https://www.microsoft.com/en-gb/download/details.aspx?id=36805

Share this post


Link to post
Share on other sites

My Beta Affinity Designer shows it expired. Is there a way around this. I know it can't be forever, but I am enjoying learning the interface. I have Serif drawplus and page plus, which are both great products, but just trying to keep up with the latest and best. Could I just download another time or is this a one time use offer? I only use it for myself and not using for any commercial projects. I would expect to pay for any commercial uses. You have a really great talented team and thanks for the introduction of the beta version.

Share this post


Link to post
Share on other sites

Hi Robsch,

Welcome to Affinity Forums :)

You will be able to use the Public Betas freely until Affinity Designer's commercial release.

All public betas have an expire date set. The dev team probably was expecting to have a new Beta ready by now thus the expired warning.

Are you sure you are using the latest Beta version (1.5.0.8)?

In any case there should be a new Designer Beta available soon. Sorry the trouble.

Share this post


Link to post
Share on other sites

My Beta Affinity Designer shows it expired. Is there a way around this. I know it can't be forever, but I am enjoying learning the interface. I have Serif drawplus and page plus, which are both great products, but just trying to keep up with the latest and best. Could I just download another time or is this a one time use offer? I only use it for myself and not using for any commercial projects. I would expect to pay for any commercial uses. You have a really great talented team and thanks for the introduction of the beta version.

 

All betas expire 30 days after they are released. It sounds like you're using an old version (1.5.0.5 or earlier). Make sure you've updated to 1.5.0.8 to continue using it.

Share this post


Link to post
Share on other sites

I have read so many tales of woe. So I am not gloating but feel sorry for those that went down. I have Windows 7 Professional installed. Installation of the latest version performed smoothly. I am systematically ging through it. So far all appears to work well. Will continue to try to "break" something, Smokey.

Share this post


Link to post
Share on other sites

1.5.0.11 (Windows 10)

 

For me the .NET Framework 4.6.2 installation took just over six minutes to complete, and also required a system restart. Not necessarily a problem (or your problem), but I think maybe new users should be forewarned, because when it's not doing anything during the installation, it looks suspiciously like it has hanged. Even checking the CPU activity in task manager didn't look promising. In the end the progress bar went from about 10% to 100% all in one go.


Windows Affinity Designer and Affinity Photo. Windows 10 Home (v1803). Windows scaling 115% 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×