Jump to content
farbenfeuer

Different color/colour values swatches panel and color picker

Recommended Posts

Hey guys,

 

so i just noticed this problem with colors in general with AD. 

 

Whenever i copy pasted vector into another program/app i noticed the colors were way off (like far too bright). I couldn't make much sense of it, until i now noticed something:

 
If i take a color in cmyk - say 70/0/5/0 and double click that swatch in the swatches panel it looks all good. But when i choose RGB or anything else in the dropdown menu it completely destroys the color ending up with something like in the image attached.
 
But when i double-click the front color thingy on the left side the (rgb)values are more in line with the cmyk ones. But then i compared it with the color picker from illustrator and with the same cmyk values the result is - not completely - but still a bit off.
 
I love AD to death, but this could be a real dealbreaker to me, since i had already complains about wrong colors from clients and....well...i guess its obvious why this is a bad thing ;)
 
Anybody else out there noticed this or knows what the problem is?
 
 

 

post-28456-0-68394100-1466524079_thumb.png

post-28456-0-00801900-1466524081_thumb.png

post-28456-0-97031500-1466524104_thumb.png


iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Share this post


Link to post
Share on other sites

I furthermore now noticed something even more worrying: If you apply a swatch to an object - again take the 70/0/5/0 and look it up on the color chooser it says exactly that. But if you take the pipette of said color chooser and click the same object, you get slightly different values.

 

It's even more worrying that noone seems to have noticed that, or gives any feedback to this topic. 

 

I guess i will bring this now to the attention of the support... oh wait i just now realize: there seems to be no support other than this forum and apparently i have to be lucky to get recognized, or how is this working?

 

Not trying to be unnecessarily grumpy about this, but i hope you can understand that i do get frustrated about the fact, that i have clients lined up waiting for me to tell them whats what and for that i have to know if i can rely on Affinity for my Corporate Design work, or if i have to redo everything from scratch in Illustrator/Indesign and avoid Affinity until it's fixed/changed.

 

Looking forward to feedback, especially from Devs.

 

Tim


iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Share this post


Link to post
Share on other sites

Thanks for your response Chris.

 

I've to ask though: Doesn't that seem to be a severe issue, that should be top priority and even worthy of some kind of warning for users in the pro section? I mean you claim the software to be a pro-software but flawed colors/color management seems to be like a "worst-case-scenario" type of deal to me, no? I mean i'm downright baffled why this hasn't been noticed before. 

 

I WANT Affinity to be successful, more than you can imagine! I deliberately avoided Adobe as much as i could and started to move over to Affinity almost entirely, but this thing scares the hell out of me, because that might mean i have to redo everything i did with Affinity up to this point. Not even talking about already printed products that clients may return after realising the difference.

 

Tim


iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Share this post


Link to post
Share on other sites

Still having the problem as well. It seems to happen when you set up colors in cmyk and then switch via the dropdown menu to hsl or rgb or whatever. Suddenly the colors get all funky - like extremely saturated and bright and its not just UI - the values are completely bonkers too then. 

 

This is extremely unsettling to say the least. Again: Professionals are supposed to work with this, but if i can't trust the color values, i can't really trust the app as a whole for anything...

 

But yeah, it has already been confirmed by the devs but yet no update for 7 months...

 

Affinity? Cmon guys - this isnt like some minor glitch or anything. This is major and shouldn't be anything but top priority no? At least an update on the topic.


iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Share this post


Link to post
Share on other sites

I have the same problem with affinity. Another problem that appears that is color related is, that if you copy something from indesign to affinity designer, the color values will change. Black changes to a dark gray which ends up like the one in the screenshot.

 

Is there something I can do to avoid this color converting problems?

screenshot-201710279_0910.png

Share this post


Link to post
Share on other sites

I just noticed it too...

I am preparing something that should be in a different shades of blue (in HSL scale it should have the constant Hue). But it does not work properly!

Also - this is not a bug specific to Mac. I am working on Windows.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×