Jump to content
Stutter

Photos Extension: "Unable to edit with Affinity Develop" error

Recommended Posts

After a while editing in Mac Photos using the Affinity Extensions I get the error message: 'Unable to edit with Affinity Develop - an unexpected error occurred' after pressing save changes. Once this has happened it recurs every time I try to use Develop unless I close Photos and re-open. The error then seems to recur after fewer photos than before - until I restart.  Is this a memory leak problem?

I am editing 24bit jpeg files of around 4500 × 3000 7.5 MB

 

  Model Name: MacBook Pro

  Model Identifier: MacBookPro12,1

  Processor Name: Intel Core i5

  Processor Speed: 2.7 GHz

  Number of Processors: 1

  Total Number of Cores: 2

  L2 Cache (per Core): 256 KB

  L3 Cache: 3 MB

  Memory: 8 GB

  Boot ROM Version: MBP121.0167.B16

 

 

Share this post


Link to post
Share on other sites

Ok - file uploaded - it reproduces the error in Develop even straight after a reboot - if no tool is used, and also with the clarity tool amongst others.

BTW another file gave the same 'Unable to edit' message with the Retouch tool set (inpainting) even without pressing 'Save Changes', but I could not reproduce this behaviour after a reboot and pinpointing worked OK.  The file I sent you works OK with Retouch/Inpainting though.

Share this post


Link to post
Share on other sites

Hi Stutter,

Sorry the delay replying to you. I've tried to replicate your error on my system (extensions from the MAS version and the Beta) and all seem to save the file without issues after editing.

I've tried with all Develop Extension's sliders (clarity included) and some tools from the Retouch Extension (Inpainting Brush and a few others), however the file you sent me is much smaller than the ones you seem to be working with. It's also an 8 bit RGB image. If you wouldn't mind to upload one of the biggest ones you usually work with i can check it out.

All files will be deleted after being checked.

Share this post


Link to post
Share on other sites

Sorry for the delay - I was busy not doing photos for a while!  

 

I have updated a full res file (Stutter3) I was working on today in Mac Photos.  I went into Affinity Extensions 'Retouch' using the Dodge tool on the face, to begin it was OK then I changed from 'midtones' to 'shadows' and pressed ']' to get the brush circle back (it had reverted to an arrow cursor). It crashed out with the 'unable to edit error'.

 

I had previously Dodged another photo:  picked ' Shadows' changed the brush size with ']'- no problem.  I have just gone back to that photo and dodging works fine on it after changing brush size.

 

I then went back to the photo I have uploaded and reproduced the error again in dodge.  However I tried inpainting and it was OK, including changing brush size - and after that Dodge worked as well.

I have not restarted photos during this.

Share this post


Link to post
Share on other sites

Hi again,

This problem is maddening!  Tonight I have been editing photos - all started ok but after doing about 20 I now repeatedly get an  'Unable to Edit with Affinity Develop' crash out error when saving changes after using Develop/Clarity.  Whereas Retouch/Dodge has been OK so far.  The problem returns immediately even after closing Photos and re-opening.

Share this post


Link to post
Share on other sites

I also got the same problem. "Unable to edit with Affinity Develop - an unexpected error occurred" dialogue show up every times whenever I try to use Affinity Develop extension in raw any file or Jpg file but the other extensions work fine for me.

It used to work fine after I reopen the photo apps when this dialogue showed up but currently, I can't use develop extension anymore even I uninstalled and reinstalled Affinity Photo.

Share this post


Link to post
Share on other sites

Hi,  same issue for me tonight on New 2020 MacBook Pro with 16 gig of RAM. Trying to develop a raw image. Only the second pic I’ve tried after downloading the app this evening....?

Any thoughts on a remedy?

Share this post


Link to post
Share on other sites

You are posting into a thread that was opened in 2016 and went silent in 2017.

Do you think nobody posted because the problem from then is still there ?

My advise: Open a new thread, and post a little more information that you are running Catalina, and can’t develop more than one RAW before running into trouble. This reads as if we would have to pay for each word posted here.

Share this post


Link to post
Share on other sites

It was my second post on this issue so I took your advice and went to start a new topic. Weirdly, issue seems to have resolved itself!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.