Jump to content
vitor

Affinity Designer is imprecise to the user

Recommended Posts

Transform only shows one decimal place but it can have more, which means we can never trust its numbers.

I’ve drawn two rectangles. They are identical in every way (size, position, stroke width) except stroke color. I’ll make my point with width, but it happens with every other field as well (X, Y, W, H).

Let’s start by making red 7.98mm wide.
a4Ds6Uj.gif

Wait, it made it 8mm? That’s not what I wanted, but alright, I guess I can live with that. Lets make green 8mm wide, then.
NUi0WZd.gif

You can already start to see the beginning of the problem. red is in fact 7.98mm just like we asked, but Affinity Designer completely hides that from us. Imagine you’re working with shapes you drew earlier and you want to check how wide they are. That is impossible, as there is no way to know their real size.
HQFX5Fu.gif

That alone makes Affinity Designer unsuitable for any kind of job that takes precision, but it gets worse. To make sense of this mess, lets at least try to make both rectangles the same size. Select them both, and set them to 7.8mm.
ihr6OY3.gif

You’ve got to be kidding me. So we can’t even resize them at the same time, and they’ll weirdly take their proportions which are invisible to the user into account? Lets try something stupid: just select the width field and press ↩
f0woN4a.gif

It worked, which in this case actually makes the case even more of a mess.

This is a problem that has been going on ever since the first beta, way before Affinity Designer was first released on the Mac App Store. Although here I’ve only tackled Transform, Affinity Designer’s precision is absolute garbage in many more areas. Expand Stroke is another example of a feature that does not work even slightly well (makes way too many points), and Boolean Operations, though getting better (they were absolutely unusable for a long while, even after a few stable releases) are still lacking.

Once more I’ll reinforce the notion that the Transform panel absolutely cannot be trusted for even the slightest needs of precision. Having one decimal point (and in some cases none, as when 7.98mm became 8mm) isn’t ideal, but it is inexcusable that a Pro app with such behaviour does not at least give the user a hint that a value is not what it really says. At the very least there must be some indication that a value isn’t exactly what is shown.
G4QrgdP.png
Raoh4IP.png

It does not matter what, but something.

Share this post


Link to post
Share on other sites

Hi vitor,

Thanks for your feedback. I believe there's two issues here which i will log but that aren't directly related with Affinity's precision.

 

In you first and second GIF's the program is performing correctly, however since you have the application configured to only show one decimal value, it is rounding the info in the Transform panel to 8mm. The objects on the canvas however are reflecting the difference correctly (one has 7,98mm and the other 8.00mm). Internally the program always work with the correct/accurate values, only the Transform panel rounds them (or not) depending on how you have configured the software. If you need to work with more precision you can set Affinity to show up to six decimal values avoiding the rounding you are seeing in the Transform panel. You can set this in Affinity Preferences, User Interface section, Decimal Places for Units Types.

Maybe we should add a symbol as you suggested to at least remember the user when the values displayed aren't being 100% accurate/showing a rounded value. I will log this as a suggested improvement.

 

The third and fourth GIF's does seems a bug in the software - when you select both objects and set the dimension to 7.8 mm, both should have changed to 7.8 mm - i'm logging this to be looked at (my bad should have known better - see Ben reply below). The other issue is pressing or not Enter in an input field. I believe there's still some inconsistencies between the various input boxes in the program. Some do require to press Enter, others seem to work fine without pressing it. This is something that was being improved but may still not be working correctly. I will also add this to the log or update the existing issue there.

Share this post


Link to post
Share on other sites

As MEB says - the precision is a user defined property.

 

As for GIF 4, if you select BOTH rectangles and enter a size - it does not set the size individually, but scales the extents of the full selection.  You will see that the smaller rectangle has been scaled proportionally.  This is as intended.  It is the same if you drag the handles on page to scale the contents of the selection.  The values displayed in the Transform panel show the position and size of the bounding rectangle of the entire selection.

 

Select the rectangles one by one, and set their size, and both will be the same size.

 

When you enter text in the boxes, the text value is converted into a size.  If it was displaying a truncated size, the text is just re-parsed as is.  The result will be an actual size based on the original text of the truncated value.  The transform tab does not try to interpret the text in any other way - it doesn't try to track the value that it originated from because we cannot easily tell the difference between a value you keyed in and a value resulting from turning a truncated value into text.  If you had a value of 7.85 that was rounded to 7.9, and you start editing the text and enter a value of 7.9 (by just pressing enter, or typing the value yourself) - you will get a precise value of 7.9.  Of course, if that means a new value that is a new size, the selection will be resized!

 

I suggest you increase the precision in the user preferences, and try a lot of these "issues" again.  You'll see it is not working quite how you think it is.


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

Thank you both for the replies. I wonder how I missed that preference, since the first thing I do after installing an app is is ⌘,. I guess the preference wasn’t there at the start, and I never looked again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×