Jump to content

Stroke properties disabled

Recommended Posts



I made a search, and didn't find anything about this potential issue (I'm still not sure if it's a bug or not).


Here is my problem : I create a curve (freehand, or by converting a shape), I select it, and go to Stroke pop-over. I can edit the width, cap, join, align, etc. But when I click on Properties button, the Brush window is completely locked (everything is disabled, impossible to select anything).


And when my curve is selected, I can change the Color in the right tab, but if I try to select another brush in "Brushes" tab, then nothing happens : my curve keep its "standard" shape.


I'm doing something wrong, or it's definitely a bug ?


Thank you !



Share this post

Link to post
Share on other sites

Hi javerous,

Welcome to the forums :)


This seems to be working fine for me. I'm able to click Properties and change the brush and colour etc. Can you give me a bit more info about your setup? What OS are you on and what version of Affinity are you running? 

Any chance you could attach a document so I can see if that document has issues on my machine? I suspect it will work but it's worth ruling it out.


You could try seeing if it is working correctly in the beta which can be found here

Share this post

Link to post
Share on other sites

Hi Chris !


I'm on OS X 10.11.4 (15E65) with Affinity Photo 1.4.1 (hmm… shame on me, I even forgotten to specify that I use Affinity Photo, not Affinity Designer…)


I attached a document. As you can see, I was able to configure some properties of the curve stroke (its width + pressure). But when I click on "Properties" button, the Brush window which open is completely deactivated.






I tried with last Affinity Photo Customer Beta (1.4.2 - Beta 4) : same result.

Share this post

Link to post
Share on other sites

Hi Javerous


This is greyed out as there is no brush applied to the stroke. Only vector brushes can be applied to the pen line, however all the brushes in Photo are raster based so won't apply, hence why there is no change to the stroke when you attempt to apply it.


This properties button is something that has been brought over from Designer. It's been left in as you can import a designer file which has vector brushes applied to the stroke and still have the ability to edit them in Photo. perhaps we can be a little bit smarter and grey this button out when it does not apply.

Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post

Link to post
Share on other sites

Hi Chris_K !


Okay, I understand. Do there is any plan to be able to use raster based brushes on pen lines, or it's something technically impossible, or which can't give good results ? (I see at least one problem : when an image is resized to something bigger, it's hard to keep a good quality if the raster based brush has to be enlarged to keep proportions of the whole picture).


Would be better to gray out the button or add some warning yes, because it looks like something buggy (but it's subjective, so…).


By the way, I don't have anymore solution to add an arrowhead to my curve (well, okay, I can buy Affinity Designer…)...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.