Jump to content
You must now use your email address to sign in [click for more info] ×

Batch processing in raw editor


Recommended Posts

I have tried to use both batch and macros in raw the editor, but failed to do it.

What for example I would like to automate process my raw files with a raw profile. One of the for me most usefull function  lens vingetting removal. Its very tedious and ineffective doing for every file. Is there anyone who could tell me something about this functionality?  Lack of it / workaround ?

/Ken

Link to comment
Share on other sites

Hi,

this should work in general, but there are many quirks and unfixed bugs. In what sense is it breaking? Any error messages, unexpected results, corrupted files?
 

first try to deactivate parallel batch processing.

Mac mini M1 A2348

LG34WK950U-W, calibrated to DCI-P3 with LG Calibration Studio / Spider 5

iPad Air Gen 5 (2022) A2589

Special interest into procedural texture filter, edit alpha channel, RGB/16 and RGB/32 color formats, stacking, finding root causes for misbehaving files, finding creative solutions for unsolvable tasks, finding bugs in Apps.

 

Link to comment
Share on other sites

Hello,

well when I open a raw file with open then the menu choice for both batc and macro is not available. What would work is if it was possible to record a macro while I enter my values in the raw panels , for me most importan "remove lens vingetting". If that was possibler then I could start a batch job and include that macro.

Link to comment
Share on other sites

What is possible can be found Here

Mac mini M1 A2348

LG34WK950U-W, calibrated to DCI-P3 with LG Calibration Studio / Spider 5

iPad Air Gen 5 (2022) A2589

Special interest into procedural texture filter, edit alpha channel, RGB/16 and RGB/32 color formats, stacking, finding root causes for misbehaving files, finding creative solutions for unsolvable tasks, finding bugs in Apps.

 

Link to comment
Share on other sites

13 hours ago, ken_wiberg said:

I tried it and it stopped at no 6, when trying to open develop mode again , it failed, and an error message

Just retested and it works fine for me (Windows 11).

Double clicking the thumbnail at step 6 takes me back into the Develop Persona

Can you upload a full-size screenshot of what you have just before you try step 6. Please include the macro panel and Layers panel in the screenshot.

 

 

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

OK, forget macro recording for now

When you develop a RAW file and develop it with Linked or Embedded selected in the Develop persona, you should be able to reenter the Develop persona by double clicking the thumbnail of your .CR3 file in the Layers panel

Can you check that works with your RAW files?

As if not, we need to find out why that is not working first

 

PS that is not a full-size screenshot, I can't even determine if you are using a Mac or Windows amongst other things that may have helped diagnose the issue

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

3 minutes ago, ken_wiberg said:

Yes that is working, no problem

OK, I can now see you are working on a Mac, I am on Windows so someone with a Mac will need to confirm they are seeing the same issue as you, as I cannot test that.

Please state what Mac OS version you are using so someone can test that and get back to this thread later for you


In the meantime, if you develop an image with the "lens vignetting removal" options you want already applied to it and attach that .AFPhoto file to the forum I may be able to complete the macro for you so you can test it in a batch file. Please use the Embedded option as I won't have the original Raw file   

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

Like I said you need to Embed the RAW file or else I cannot see it

You have linked it

Alternatively, just upload the Raw file on your next post to the forum

  

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

Thanks

OK I have uploaded the macro to this post

I tested it by removing your applied vignette and linking your Raw file to export it

I then did a batch job using that file with the macro and it worked OK

Hopefully, it should work for you on a few test RAW files you have not processed as yet

Just save the attached macro to your Library panel and follow the instructions in Step 2 of this post

 

 

Vingette.afmacros

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

I think, maybe the Devs/Support will need to look into your issue further and testing with "MacOs:  Sonoma 14.0"

 

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

Ok. This feature is of great use for me. Im doing real estate photography and are shooting between 5 to about 10 exposures to be combnined into one merged  picture. And multiplying this with about 25 angles/shoots for each appartement or house assignments illustrates the need for efficient post procesing. I have left Photoshop and dont want to go there.

I greatly appreachiate the help so far. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.