Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity dev team showing very disappointing development skills! Looking at Photoshop now!


Recommended Posts

Hi,

I'm a Affinity One user from day 1!!! This is about Affinity Photo 2 the latest version.

The 9th of November 2022 I purchased the Universal licence for version 2. Now after almost one year of waiting I am still not able to make a preset in the slices panel and export multiple images sizes in jpg and webp extension. It makes the latest version still crash big time.

It's pathetic to see how slow and unprofessional the updates are done!

This is totally unacceptable!  

Good luck, but I'm looking elsewhere for a good and reliable photo editor!

David

Link to comment
Share on other sites

Harsh but justified, I gave up after the msi/msix debacle

As someone who spent a working life in heavy engineering where document revision control can be the difference between life and death I found this amusing
https://forum.affinity.serif.com/index.php?/topic/191874-220-prompt-still-appearing/

Now no one will die because of a few wobbly pixels but it reflects the company's attitude. Good luck to you

Microsoft Windows 11 Home, Intel i7-1360P 2.20 GHz, 32 GB RAM, 1TB SSD, Intel Iris Xe
Affinity Photo - 24/05/20, Affinity Publisher - 06/12/20, KTM Superduke - 27/09/10

Link to comment
Share on other sites

3 hours ago, All Media Lab said:

Now after almost one year of waiting I am still not able to make a preset in the slices panel and export multiple images sizes in jpg and webp extension. It makes the latest version still crash big time.

FWIW, in the Mac version I have no problems doing either of these things in V2 nor did I in V1.

All 3 1.10.8, & all 3 V2.4.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

40 minutes ago, R C-R said:

FWIW, in the Mac version I have no problems doing either of these things in V2 nor did I in V1.

 

@R C-R Hi,

Then your the only one because webp in the slices panel is not possible in version 1 of Affinity Photo!

Secondly the problem in even the last version of Affinity Photo V2 is a known bug for almost a year when I discovered it and reported it on this forum:

 

Link to comment
Share on other sites

16 minutes ago, All Media Lab said:

Then your the only one because webp in the slices panel is not possible in version 1 of Affinity Photo!

Sorry, I worded that poorly. What I meant was I was not getting crashes in V1 exporting multiple JPEGS or making slices presets in either V1 or V2, & also in V2 no problems with webp exports either.

So maybe this is a Windows only issue but I am only guessing about that since I have only done limited testing in the Mac versions.

All 3 1.10.8, & all 3 V2.4.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

@R C-R

It's tested on my 3 Mac's latest OS Intel and M2 and confirmed by Affinity staff: AF-266<--- the bug tracking code!!!

So I doubt that it works on your Mac! believe me It is a confirmed bug and it makes any preset made in the slices panel crash when containing multiple sizes jpg and webp after saving the preset, closing Affinity Photo, opening Affinity Photo, going to the export persona and try to open your preset in the slices panel. Pooof!

Link to comment
Share on other sites

15 minutes ago, All Media Lab said:

So I doubt that it works on your Mac!

I'm not sure what to tell you. I just tried exporting 3 JPEGs (1x, 2x, & 3x) & it worked perfectly. I tried both with slices about half the size of the document & again with the full size. So there must be something I am missing in whatever it is that makes it crash.

All 3 1.10.8, & all 3 V2.4.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

@R C-R

If you are truly interested you should first read what the issue is!!! 

It has absolutely nothing to do with what you are trying to achieve!

18 minutes ago, R C-R said:

I'm not sure what to tell you. I just tried exporting 3 JPEGs (1x, 2x, & 3x) & it worked perfectly. I tried both with slices about half the size of the document & again with the full size. So there must be something I am missing in whatever it is that makes it crash.

What you are missing is not reading what the issue is! It's explained in the bug tracking code AF-266<--- the bug tracking code!!!

And in my previous post:

42 minutes ago, All Media Lab said:

It is a confirmed bug and it makes any preset made in the slices panel crash when containing multiple sizes jpg and webp after saving the preset, closing Affinity Photo, opening Affinity Photo, going to the export persona and try to open your preset in the slices panel. Pooof!

So you have to make a preset containing for example 5 jpg's sized: 1000w, 2000w, 3000w, 4000w and 5000w and 5 webp's sized: 1000w, 2000w, 3000w, 4000w and 5000w

Now save this set up in a preset in the slices panel and close Affinity Photo.

Open Affinity Photo and load an image to be used with the preset.

Now go to the export persona and load your preset in the slices panel containing 5 jpg's and 5 webp's in multiple sizes from a 1000w to 5000w.

Watch Affinity Photo crash.

Good Night,

David

Link to comment
Share on other sites

Thanks for the more complete description of how to cause the crash. I can now duplicate it.

EDIT: Now that I have done that, any idea how I can delete just the preset I created to test with?

All 3 1.10.8, & all 3 V2.4.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

44 minutes ago, All Media Lab said:

... and 5 webp's ...

There's even another problem with the Google webp file format that hasn't been detected for very long time at all. - Only recently it was found out that Google's libwebp contains some bugs which can be used for security vulnerabilities attacks. That way that when a webp image crashes deliberately, malicious code can be introduced through the webp file format into a system.

In order to prevent this, the latest/newest and fixed libwebp libraries have to be used for any app which makes use out of the webp file format.

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

10 hours ago, R C-R said:

EDIT: Now that I have done that, any idea how I can delete just the preset I created to test with?

@R C-R Hi,

The export persona presets are stored in an export_config.dat file when custom presets are present. This file can be found by opening spotlight search (CMD + SPACE) and entering the following:

~/Library/Application Support/Affinity Photo 2/User

I've not tried it my self, but you should be able with a text editor to remove the test preset and save the .dat file again. Or if you have no presets there remove the .dat file.

David

Link to comment
Share on other sites

6 hours ago, All Media Lab said:

I've not tried it my self, but you should be able with a text editor to remove the test preset and save the .dat file again. Or if you have no presets there remove the .dat file.

I know about that file & can open it with a text editor like BBEdit, but it is not obvious how to just remove one preset from it due to the way it encodes data. (Open it foer yourself to see what I mean.)

All 3 1.10.8, & all 3 V2.4.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

17 hours ago, R C-R said:

EDIT: Now that I have done that, any idea how I can delete just the preset I created to test with?

Use the Slices Panel's Clubhouse Sandwich/Hamburger menu in the Export Persona.

ScreenShot2023-09-21at7_38_22AM.png.81f34e257d9e3300a263d9f9b45ae693.png

Mac Pro (Late 2013) Mac OS 12.7.4 
Affinity Designer 2.4.1 | Affinity Photo 2.4.1 | Affinity Publisher 2.4.1 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

3 minutes ago, Old Bruce said:

Use the Slices Panel's Clubhouse Sandwich/Hamburger menu in the Export Persona.

That won't work because as soon as I choose that preset, the app crashes.

All 3 1.10.8, & all 3 V2.4.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Hi @R C-R,

I looked at the export dat file and made an other solution 😋

The way to remove the preset that is causing a crash is simple!

1. make in the slices panel a simple setup with png 1x and jpg 1x save it under the same name "test" (overwrite yes).

2. now open the preset again select the whole panel and remove the preset you just made.

Link to comment
Share on other sites

2 hours ago, All Media Lab said:

The way to remove the preset that is causing a crash is simple!

Thanks for that! Before I read your post I ended up deleting the whole export_config.dat file, but I'm sure your clever workaround would have worked.

All 3 1.10.8, & all 3 V2.4.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

@R C-R Hi,

I hope you understand now why I'm very much pissed off!

For my webdesign purposes I created 20 plus pre-sets to find out later that non of them would work! 

Almost a year later nothing has changed in any update.

I think export slices is basic stuff that should have worked from day one!

When I look at the Affinity forum what is all wrong with the apps It is getting out of hand and most people seem to except this as normal! I can tell you using multiple other apps from different companies Affinity beats them all with no communication and tons of bugs!

Using Photoshop now and write off the price of the Universal Bundle!

David 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.