Jump to content
You must now use your email address to sign in [click for more info] ×

SOLVED Publisher 2.2 : Problem launching app after upgrade to 2.2

Recommended Posts



I have upgraded Affinity Photo to 2.2  : no problem detected


After upgrading Affinity publisher to 2.2 : impossible to launch the application here is the error




I don't have any firewall working


Any idea ?


Thanks for the Help

Link to comment
Share on other sites

  • Staff

Please could you try closing any Affinity apps you have open currently and then try opening Publisher to see if this issue persists? If it does please could you try restarting your computer and then opening Publisher before any other apps to see if it then works for you?


Please tag me using @ in your reply so I can be sure to respond ASAP.

Link to comment
Share on other sites

Hi Callum

I know what happened you were right , Affinity photo was opened and i launched external filter ( Nik Collection ) when i tried to launch Publisher

I closed the Nik Colelction filter and tried to launch Publisher , it's worked 


Thanks for your reactivity and your Help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.