Jump to content
You must now use your email address to sign in [click for more info] ×

Serious Color Management Issue


Johannes

Recommended Posts

  • Staff
44 minutes ago, Hangman said:

I likewise have a CMYK Tiff file that uses the ISO Coated v2 300% (ECI) profile, exported from Affinity Photo. If I open in Affinity Publisher 2.2.0.2005 (Retail or Beta) when I have 'Convert open files to working space' and 'Warn' checked in the Colour Settings if my Working Profile in Publisher is also set to ISO Coated v2 300% (ECI), the Publisher Assistant still pops up telling me it is converting the image to the Working Profile which in this instant it shouldn't need to as the Working Profile is the same as the image file being opened, but the image is being converted to the Working Profile set prior to setting a new Working Profile (if that makes sense)...`

I've split the above issue into a separate thread here, which our team will investigate in due course -

Although potentially related, a separate thread makes it easier for our team to track, and to report each separate issue to our developers :)

39 minutes ago, Optische Ausrichtung said:

Something is wrong with this profile. I deleted it in Library > ColorSync > Profiles and the behavior is as it should be.

29 minutes ago, Hangman said:

There certainly seems to be despite downloading the profile from the http://www.eci.org website...

I can confirm that part of my testing was downloading this specific profile from the above website and installing it on my Mac, which did not exhibit the reported issue - this is the reason I have asked for the specific .ICC files from your Profiles folder, as I'm interested to see if your ICC profile file differs from the file I have recently tested using, for example if the file itself had been renamed between downloading and installing as a Profile, etc.

Link to comment
Share on other sites

22 minutes ago, Dan C said:

Although potentially related, a separate thread makes it easier for our team to track, and to report each separate issue to our developers :)

No problem at all, I was in two minds about whether to create a new post since you'd already replied to @Optische Ausrichtung in the original thread...

I've now uploaded all my ICC Profiles to the other thread...

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

The problem occurs with the profile "ISOcoated_v2_300_eci.icc" of http://www.eci.org/lib/exe/fetch.php?media=downloads:icc_profiles_from_eci:eci_offset_2009.zip. If the file is in the Library > ColorSync > Profiles folder, then the problem occurs with any profile that is selected. I just tried again with freshly downloaded ZIP archive "eci_offset_2009.zip".

 

Ich hoffe, ich erlebe es noch, dass die deutschen Anführungszeichen in Affinity Publisher korrekt funktionieren.

Link to comment
Share on other sites

28 minutes ago, Optische Ausrichtung said:

The problem occurs with the profile "ISOcoated_v2_300_eci.icc" of http://www.eci.org/lib/exe/fetch.php?media=downloads:icc_profiles_from_eci:eci_offset_2009.zip. If the file is in the Library > ColorSync > Profiles folder, then the problem occurs with any profile that is selected. I just tried again with freshly downloaded ZIP archive "eci_offset_2009.zip".

That's the exact same .zip I downloaded as per the instructions on the eci.org website for that specific profile, though interestingly @Dan C mentioned above that he likewise downloaded the same profile from the same source and he's not experiencing any issues...

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

47 minutes ago, Hangman said:

That's the exact same .zip I downloaded as per the instructions on the eci.org website for that specific profile, though interestingly @Dan C mentioned above that he likewise downloaded the same profile from the same source and he's not experiencing any issues...

Yes, I'm afraid I have no idea how to pull the chestnuts out of the fire. I've tried it with newly created user, reinstalls, selected profiles in many possible variants and much more. Something went pretty wrong there. Maybe I'll switch back to version 2.1 this weekend. The alternative might be to temporarily try replacing Designer with Publisher or switch to the Windows version. The universal license has to be good for something. ;-)

Edit (and asked by the way): Is it possible to downgrade the Universal license from 2.2 to 2.1 under macOS?   

 

Ich hoffe, ich erlebe es noch, dass die deutschen Anführungszeichen in Affinity Publisher korrekt funktionieren.

Link to comment
Share on other sites

I would like all to be specific in which program the error occurs.

I'm still having issues in Designer. Publisher is now (mostly) fine.

So Yesterday I had to quickly export a Print PDF from a Designer document and the resulting PDF did wrongly include "US Web Coated whatever" instead of the correctly set "Generic CMYK". So when you checked it in Adobe Acrobat you saw that all the colours were cross-converted (0/100/100/10 became 3/96/80/5 or something like that)

My Workaround for now is to finish the job in Designer and then open the file in Publisher just to export the PDF for the offset printing firm. (Most of my print jobs are Publisher files anyways... I use AfDesigner mostly for logos and info-graphics, which I then link in AfPub)

  • Main machine: iMac 2019 (21,5-inch 4k, 6core), 64GB RAM, 1TB nvme + 2TB ssd, running on Mac OS 13;
  • Display setup: 28" 5k Display (primary) + 21,5" iMac4k-Display for studio panels (secondary);
  • Keyboard layout: german apple extended keyboard (aluminium);

 

Link to comment
Share on other sites

Perhaps a helpful hint: When I compare the PDF standards of two Affinity-Designer-PDFs exported with the profile "ISOcoated_v2_300_eci.icc" using Acrobat Reader, there is a difference under "Kennung" (Identifier?) for this profile (see screenshots). The special character "ÿ" (Lower case letter Y with Diaeresis) certainly does not belong in front of the profile name and is not found when using other profiles or in PDFs written with an earlier version of Affinity Designer. The profile used is the normal and not renamed profile from the file "eci_offset_2009.zip".

Actual PDF:

image.jpeg.1dc3ccd69ceee17381d1a71643002e9f.jpeg

Older PDF:

image.jpeg.6163b896c557497d5d7e7e9fb89eddc1.jpeg

 

Ich hoffe, ich erlebe es noch, dass die deutschen Anführungszeichen in Affinity Publisher korrekt funktionieren.

Link to comment
Share on other sites

8 minutes ago, Optische Ausrichtung said:

The special character "ÿ" (Lower case letter Y with Diaeresis) certainly does not belong in front of the profile name

Good catch! My old Acrobat Pro (v9) does not display this info

Can you repeat this with AfPublisher if you have it installed?

I'm beginning to think it may indeed a localisation bug (german) in AfDes but is linked to the system language not necessarily the program language.

  • Main machine: iMac 2019 (21,5-inch 4k, 6core), 64GB RAM, 1TB nvme + 2TB ssd, running on Mac OS 13;
  • Display setup: 28" 5k Display (primary) + 21,5" iMac4k-Display for studio panels (secondary);
  • Keyboard layout: german apple extended keyboard (aluminium);

 

Link to comment
Share on other sites

19 minutes ago, woefi said:

Can you repeat this with AfPublisher

Done. Here, too, the special character is found in front of the profile name. Although "Publisher", unlike "Designer", does not show the rest of the strange behavior, a queasy feeling still remains. The character certainly doesn't belong there, and no one knows what consequences it will have in finishing or prepress.

Let's hope that programmers can quickly find the place in the code where a bracket was left open or a semicolon was forgotten. ;-)

 

Ich hoffe, ich erlebe es noch, dass die deutschen Anführungszeichen in Affinity Publisher korrekt funktionieren.

Link to comment
Share on other sites

1 hour ago, Optische Ausrichtung said:

Done. Here, too, the special character is found in front of the profile name. Although "Publisher", unlike "Designer", does not show the rest of the strange behavior, a queasy feeling still remains. The character certainly doesn't belong there, and no one knows what consequences it will have in finishing or prepress.

Just to add, the additional ÿ with diaeresis character at the start of the profile name is unique to 2.2.0 (both Beta and Retail) in both Designer and Publisher. Using the identical profile in 1.10.6 and 2.0.4, again in both Designer and Publisher, displays the profile name correctly. I'm using English for both my system and Affinity languages.

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

  • Staff
On 9/24/2023 at 9:48 AM, Optische Ausrichtung said:

Perhaps a helpful hint: When I compare the PDF standards of two Affinity-Designer-PDFs exported with the profile "ISOcoated_v2_300_eci.icc" using Acrobat Reader, there is a difference under "Kennung" (Identifier?) for this profile (see screenshots). The special character "ÿ" (Lower case letter Y with Diaeresis) certainly does not belong in front of the profile name and is not found when using other profiles or in PDFs written with an earlier version of Affinity Designer. The profile used is the normal and not renamed profile from the file "eci_offset_2009.zip".

Many thanks for the further testing performed here!

I can confirm that our development team have identified this to seemingly be the cause of this issue, as we made a fix in 2.2 to attempt to better handle ICC profiles that contain accented characters in their name, and this seems to have had a knock-on effect for other installed ICC profiles that don't include such characters - though it does not affect all installed ICC profiles.

The failure to correctly understand these profiles/profile names causes the list to appear in the incorrect order in-app, and when selecting one of these profiles the app will silently fall back to a previously selected/default profile, causing the issue to appear as though the app doesn't retain the colour profile option selected.

With the above information provided from our developers, I believe this issue is in-hand and should hopefully be resolved shortly, in our next available update. Apologies once again for any inconveniences caused in the meantime!

On 9/22/2023 at 7:33 PM, Optische Ausrichtung said:

Is it possible to downgrade the Universal license from 2.2 to 2.1 under macOS?  

It is possible to 'roll back' to a previous version when using the Affinity Store version of the app, however the Mac App Store version does not allow for this, as Apple only provide the latest update through the MAS.

Can you please confirm for me, are you using the Affinity Store or Mac App Store version of the Affinity apps? :)

Link to comment
Share on other sites

10 minutes ago, Dan C said:

The failure to correctly understand these profiles/profile names causes the list to appear in the incorrect order in-app, and when selecting one of these profiles the app will silently fall back to a previously selected/default profile, causing the issue to appear as though the app doesn't retain the colour profile option selected.

Hi @Dan C,

Out of interest is this specific to the OS Version as the list order isn't impacted in Monterey...

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

On 9/22/2023 at 8:33 PM, Optische Ausrichtung said:

Is it possible to downgrade the Universal license from 2.2 to 2.1 under macOS?

44 minutes ago, Dan C said:

however the Mac App Store version does not allow for this, as Apple only provide the latest update through the MAS.

You can always downgrade from your Time Machine backup, even by simple drag & drop, as long as you have an administrator account/password.
(@Optische Ausrichtung, you do have a Time Machine backup, right…?)

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

  • Staff
49 minutes ago, Hangman said:

Out of interest is this specific to the OS Version as the list order isn't impacted in Monterey...

I'm not 100% certain, but as I understand it this issue is not specific to a certain OS version (or even a certain OS) as it can occur on Windows also.

The reason that some users see the 'incorrect' list, when others do not - or that some users see the 'incorrect' list only in certain Affinity apps, but not all Affinity apps on the same system is unfortunately something I'm not knowledgeable enough to answer, my apologies.

However, our devs seem to have identified this cause (and they certainly know more than I do!) so I am confident this should be resolved across all platforms/OS versions, once the fix is made available via beta/release :)

Link to comment
Share on other sites

Hi @Dan C,

Thanks for the detailed explanation which is very much appreciated. It sounds as though the cause of the issue has been identified really quickly and will be resolved equally as quickly which is great to hear… 😀

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

3 hours ago, Dan C said:

Can you please confirm for me, are you using the Affinity Store or Mac App Store version of the Affinity apps?

Thank you, I use the versions purchased from Affinity (as »Universal License«). Just for interest: How does the 'roll back' work?

 

2 hours ago, loukash said:

you do have a Time Machine backup, right…?

Oh, yeah, good idea. That is exactly what it is for. I could have thought of that myself, and I might try that. On the other hand, the update will hopefully come soon as well. 

 

Ich hoffe, ich erlebe es noch, dass die deutschen Anführungszeichen in Affinity Publisher korrekt funktionieren.

Link to comment
Share on other sites

  • Staff
13 hours ago, Optische Ausrichtung said:

I use the versions purchased from Affinity (as »Universal License«). Just for interest: How does the 'roll back' work?

Thanks for verifying that for me!

Please visit the below links for each app, where you can download the previous versions of the Affinity apps:

Photo - https://store.serif.com/update/macos/photo/2/ 
Designer - https://store.serif.com/update/macos/designer/2/ 
Publisher - https://store.serif.com/update/macos/publisher/2/ 

With these downloaded, please open the Applications folder, select the currently installed Photo/Designer/Publisher 2 and right-click the app and select Send to Trash.

Once complete, return to the downloaded .DMG file and install these as normal. You should find that all of your custom saved app settings and resources (ie brushes, assets etc) are retained through this process.

I hope this helps :)

Link to comment
Share on other sites

8 minutes ago, Dan C said:

open the Applications folder, select the currently installed Photo/Designer/Publisher 2 and right-click the app and select Send to Trash.

As a "side question": Does it make any difference, rather than simply drag'n'drop and confirm the "An item named “Affinity XYZ” already exists in this location. Do you want to replace it with the one you’re moving?" Finder dialog? 

The only difference that I'm aware of is that if you don't replace an app and move it to Trash first, it will be removed from Launchpad arrangement you may have set up, and then the new app version will be added at the very end of your (possibly already long…) Launchpad collection. 

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

  • Staff
1 minute ago, loukash said:

Does it make any difference, rather than simply drag'n'drop and confirm the "An item named “Affinity XYZ” already exists in this location. Do you want to replace it with the one you’re moving?" Finder dialog? 

No, as far as I'm aware there's no technical difference in using this method - in fact I used to provide these steps to users who wanted to roll back, but some can become confused with the requirement to replace etc and end up with duplicated apps, at times further aggravating the user.

Therefore I recommend the simpler method of removing the app first, to ensure there's only 1 'Affinity [Photo/Designer/Publisher] 2' app in Applications at any time :)

Link to comment
Share on other sites

2 minutes ago, Dan C said:

but some can become confused with the requirement to replace etc and end up with duplicated apps, at times further aggravating the user.

Fair enough… :79_smiley_cat:

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

Has anyone else also observed that the "offending" ISO Coated v2 300% (ECI) appears twice on the list? 

image.png.cbeec27a046c818a0dab0cb514276c30.png

This is APub 2.2.0 on Windows 10

I've noticed if I use the profile on top of the list, I get the strange "ÿ" in the profile name on exported PDFs.
If I choose the other (encircled) one, it will result in a normal looking profile name in the PDF...
I have only one "ISOcoated_v2_300_eci.icc" installed in "c:\Windows\System32\spool\drivers\color\"

Well, I'm sure the bug will disappear with the next update.
Thanks to all of you for finding the issue, and thanks to the good people at Serif for working on it!

 

Link to comment
Share on other sites

  • Staff
19 hours ago, k_au said:

Has anyone else also observed that the "offending" ISO Coated v2 300% (ECI) appears twice on the list? 

I can confirm our team have replicated this issue here and it stems from the same failure of reading these installed ICC profiles correctly.

I've covered this further in the below FAQ - 

Both issues are logged with our team and we're working to resolve these ASAP :)

Link to comment
Share on other sites

  • 2 weeks later...
  • Staff

The issue "Unable to correctly set colour profile in Doc Setup> Colour" (REF: AF-360) has been fixed by the developers in internal build "2.2.1.2052".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

  • Staff

The issue "[macOS] Changing the profile under Settings > Colour is not retained if an externally installed profile is selected" (REF: AF-369) has been fixed by the developers in internal build "2.2.1.2052".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

  • 2 weeks later...

I updated the suite right now to version 2.2.1. 

App wide color settings are stable now and changing document profiles works as it should.

Thanks.

I now will enjoy the new features of 2.2 😊

Advertising designer - Austria —  Photo - Publisher - Designer — CS6 d&wP — Mac Pro 5,1 (4,1 2009) 48GB 2x X5690 - RX580 - 970EVO - OS X 10.14.6 - NEC2690wuxi2 - CD20"—  iPad Pro 12.9" gen1 128 GB - Pencil

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.