Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts

With V2 I've noticed that when using the Freehand Selection Tool in Polygonal mode the selection lines temporarily disappears if I pan around the canvas. If I wiggle my cursor/stylus it reappears after 1-2 seconds so it's not a huge deal, but it can be a bit annoying at times. 

The long explanation: When you are selecting in polygonal mode then you can lift your stylus/mouse to reposition before continuing the selection (unlike the freehand mode that automatically closes the selection when you do the same). When I do this and press spacebar to pan around before continuing the selection the selection guides (not the marching ants) vanish temporarily so I can't see where I left off last. They reappear after a second or two or when I hover my Wacom pen around a bit, but I've never had this happen with previous versions of Affinity. This happens with my mouse too.

I thought it might be a known bug and would be addressed in 2.1, but no luck!

I can reproduce this time and time again, so if you need a screen recording for clarity I'm more than happy upload that here. 

Link to comment
Share on other sites

  • Staff

Hi @ChristiduToit,

Thanks for your report!

As I understand it, the Freehand Selection selection guides are treated the same as an objects bounding box - which are temporarily hidden when panning using the spacebar, so I believe this is expected behaviour.

However I certainly wouldn't expect a delay in these selection guides being re-drawn, and I'm not seeing this on Windows currently.


In my testing on macOS (M1, Big Sur) I'm seeing very similar behaviour as shown above - the selection area is shown after panning or zooming with the spacebar.

Am I missing a step in my testing to replicate this issue? If not could you please confirm your specs and provide a short screen recording for me?

Many thanks in advance :)

Link to comment
Share on other sites

@Dan C Thanks so much for the quick response here!
The way the freehand selection tool acts in your video is how I'd expect/hope for it to work, but I've made a quick screen recording showing the delay on my side.
I'm running MacOS Monterey. My iMac is a bit old (probably due for an upgrade soon), but I've never had major lagging issues, and never had any problems with the freehand selection tool like this prior to Affinity V2. 


Link to comment
Share on other sites

  • Staff

No problem at all, thanks for the further information and screen recording provided - this certainly seems unexpected!

I have tested this on macOS Monterey to ensure it was not specific to the OS version and even within a VM with limited resources, I've still been unable to replicate this thus far.

Can you please navigate to Affinity Photo 2 > Settings > Performance and provide a screenshot of your settings here for me?

Are you using an external monitor, drawing tablet or anything non-standard with your mac setup please?

I can see in your screen recording that the cursor is drawn after panning & it's only the selection bounding outline that is not shown - I would expect if this was a re-draw issue then the cursor would not be shown also, so this does narrow down the possibilities for us.

Many thanks once again :)

Link to comment
Share on other sites

@Dan C That's odd! I might just go ahead and assume this is due to my relic computer struggling to keep up with the times,, since I'm the only one who's having this problem.

I've tried all different options and combinations of settings under the Performance preferences, and they all seem to give the same odd behaviour. 
I've attached a screenshot of the original settings I had before I started tinkering, but I'm not sure it would be of much use.

I'm using a Wacom Cintiq 16, but again, the issue seems to be present even when I use a mouse, so I don't think the problem lies there - especially considering all the other tools work as they should in the app.

Fortunately not all hope is lost as I can still get the same selection effect by using the freehand selection tool in 'freehand' mode and use the shift key to toggle straight lines. It might take a bit of getting used to, but it still works for what I need it to. I just thought I'd bring it up here in case it was a known issue, or if I was just being dumb.

I wouldn't put this very high up on your priority list, but if you happen to find out why this might be happening at some point then you can just drop a comment here. :) 


Link to comment
Share on other sites

  • Staff

Apologies for the delayed response @ChristiduToit!

I've been able to test this using a Cintiq 13HD on Monterey and have now been able to replicate this issue - although not as frequently as shown in your recording, it still does occur here so I'm getting it logged with our team to see if this can be improved in a future update.

I hope this helps :)

Link to comment
Share on other sites

Posted (edited)

Same 'ish here, When I use the line select tool (magnetic, polygon et) the selection won't take..
UNTIL I switch to the brush tool and come back to my line tool.

So it looks like the selection has been made but the screen is not updated.

Windows 10

A little vid attached

Edited by Jack Malagride
Attached vid of behaviour
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.