Jump to content
You must now use your email address to sign in [click for more info] ×

Object styles have totally disappeared

Recommended Posts

I deleted a few style categories from Affinity Photo V. 2.0.4 on Windows 11, then all of a sudden AP froze and when I rebooted it, all the styles had gone.

I've tried every suggestion I could find in this forum but nothing has worked, I tried uninstalling and then reinstalling AP 2.0.4 but still no styles. And I get an error message if I try to import an individual .afstyle file from my backups. The styles have also disappeared from Designer and Publisher.

I sure hope someone can help.

Link to comment
Share on other sites


Close all affinity apps
Open APhoto
Edit > Preferences > Miscellaneous > Reset Object Styles
Try to import styles from your backups


1 hour ago, M4ndyL said:

And I get an error message 

Please specify the error message if the above does not work

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

5 hours ago, carl123 said:


Close all affinity apps
Open APhoto
Edit > Preferences > Miscellaneous > Reset Object Styles

Good suggestion, but in similar situations it hasn't worked.

This issue often requires pressing/holding Ctrl while starting the application, and then resetting the object styles using the Clear User Data dialog. This does a more complete reset than using the Preferences/Settings dialog.

7 hours ago, M4ndyL said:

then all of a sudden AP froze

Make sure you wait a few minutes before deciding it's frozen, even if Windows says it's not responding. There can be some extreme delays in V2 due to inter-app communication. (This is improved in the 2.1 beta.)

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.1.2, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.1.2

Link to comment
Share on other sites

Thank you so much for your reply!

Carl,  resetting the Object Styles that way was one of the first things I tried, and I tried it about 4 times, lol! A popup messaged declared they had been restored but nothing had changed.

Walt, I tried your advice to start the program by holding down the Ctrl key while clicking on the program icon.

It worked!

I got my default styles back, and then able to import all my .afstyle backups. Designer and Publisher all working normally now too.

Thank you both so much! I really appreciate your help.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.