Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Fonts conversted to curves unable to merge/add


Recommended Posts

  • Moderators

Hi @darkcrowgraphics,
Welcome to Affinity Forums :)
I'm not sure what you mean with "converted a selected font into curves", by font do you mean some text words? If so the letters were individually placed inside a group. To turn them into a single object, select all the letter's layers in the Layers panel and perform an Add Boolean operation (or alternatively go to menu Layer > Geometry > Merge Curves). A quicker way to do this is simply selecting the text object and perform an Add Boolean operation (no need to convert to curves first). In this case the whole text/word will be converted to a single vector object rather than to its letters individually (grouped).

If i haven't addressed your question/issue can you provide more details please (a small clip/video showing what you are doing, or some screenshots with the Layers panel visible so we can see what you are trying to achieve. Thanks.

Link to comment
Share on other sites

Appreciate the reply. I have been using ADV2 for some time now with no issues. In the past week, I have not been able to Boolean letters. In the past, I would choose a word and convert to curves, manipulate to accommodate design and then Boolean, add. It was perfect. for some reason, I cannot do the same. The curved letters do not merge, add. My ADV2 is up to date and I am completely puzzled. I tried the approach you mentioned with , layer, Geom., Merge but it failed also.  The attached pic shows how the HA and last PY where correctly Boolean with the add. The center P will not cooperate as the others. Nothing different was done to the center P. At other times, the P will not Boolean with the Y.

Screenshot 2023-01-18 062216.jpg

Link to comment
Share on other sites

This sounds similar to another problem that a few have posted about elsewhere, to do with boolean operations (including knife and shape builder) upon curves that were converted from TT/OTF glyphs. 

As a matter of interest, if you take your text in Affinity Photo/Designer 1.x, convert to curves in there and copy and paste those curves into Designer 2.x all the boolean functions work correctly.

Link to comment
Share on other sites

Apologies, you are quite correct; whilst it does seem to work for the boolean ops I've been using on converted text; using the same font as you I attempted to reproduce it and whilst it merged the H to the a and the p to the y the others didn't boolean add at all.  I concur, it's as frustrating as heck.  Sorry it didn't work for your use case :(

Screenshot_57.png

Link to comment
Share on other sites

I think the problem I am having might be similar to this issue.

Designer 2.0.3 on Windows 10.

In the attached video, I have three documents, all created in the same way:

  1. Create some text;
  2. Convert to curves;
  3. Ungroup curves group;
  4. Merge Curves;
  5. Duplicate, drag and power duplicate.

All standard stuff.

However, in two of the documents I can use the geometry functionality as expected but one of them works a bit strangely.

As you can see in the video, the first two documents allow the top two curves in the stack to have the geometry Add function applied to them but, in the third document, they don’t.
Even if the curves were constructed in a ‘weird way’ I would have expected ‘something’ to happen, but ‘something’ only happens when I use the Divide function (which simply removes both layers).
As you can also see in the video, when I select curves further down the stack, the functionality works as expected but I can’t get it to work with the upper curves.
It doesn’t matter in which order I select the curves before trying to apply the function.

The font used in the ‘problem document’ is Deftone Stylus (I don’t know where I got it from).
I have attached the ‘problem document’ in case it helps (the problem persists after saving and loading the document).

geometry-problem-with-upper-curves.afdesign

Link to comment
Share on other sites

Appreciate the input and advice. I have also tried changing the layers and maybe creating in other boards but still same result.  Boolean does not work as intended.  Hopefully it will be fixed soon. I do enjoy ADV2 but its annoying that Boolean has this hick up.  It takes to much time to correct design.

Link to comment
Share on other sites

@darkcrowgraphics as I just wrote in other thread (and some others, longer ago) it's a bug with text converted to curves, and it causes problems to booleans (add, subtract, divide...), shapebuilder and knife.

There are two workarounds.

1) One is setting all document (in document properties) width to 1px, doing all operations with booelans, shapebuilder or knife, then set in document properties the width to what it was.

or

2) And the one I found out (also for booleans, shapebuilder and knife), set 'copy as svg' in preferences->general. Leave it permanent or not, as you prefer. Do a copy of your curves (converted from text) with ctrl+c or right click, 'copy', then, top menu Edit/Paste Special, then "paste as Scalable vector Graphics (svg)" (advice: make a preference shortcut for it). Get rid of a layer or group that it generates, and place with snapping the new curves object to snap to the old one, to get it in same position (no needed if it pasted in-place). Get rid of  the old one. I just detailed it better here. It's very fast to do.

I have not tested much the first one, but yep a pair of times, and it worked. I suppose each is better for different cases (ie, not willing to use the copy as svg preference or not willing to change temporarily the document dimensions, but I don't see much issue with any of the two). 

 

Edit: When using several letters, I would recommend using right click-> Geometry-> melt, as it combines all curves into one single object/layer.

 

AD, AP and APub. V1.10.6 and V2.0.3 Windows 10 and Windows 11.  Both are regular Windows,  I'm not in the Windows Insider program.
Ryzen 9 3900X, 32 GB RAM,  RTX 3060 12GB, Wacom Intuos XL, Wacom L. Eizo ColorEdge CS 2420 monitor. Windows 10 Pro.
HP Omen 16-b1010ns 12700H, 32GB DDR5 (corsair), nVidia RTX 3060 6GB + Huion Kamvas 22 drawing screen, Windows 11 Pro.

 

 

Link to comment
Share on other sites

  • Moderators

Hi @darkcrowgraphics,
Sorry the delay getting back to you. Do you mind uploading your afdesign file as well as the font file using this link please? Thank you.
There's a few reported issues pertaining to text and booleans operations and I would like to add your files to our logs so they can be tested against new builds.
Thanks.

Link to comment
Share on other sites

  • Moderators

This will be fixed in 2.1.

SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB
Link to comment
Share on other sites

Does the problem only affect the Windows version of Affinity Designer 2.04 or does it also affect the Mac version?

I'm now using the 1.0 version of Affinity Designer again because there are just too many things that don't work 100% with the 2.04 version. The problems of the 2.04 version have all been addressed here in the forum and forwarded to the developers.

I hope the next version of Affinity Designer will fix some bugs again.

I absolutely love Affinity Designer.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.