Jump to content
You must now use your email address to sign in [click for more info] ×

Long sidenotes can make following sidenotes disappear


RM f/g

Recommended Posts

Here’s a Publisher document with three sidenotes near the bottom of a text frame. The first note is a rather long one.
Notes 2 and 3 aren’t visible. Not on the page where the note references are, not on the next one.

When the third note moves to the next text frame (e.g. when inserting text before the  first note), notes 2 and 3 both appear at the top of that page.

I suspect the reports of Publisher crashing when converting footnotes to sidenotes are related to this. In a document with longer footnotes these notes were converted to endnotes without problem, trying to convert them to sidenotes resulted in Publisher crashing.

Publisher 2.0.3  / MacOS 12.6.2

 

Screenshot 1.png

Screenshot 2.png

TestSidenotes.afpub

Macbook Pro mid 2015, 16 GB, double barrel: MacOS Mojave + Affinity 1 / MacOS Monterey + Affinity 2

Link to comment
Share on other sites

Definitely a bug and a very good demo of the problem.

@JanG perhaps this is related to the crash problems you are having - do you have any really long notes and do you tend to have a lot of notes on the same page? 

Download a free manual for Publisher 2.3 from this forum - expanded 260-page PDF

Affinity 2.3.1 for macOS Sonoma 14.3, MacBook Pro 14" (M1 Pro)

 

Link to comment
Share on other sites

Playing about with this I see that if I delete the second and third then add a second I get a note position in the Footnote area. But it is 'not visible'.

Messing about with a document I make I see that the second note would show up on the next page but a third one causes the sidetones to appear at the end of the document. 

More to this bug than meets the eye.

Mac Pro (Late 2013) Mac OS 12.7.2 
Affinity Designer 2.3.1 | Affinity Photo 2.3.1 | Affinity Publisher 2.3.1 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

7 minutes ago, Old Bruce said:

Playing about with this I see that if I delete the second and third then add a second I get a note position in the Footnote area. But it is 'not visible'.

Messing about with a document I make I see that the second note would show up on the next page but a third one causes the sidetones to appear at the end of the document. 

More to this bug than meets the eye.

Good catch!

I didn't think to look for the notes in the Layers panel. Without any changes to the test document, we can see that the second note is on the right page but when clicked its bounding box is shown below the frame instead of to the side. And the third note is on the second page and when clicked its bounding box is below the right frame instead of to the side.

The issue is if there is not space on the side for the sidenote due to the previous sidenote extending to the bottom of the frame, Publisher is failing to adjust the start position of the previous note and is instead positioning the new note below the frame or the frame on the next page.

image.png.8f7d829988487a318c95aab57f38ae2b.png

Download a free manual for Publisher 2.3 from this forum - expanded 260-page PDF

Affinity 2.3.1 for macOS Sonoma 14.3, MacBook Pro 14" (M1 Pro)

 

Link to comment
Share on other sites

  • 3 weeks later...
  • Staff

Hi @RM f/g,

Thanks for your report and our sincerest apologies for the delayed response here. We are exceptionally busy following the release of V2 and we thank you for your continued patience and understanding here.

I can confirm I've replicated this issue and a few others when using long sidenotes & therefore I have logged these with our developers for you now.

I hope this helps :)

Link to comment
Share on other sites

  • 3 weeks later...
  • Staff

The issue "Sidenotes set 'Towards / Away from Spine' that are long enough to cover one another are hidden, or displayed on the last page incorrectly" (REF:  AFB-7222 ) has now been fixed by the developers.
This fix is included in build 2.1.0.1706 (or later) which is already available as a customer beta and will be included in the next release.
Customer beta builds are announced here and you can participate by following these instructions.

If you still experience this problem once you are using that build version (or later) please make a new thread referencing this one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.