Jump to content
Andrew Skinner

Fuji X-E2 firmware v4

Recommended Posts

I'm sorry if this has been raised before or this is the wrong place.

 

Affininty 1.4.1 opens X-E2 RAF files but not if the firmware has been updated to version 4.  This is such a big upgrade almost all owners will.  RawTherapee is in the same position.  I'd attach a file but they are too big.

 

Andrew

Share this post


Link to post
Share on other sites

Hi Andrew,

In addition to MEB's reply it is still possible for you to open the image in Affinity by using Apple's Core RAW engine. To do this:
1. Open up another image (any JPG will be fine)

2. Enter Develop mode

3. Click on the Assistant Options (Tuxedo icon on the toolbar)

4. Change the RAW Engine to Apple (Core Image RAW) and then close the dialog
5. Close the image you had open and then open your Fuji RAW file

 

It should now open in Affinity using Apple's own RAW engine.

Share this post


Link to post
Share on other sites

Thanks.  Sorry again if this was a duplicate, I did try to look.  I'll probably use OOC jpgs pending the hoped for fix though the Apple RAW engine is a clever suggestion and deeper into Mac than I'd get alone.

 

Andrew

Share this post


Link to post
Share on other sites

Well, I'm glad I came by today. I had been sort of annoyed at the problem lately. Each time I tried to open a RAF file, Affinity 1.4.1 would quit on me. I wasn't sure if my Fuji X-E2 had anything to do with it. Now Sean P came in and saved the day. Until MEB fixes the bug, I'll be grateful to you Andrew!

Share this post


Link to post
Share on other sites

Hi

Downloaded Affinity tonight and it shuts down as soon as i try to import a Fuji RAW file(updated) from X-E2. Is there any news on fix for this.

 

Best

 

Andy

Share this post


Link to post
Share on other sites

Hi Alton Land, Andyw,

Welcome to Affinity Forums :)

 

@Andyw,

Have you tried to change the RAW engine to Apple (Core Image RAW) as @Sean P suggested in post #3? It should open the RAW correctly.

The Serif Labs RAW engine wasn't fixed yet.

 

@Andrew Skinner,

Tha latest Mac App Store version is 1.4.1. There's no new updates (yet).

Share this post


Link to post
Share on other sites

Hi, i've the same problem. With the 1.4.2 beta 5 (RC1), I change the raw engine to Apple and open the files, but Affinity photo crashes randomly.

 

¿ When will you fix this bug with Fuji X-E2 raws ?

 

Thanks you,

Daniel

Share this post


Link to post
Share on other sites

Here is one more X-E2v4.0 user with RAF issues with Affinity Photo, with AP either freezing or crashing.

I tried the switch to the Apple RAW engine and even that is not a good fix. The RAF opens but only presents itself as a black image in the AP develop window. This is not an issue with the Apple engine as the RAF will open in Preview.

 

My current workaround is to use Lightroom to convert the RAF to a DNG which will open in AP.

Needless to say this is an unacceptable kludge making Affinity Photo a bit of a white elephant for Fujifilm X-Series shooters.

 

I can only hope that a fix is in the works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.