Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Weird problems since installing Affinity Designer


Recommended Posts

Since I installed Affinity Designer I have been having trouble with my Mac.  It keeps saying that my printer is offline (its not and works fine for all other devices)  I have tried everything I can think of to get it working from the Mac with no luck.  Also, when I connect my Canon camera to import RAW files into iPhoto the Mac is now telling me that the files are CR2 files and cannot be recognised by the Mac, which is strange as up until now there has never been a problem importing these files.  I'm guessing that its AD causing the problem.  I had a trial version of AD which expired and I can't uninstall that, each time I go to open an AD file it automatically launches the trial version and takes me to the Affinity website to buy the full version (which I have done.)   I can open the full version though. Your thoughts folks?  What's going on?

Link to comment
Share on other sites

move the trial version of ad to the trash, this should be enough to force the doubleclick to open the purchased app.

if the system does not recognize the application change and claims that the app cannot be opened because it's in the trash, you can rightclick on the icon of any ad image, select "get info" and, in the "open with" section of the window that just appeared, select affinit designr from the dropdown menu and click on the "change all" button.

 

i have no idea of what could be the cause of the other problems you wrote about.

take care,

stefano

Link to comment
Share on other sites

  • Moderators

Hi funkymama,

Welcome to Affinity Forums :)

Drag the trial from your Applications folder to the trash and empty it.

It should now launch the Mac App Store version, if not restart your computer.

It's unlikely that Affinity may be causing that type of issues. Have you installed any other software recently (drivers included)?

Link to comment
Share on other sites

Hi, thanks for those comments. I can't actually delete the trial version, when I drag it to the recycle bin it will not delete. I have not installed any other programs apps or drivers recently, it's only since I installed Affinity so I am wondering whether there is a problem with affinity? Any further ideas?

Link to comment
Share on other sites

what exactly happens when you try to drag affinity designer's icon to the trash? do you get an error message?

as a last resort, i'd suggest the following:

 

1) reboot your mac: this will ensure that any process still in memory is shut down. i also found that some strange behaviors of the finder stop when rebooting.

2) try to drag the app to the trash once again, if this still doesn't work, proceed with the following steps

3) open the system preferences app

4) click on the keyboard icon, then on the shortcuts tab

5) in the left panel, click on services

6) in the right panel, locate "new terminal at folder" and tick its checkbox, if it's not already checked; then close system preferences

7) in the finder, go to the folder containing affinity designer 

8) right click in the icon of this folder (that is, the folder that contains affinity designer), choose "services", then "new terminal at folder"

9) in the windows that opens, type

 

rm -fr "Affinity Designer Trial.app"

 

and press enter. this should delete the app at system level.

 

please be careful:

 

1) what you delete this way doesn't go to the trash, it's deleted for good

2) if you make mistakes in the command, you can destroy something useful unexpectedly, with no or very little chance to recover it

3) if your user has administrative privileges, an error in the command can severely damage your system (the software, not the hardware)

 

i won't assume any responsibility :)

take care,

stefano

Link to comment
Share on other sites

Might I suggest before reaching for Terminal (that’s such a scary sounding name!) have you tried the other two standard methods of deleting an app, file or folder;
Left click once on item to highlight it then press; cmd+Delete.

Or;
Right click on item and from the pop-up choose; Move To Trash.
Do these methods fail as well?

 

As to CR2 files not being recognised I couldn’t really say why. But…
Some years back my iPhoto stopped recognising jpeg from a Kodak I had at the time when it was plugged in. Claimed they were an invalid format of all things!
I forget why I did it now but I eventually took the SD card out of the camera and put it in a card reader. Plugged that in and iPhoto was more than happy to accept them. The exact same files! But whenever the card was in the Kodak iPhoto didn't want to know.
It’s maybe worth a try.

macOS 10.15.7  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.