Jump to content
andy-in-mke

Strange rasterizing of opacity gradients when exporting to PDF

Recommended Posts

I’m getting ready to send some rack card pdf files to our service bureau when I noticed something strange...

 

I’ve got a couple png files (done in Photoshop) embedded in the Affinity Designer file, and they look fine in Affinity Designer. But when I export them to PDF and open them in Apple Preview, I’m seeing things that I don’t like. 

 

In particular there’s a strange milky-white quality to the lower edge of one embedded object (see attachment) when it should be a smooth opacity gradient... In the second embedded object immediately below the first one, the lower edge of the object cuts off sharply when it should be a more gradual opacity gradient. Again, it displays properly in Designer but not in Preview. Is it going to print out this way? 

 

Is there a pdf exporting setting I need to use?

 

Is there something else I need to tweak in the Photoshop > Designer > pdf Export pipeline?

 

Thanks,

 

Andy

Share this post


Link to post
Share on other sites

Hi Andy, 

 

Have you tried opening the PDF in Adobe Reader/Acrobat Pro? 

 

Preview doesn't always handle PDF files the same way as Adobe. 

How does the PDF look if you open it in any other software that you have that can open PDF files? 

 

Also, as Miguel stated, please upload/attach the images/files, perhaps including the PDF? 

Share this post


Link to post
Share on other sites

Hi Andy, 

 

Have you tried opening the PDF in Adobe Reader/Acrobat Pro? 

 

Preview doesn't always handle PDF files the same way as Adobe. 

How does the PDF look if you open it in any other software that you have that can open PDF files? 

 

Also, as Miguel stated, please upload/attach the images/files, perhaps including the PDF? 

 

 

Hi Paul,

 

It’s been so long since I’ve used Adobe Reader I don’t have it on my system. Just tried to install it and couldn’t. I double click on the Adobe Installer, I get the standard Apple dialog (“This is an application downloaded from the internet, are you sure you want to install it?”), I click OK, and then nothing happens. Nothing. The last two times I’ve tried to install Adobe software this has been the result. 

 

I did open up the pdf in several other apps:

 

Photoshop

Pixelmator

AutoDesk Graphic (formerly iDraw)
Intaglio
Safari
 
They all display the embedded graphics with the milky fringe. So at least it’s not just Preview. In fact the only app that displays this properly is Affinity Designer!  :-)
 
Andy

Share this post


Link to post
Share on other sites

Paul,

Here is the pdf.

Andy

Hi Andy, 

It is definitely a transparency/flattening issue. Have you tried flattening/merging the layers with the montaged images? 

Paul. 

Share this post


Link to post
Share on other sites

Hi Andy, 

It is definitely a transparency/flattening issue. Have you tried flattening/merging the layers with the montaged images? 

Paul. 

 

Paul -- I rasterized the embeds and now it looks good. Thanks. -- Andy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×