Jump to content
You must now use your email address to sign in [click for more info] ×

Photo V2 Metadata time shot not correct


vjb1976

Recommended Posts

It seems like AP V2 is using UTC rather than local time to set the time a photo was taken. I took a photo of my computer screen at 3:38 PM my time (UTC -8) but the metadata for the photo is showing 11:38 PM. This is happening for jpg and Nikon raw files. The correct local time is given in the metadata when opened in V1.

image.png.26618916380bb6f71a0d8c104d22124b.png

VJB_7802.JPG

Link to comment
Share on other sites

Another user mentioned that, too, but it's not logged as a bug yet that I can see. 

 

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

  • 3 weeks later...
  • Staff

The date/time widget does use local time (if you change your system settings you'll see the widget adjusting to match; on Windows you have to restart the app to see this update though), but it looks like the value we're initially passing into it has the local time offset erroneously re-applied.

Link to comment
Share on other sites

  • 4 weeks later...

Similar comment.  Using MacMini (M1) with system 13.0.1; Photo2 v 2.0.4. live in UTC -7; Issue is with Metadata panel, category EXIF, "Date Shot" field.  

Category: EXIF, "Date Shot" field shows incorrect time, the time displayed is my local time minus 7 hours (i.e. 7 hours earlier than I took shot);

Meanwhile in Category: Detail > XMP > "Create Date" field shows correct time (as does the "Modify Date" field); and in Category: Detail > EXIF >"Date Time Original" field shows correct time;

Lastly, in the Category: RAW  "<exif:DateTimeOriginal>" is also correct

Link to comment
Share on other sites

  • 1 month later...
  • Staff

The issue "Metadata Panel - EXIF 'Date Shot' field incorrectly re-applies the local OS time offset for images lacking timezone data" (REF: AFP-6061) has been fixed by the developers in internal build "2.1.0.1736".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.