Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Preserve Alpha disappears in Live Blur filters


Recommended Posts

When using the Live Gaussian Blur, the preserve alpha checkbox is available when it is added. After closing and opening it again, the preserve Alpha checbox disappears? (Same happens with box blur and probably with other blurs too)

 

image.png.f33b90360d67016ddd5168c1de629e5f.png

 

Also interesting enough, after pressing the merge button, the filter is blocked for editing (the edit dialog does not come up) until you select another layer and switch back, then the edit dialog comes up again?

BTW any idea what the merge button does??

Link to comment
Share on other sites

1 hour ago, loukash said:

It applies the filter destructively on the next pixel layer below.

Thank you for clearing that out.. that was also my expectation (destructively applied(, however as i am mostly working with image layers, nothing was happening. Pixel layer was the magic word here :)

I would suggest that when the filter is a child of an image layer, to hide this button or have the image layer rasterize to pixel (with a warning from assistant), which would make more sense. Secondly it is kind of strange behaviour when the (blur) filter in on top of image layer and a pixel layer is below it. The image layer gets blurred when merge is pressed, it skips the image layer and merges with the pixel layer below. It makes sense but i don't think that is expected behavior.

Link to comment
Share on other sites

3 minutes ago, Zero1 said:

I would suggest that when the filter is a child of an image layer, to hide this button

No, because you can also have another pixel layer as a child of the image layer, and you may want to merge the filter into that one
The possibilites are immense. :) 

Link to comment
Share on other sites

1 minute ago, loukash said:

No, because you can also have another pixel layer as a child of the image layer, and you may want to merge the filter into that one
The possibilites are immense. :) 

Haha, that is true, but still think it is detectable whether the merge is going to apply to the "parent" image or a child pixel... (at the end it applies to something and is processed if applicable, so it can be detected too...). Maybe hiding the button would case confusion (why not shown etc), but rasterizing the image layer would make sense.

Link to comment
Share on other sites

4 hours ago, Zero1 said:

When using the Live Gaussian Blur, the preserve alpha checkbox is available when it is added. After closing and opening it again, the preserve Alpha checbox disappears?

Getting back to your original question, which I think we have not addressed: The Preserve Alpha checkbo does not disappear on Windows when the Live Filter layer is closed and reopened. At least for the file I tried it on.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0..3  and 2.0.3.1670 beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta
iPad Pro M1, 12.9", iPadOS 16.3, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.3 / Affinity Designer 1.10.6 and 2.0.3 / Affinity Publisher 2.0.3

Link to comment
Share on other sites

1 hour ago, loukash said:

Hiding something is a bad UI idea. If a function is unavailable, then it has to be "grayed out".

You are completely right! Which brings us to the original question :) A checkbox is being hidden without reason... which is bad :)

Link to comment
Share on other sites

1 hour ago, walt.farrell said:

Getting back to your original question, which I think we have not addressed: The Preserve Alpha checkbo does not disappear on Windows when the Live Filter layer is closed and reopened. At least for the file I tried it on.

That is why this post is in macOS Beta forum :)

Link to comment
Share on other sites

  • 4 weeks later...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.