Jump to content
You must now use your email address to sign in [click for more info] ×

Language not updating properly despite showing native language results on MacOS 13 on Affinity Publisher 2.0.0


Recommended Posts

Hi!

I've run into a unique problem with the language feature on MacOS.

I have set both my autocorrect and general preferences to English (Non Uk, e.c.t.). I have a template I am editing, and no matter how many times I reset the language preference to English, when Affinity Publisher reopens, the * before the language doesn't go away, and my English content is being autocorrected to a non-english language. (I thought it was Spanish, but it's almost a mix of everything but English). So I resent English, it asks to restart, I let it restart, and it doesn't change anything.

I've attached photos of the document, and settings. (It's a mock-political magazine, there is no political content on it. The words are just nonsense to fill.)

Thank you so much for taking the time to read this, and any support would be much appreciated! I've looked everywhere on the forums, (for about two hours), and YouTube to no avail. Thanks!

 

Screen Shot 1.png

Screen Shot 2.png

Screen Shot 3.png

Link to comment
Share on other sites

First check what language your text is set to...

Highlight some text
Go to the Character panel
Scroll down to the Language section
Check what setting Spelling is set to there

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

6 minutes ago, carl123 said:

First check what language your text is set to...

Highlight some text
Go to the Character panel
Scroll down to the Language section
Check what setting Spelling is set to there

Aha! That did it. Oddly enough, I knew this, and checked it first, and I somehow must have switched it from English to Spanish. (What I thought, but didn't want to assume.) 🥲. So I must have dumped myself out somehow, and just never thought to check it. Lesson learned! Thank you for the quick response and your very helpful info! I'm sorry if I wasted your time.

 

Link to comment
Share on other sites

This trips up a number of users, @GraphicsForWhatevs. The key point is that the language you pick in AutoCorrect is not a setting, that determines which corrections are used. It simply gives you access to see or modify the set of corrections that will be used if you are using a particular language. But if you're using a different language, a different set of corrections will be used.

Separately, you have to say what language you're using for the text itself :) 

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.