Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Designer instantly crashes on open


Recommended Posts

Hi, I've been trying to fix this forever and it isn't just an Affinity Designer issue, this also doesn't work for Photo, just crashes on open. What I mean by that is I can't even open the app, the little box comes up and boom crash. 
 

I tried using photoshop and it said my graphics driver was incompatible, even though I have the most recent driver and have completed a full clean installation of my graphics driver it still says "Open CL Unavailable" in photoshop, and Affinity apps won't open at all. 

I don't know if this is just limited to me but here are my specs:

- Windows 10

- GeForce GTX 1070 with latest driver (I've also tried studio and other drivers and it still says "your driver is out of date" even though it's the most recent driver.)

- Old integrated intel 550 graphics which I'm not running the application through, it's set to my High performance GPU, in both GeForce control panel and in my graphics settings.

- I'm running on an older version of affinity apps, but I have tried the new ones and they don't launch either.

 

Another interesting factor to this problem is that I've download GPU-Z and it says OpenCL is checked, my OpenCL.dll is in System32 and it detects my graphics card. I'm not sure if I'm supposed to have twelve OpenCL.dlls in System32, but I'm hesitant to delete them, because well it's a system32 file. Yet with it detecting my graphics card in photoshop (and look I understand this isn't the adobe support site but I'm using it as a debugger so I can know when OpenCL is available), it still has OpenCL greyed out and I always get a pop up saying "Your Graphics Card Isn't Support, Please Update Your Drivers"


It's incredibly frustrating and I've asked everywhere, from Nvidia's own subreddit to Quora and Yahoo answers, and nobody can seem to help. If there is anyone out there that can help me I'd greatly appreciate it, I need these apps for work.

Link to comment
Share on other sites

@OreOscar welcome to the forums,

Where did you update the drivers for your GeForce GTX 1070, through Windows or directly from the manufacturer (Nvidia)? It's always best to update from the manufacturer, as Windows update for such things maybe a version or more behind.

Check the following post for the minimum requirements to run Hardware Acceleration/OpenCL.. There's a minimum requirement for Direct3D.

Also read through this one concerning issues like you're having.

Finally please post a couple of the latest Crash Reports/Dump Files.

 

Affinity Photo 1.10.5.1342 ; Affinity Designer 1.10.5.1342;Affinity Photo 2.0.0.1640 Affinity Designer 2.0.0.1640; Affinity Publisher 2.0.0.1640; Affinity2 Beta versions. Win10 Home Version:21H2, Build: 19044.1766: Intel Core i7-4770, 3.90GHz, 32GB Ram, Nvidia GTX 645, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Link to comment
Share on other sites

Thank you I’ll try looking through what you have suggested, and yes I did download from the manufacturer’s website, I didn’t even use the experience app, to eliminate all possibilities. 
 

update: I used an online tutorial from YouTube and it fixed the issue, basically all I had to do was copy opencl64.dll from my graphics driver location in system32 then paste it directly into system32 after deleting the old already downloaded OpenCL.dll that was there, and I restarted my system, and BOOM. It worked! Thank you so much for your help now I can finally get back to making my thumbnails, I greatly appreciate it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.