Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Affinity Designer 2- crashing and Freezing when saving certain files


Recommended Posts

Having upgraded to Designer 2, on Mac 12.6, I am having major problems.

Some (but not all) files created in Designer 1, cannot be saved after the simplest of actions. The screen freezes at "Save document" and all I can do is Force Quit.

The problem is that once a file is opened in Designer 2, I can't open in Designer 1.

I've tried re-installing the App but no change.

Other files can be opened and worked on OK.  At the moment its about 50% of the old files that I've opened where there is a problem.

It's all a bit of a nightmare and severely affecting my confidence in Affinity.

 

Mike

 

Screenshot 2022-12-05 at 11.44.18.png

Link to comment
Share on other sites

The response and silence from Affinity is deafening. Now files created in  Affinity Designer 2 are crashing when I try to make changes. And of course I can't open in Designer 1 to fix.

Can anyone from Affinity help?

It looks like moving to Designer 2 was a big mistake - in terms of both payment and production.

What can I do? Apart from go back to Illustrator?

 

Link to comment
Share on other sites

11 minutes ago, mikejard said:

Thanks.

Have downloaded Beta and version 2.03.

I can’t open affected files in either version.

Here's one of the affected files - can you open?

 

Mike

 

23CWC Village.afdesign 9.97 MB · 0 downloads

Hi Mike, I can open & save without any issues, I am on Big Sur

The attached has a rectangle added then the file was saved

There is a bit of a difference in file sizes, don't know if this might be part of your problem or if the forum software has messed with anything your uploaded file is 9.97 MB, my downloaded & saved versions are 5.8 MB

23CWC Village copy.afdesign

 

Link to comment
Share on other sites

2 minutes ago, mikejard said:

Murfee

Thanks for trying file. I'm using Montery (12.6) - and can't open the file that you were able to open and change.

It's all very confusing and frustrating. It used to just work. Now I'm in a bit of a death spiral.

I know this might sound a bit odd...have you rebooted your Mac, can often fix some weird problems

Link to comment
Share on other sites

4 minutes ago, mikejard said:

I'm struggling....

I feel for you but doubt I can help further, I suppose you have tried uninstalling V2, reboot then reinstall

Could it be trying to open a file that it no longer has access to, possibly on an external drive. Try going into Preferences General & making sure that reopen documents on startup is not ticked

image.png.1c86a97624978de932ff9d54a408053a.png

Link to comment
Share on other sites

1 minute ago, mikejard said:

Thanks for all the help - much appreciated.

For an uninstall do you know if there are certain files (other than the app) that need to be removed?

I don't but @Gabe will 

It will help if you add where you bought the App from, Mac App Store or direct from Serif

Link to comment
Share on other sites

9 minutes ago, Murfee said:

Have you tried booting in Safe Mode, then reboot normally

I do not have the font Myriad Pro but the file opened fine for me, is there any chance of a font corruption on your system? Do you have lots of fonts installed?

Lots of fonts. But will try.

 

14 minutes ago, Gabe said:

Can you try creating a new user profile on your mac and see if that's fine? I wonder if it's a permission error of some sort. 

Will try later - I've got to do some work that doesn't involve grumpy apps.

Link to comment
Share on other sites

18 minutes ago, Gabe said:

Can you try creating a new user profile on your mac and see if that's fine? I wonder if it's a permission error of some sort. 

I just opened a pdf from the last time everything was working fine - and it opened OK as an Affinity file. All the layers are a bit of a mess - but at least I've been able to open it. I don't know if there'll be anything else missing from the original Affinity file but it's a start. Even with a few days of work missing. But still worried everything is going to fall over again.

Link to comment
Share on other sites

Hi @mikejard, I have just seen another post where the user can't open some V1 files. 

The file contained the font Myriad Pro, this is a font from Adobe CC... just a thought but have you enabled these fonts, I am wondering if Designer knows it is there but can't access it so will not open the files that contain it. 

That may be why some V1 files can be opened but not others, if they do not contain Adobe CC fonts then they open.

Could you try removing that font from your system temporarily and see if you file opens?

Do you have Publisher? if so does the file open in that

It could be that Designer has a problem with Adobe CC fonts that it can't access 

@Gabe does this sound feasible to you?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.