Jump to content
You must now use your email address to sign in [click for more info] ×

Original file associations irreparable with Affinity Photo 2

Recommended Posts

After installing Affinity Photo 2 none of the file associations I had for files that are also served by Affinity Photo 2 open.
Nothing happens when I click a *.pdf, *.jpg, whatever, not even Affinity Photo 2 itself.
In the Windows settings for standard apps all my original associations are still active. But none of them work.
Choose "Open with" from the right click menu let me choose an association, however, nothing happens. It looks as though the installation of Affinity Photo 2 disabled all other software associated with the files.
This ended miraculously when I removed Affinity Photo 2 after much trial and error.
I hope this is no double post, I cannot find a similar issue solved on this board.
Yes, I do need help, thank you for your kind interest.

Windows 11 Pro 64bits
Versie    22H2
Build 22621.819
Windows Feature Experience Pack 1000.22636.1000.0

I edit this post to alert visitors that once you have created an item with Affinity Photo 2 and you uninstall this version, Affinity Photo version 1 can not open your work made in version 2. Bad luck......


Edited by salto
Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
  • Staff

Hi @salto,

Thanks for your report and our sincerest apologies for the delayed response here. We are exceptionally busy following the release of V2 and we thank you for your continued patience and understanding here.

On 12/2/2022 at 5:29 PM, salto said:

I cannot find a similar issue solved on this board.

I agree, I haven't seen this issue reported previously and I do not understand how Affinity could affect other applications opening to view documents, when your default is set to an app that is not Affinity Photo 2.

Is this still occurring for you in the latest update (2.0.4) or have you chosen to leave Affinity uninstalled on your PC at this time?

If you don't currently have the app installed, it may be worth trying the .EXE install versions, rather than the .MSIX versions - so please do let me know :)

Link to comment
Share on other sites

1 hour ago, salto said:

Can you not have both versions installed?

Yes, you can have both installed, and it does not cause a problem like you've described.

-- Walt

Desktop:  Windows 11 Pro, version 22H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 11 Pro, version 22H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.2.0 and 2.2.0. beta/ Affinity Designer 1.10.6 (.1665)  and 2.2.0  and 2.2.0 beta / Affinity Publisher 1.10.6 (.1665)  and 2.2.0  and 2.2.0 beta
iPad Pro M1, 12.9", iPadOS 16.7, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.7 and 2.2.0 and 2.2.0 beta/ Affinity Designer 1.10.7 and 2.2.0 and 2.2.0 beta/ Affinity Publisher 2.2.0 and 2.2.0 beta

Link to comment
Share on other sites


But did you try @Dan C's suggestion of installing the .msi (EXE) version of APh?  So, NOT the .MSIX version.  (If installing the .EXE version works for you - personally I prefer it to the .MSIX version - you can then uninstall the .MSIX version without affecting any assets, plugins etc. you might have already added to APh 2.  This is what I did.)

And, to underline @walt.farrell's comment: I have all the version 1 and version 2 apps happily co-existing on my PC.

Win 10 Pro, i7 6700K, 32Gb RAM, NVidia GTX1660 Ti and Intel HD530 Graphics

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher, version 1 and now version 2.

iPad Pro (11") running Affinity Photo and Designer (iOS 16.5) version 1 and all three version 2 apps.

Link to comment
Share on other sites

  • Staff

You can find these .EXE versions at the following links, by selecting the Also Available : EXE option below the main download button -

Photo - https://store.serif.com/update/windows/photo/2/
Designer - https://store.serif.com/update/windows/designer/2/
Publisher - https://store.serif.com/update/windows/publisher/2/ 

Please uninstall the .MSIX versions through Settings > Apps before installing the .EXE versions, as emmrecs mentions above this will retain your custom brushes, assets, settings etc :)

Link to comment
Share on other sites

  • 2 weeks later...

Unfortunately, my system got in complete disarray following the installation of the *.exe version.
I don't think it had to do with the *.exe  itself, I think yet another installn/uninstall of Affinity after MSIX and *.exe was too much.
Microsoft store threw errors, and I could not do a full repair because I do not have or want to have a Microsoft account. I work with a local user and admin account only.
When I could not even start NotePad because the file association was missing, and I found that the error codes were mostly related to rights and permissions, I gave up.
I did a repair install of Windows, which has kept me busy this week. But Affinity Photo2 is working fine as is the rest of my system.
Thank you for your kind interest!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.