Jump to content

APhoto/ADesigner: Do not zoom new or opened docs to full view if they're small

Recommended Posts



This has been annoying for me ever since day one. I am using a 27 external monitor for my mini. When I create a new document or open an existing one, as long as the document size is smaller than the available viewport, the document will zoom to the full possible extents of the viewport.


If you create or open a 32x32 pixel document, just for the sake of illustration, then your full viewport (nearly 2560x1440) will be filled with a huge white, empty canvas (in case of a new document), or with a pixelated blob (if an existing document). This is due to the fact that the document will be resized to the available viewport space.




I understand that when a new or existing document is bigger than the available viewport size, it will be scaled so the full document will fit and be visible in the viewport.


But if the new or existing document is smaller than the available viewport space, why can't the document just be opened at it's actual size and let ME (aka the user) decide whether I want to zoom in on it or not?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.