Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Publisher crashing 100% of the time


Recommended Posts

 

I’ve got a document I can no longer open - every time I try it crashes Publisher and I have to Force Quit.

The document worked yesterday. I reopened it today, and this happens.

The same thing happens on a backup of the document from a couple of days ago. Other documents seem to work okay.

The fact that yesterday it worked and today it doesn’t, even using a backup that is therefore the same document I started working on yesterday, is very odd.

The document is something I’ve been working on for weeks, so restarting from scratch is not an option.

Computer: M1 iMac, 16Gb RAM, Monterey 12.6.1. There are no external devices connected to the computer.
Publisher: 1.10.5

I’ve tried turning off Metal compute acceleration, setting display to low res, and reducing display options all the way down to software only.  On ‘software only’ I can work on the document, but it’s so slow it’s unusable. Every other setting just causes Publisher to freeze completely. Sometimes it shows as "Not Responding", sometimes it just freezes with a never-ending beachball.

I’ve restarted the computer multiple times, and tried with only Publisher running and nothing else (not that memory is an issue according to Activity Monitor).

The document is about 100Mb with embedded images, or 41Mb with linked images. Both versions cause the same problem. I cannot post the document publicly.

Any suggestions?

 

Link to comment
Share on other sites

5 minutes ago, Mooxo said:

The same thing happens on a backup of the document from a couple of days ago

If you have an earlier backup that works correctly, you may then be able to switch to ‘software only’ mode and import the other pages from the "duff" document

Or wait until a moderator gives you are private upload link so they can see if the document opens OK for them

 

Link to comment
Share on other sites

Thanks. Tried that, doesn't work. Document still crashes as soon as I go back from Software only mode.

To make matters worse, I've just tried resetting Publisher to default settings. When I start it, it won't let me sign in because Affinity's website is down for maintenance! Please tell me the sign it page is not going to be down until v2 is released tomorrow? I cannot now work on anything at all because I can't sign into the product!

ETA: Discovered I can bypass the sign in screen - phew! Resetting didn't fix the problem though.

Link to comment
Share on other sites

13 minutes ago, Mooxo said:

Thanks. Tried that, doesn't work. Document still crashes as soon as I go back from Software only mode.

Not sure exactly what you did, but to clarify

If an old document works in non-software mode try importing pages from the "duff" document one by one or in batches (you may need to switch to "software only" mode to do this, if so you will need to switch back to non-software mode after each import to test the document)

Hopefully, this procedure will help you narrow down the problem if a specific page is causing it and therefore you can just skip that page and redo it manually

Tedious? Yes, but without seeing the document it's only guess work here

Link to comment
Share on other sites

Every version I have of this document, including the oldest backup, crashes, except in software-only mode.

I've tried opening the oldest backup in software only, resaving it with zero changes to a new location under a new name, then opening it in regular (or at least OpenGL) mode, but it crashes. I've tried adding the newest pages to it in software only mode, but again it crashes in any other mode.

So to clarify, the only way I can work on this document, including every backup version I have, is in software only mode, which is unusably slow. It would take weeks to complete the document in software only mode, but it will also take me weeks to recreate it from scratch. 

I can't seem to get a crash report out of Publisher (or Console.app) because it just hangs and has to be Force Quit each time.

Link to comment
Share on other sites

  • Moderators
11 minutes ago, Mooxo said:

Uploaded - thank you.

Yup that file doesn't seem happy at all.  I'm also just getting a beachball straight away.  I'll poke it some more, as i've had someone on the Team try opening it on Windows and seemed to open fine.  So hopefully i can try a few things on Windows with the file and then try opening it on Mac and see if its any better :) 

Link to comment
Share on other sites

I know you guys are busy with v2 now, but I just wanted to update this thread to say I've recovered some of the document.

Having bought the fancy new universal licence, I tried installing the Windows version of Publisher in a VM on my iMac. It works great, but the document still crashed. So I deregistered that and installed it on a real Windows laptop. That was able to open the document without any problems.

I tried a variety of things (removing master pages, splitting the document etc), and it seems most likely that like multiple embedded SVG files are the cause of the problem.

I've managed to make a version of the file that contains almost everything except those embedded SVGs, and that opens correctly on the Mac. So I can use that as a basis to rebuild the document.

Also for information: the document works on the iPad version. It's just the Mac it doesn't like. The iPad is an M2 version, so maybe it's the M1 it doesn't like.

Thanks again for your earlier reply. I would never have thought to try Windows. 

Link to comment
Share on other sites

Another update. I've spent three hours this morning rebuilding the document from what I could salvage via Windows. Everything worked perfectly.

Until I closed it and then tried to re-open it. And then it cashed Publisher almost instantly.

I had saved extra copies of the document about every half hour as I worked today, so I tried opening those. Exactly the same problem.

I don't know what is causing this, but I think at this time I have to abandon the whole project. I've lost weeks of work and I don't want to lose more time on it. It's knocked my confidence in Publisher, though I've used the software for many bigger and more complex projects, so I hope it's just a one-off.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.