Jump to content

Pencil and Brush Super Laggy on New iMac

Recommended Posts

This is really disappointing.  Could it be some kind of conflict between my Wacom settings and Designer?  I never had this problem with my old MacBook Pro, strangely.  I'm using a brand new iMac, and there's not only horrible lag when trying to draw a line at any thickness, and even with fill only, and not only that, there seems to be some kind of spillover drag, too.  As if the pen is way too sensitive, and it overshoots the line as I try to end it.  I'd use the pen tool, but I'm trying for more of a loose, sketchy, not so perfect line shape, so this is really distracting to me.  The more slowly I try to draw, I lose the natural flow of the sketchy line I need to make, so it's just not working.  I'm using an Intuos3 tablet, if that helps any.  The canvas size isn't any bigger than any I've used before, either...Not sure what's going on.


What can I do to help reduce the lag?  I'm not getting any spinning wheels, but it's just slowwwwwww.....Hope someone might have some advice asap!


Happy New Year to everyone, btw!  :)




ONE MORE THING:  Is there some way I can remap a Japanese key so that I can use command+ again to zoom in?  I'm now getting used to a Japanese keyboard, and the plus requires shift to make it zoom in (though I don't have this problem when using other programs).  Is it possible to remap shortcuts through Designer?



Share this post

Link to post
Share on other sites

Hi Patchwork,


That doesn't sound right - we've got lots of new iMacs in the office of all different specs and none of them show this (that I'm aware of). Can you tell me what kind of iMac you have? Is it the 4k, 5k, which processor, graphics card, etc? 




Share this post

Link to post
Share on other sites


I solved some performance issue just choosing a less accurate rendering in the preferences. In addition, i see that using big brushes slow down the Program (i think it's due to the dynamic preview), so keeping their size small when possible and/or disabling the dynamic preview (i don't have my mac at hand now but i'm quote sure it's possible) also cam belp.

take care,


Share this post

Link to post
Share on other sites

Sorry if this is something you have tried, but have you updated your Wacom drivers?

My old wacom tablet isn't compatible with El Capitan.. (or Maveric for that matter)

- Affinity Photo 1.7.2
- Affinity Designer 1.7.2
-Affinity Publisher 1.7.2


MacBook Pro 8 GB
MacBook Pro Mojave 10.14.6

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.