Jump to content
Sign in to follow this  
thisleenoble

Photo and Designer now unusable on 10.8.5

Recommended Posts

Since upgrading to 1.4 neither Affinity Photo or Affinity Designer work correctly on my instlallation of OS X 10.8.5. The App store versions crash as soon as I click OK to create a new document. I tried the beta version of Photo, but that just hung with a beachball of death for a few minutes before I finally force-quit it. It appeared to crash with the same error as the app store version (partial copy below).

 

Fortunately I have a copy of the older Photo app on my Yosemite partition but it seems I've lost the use of Designer entirely. Where can I download older versions of that?

 

 

Application Specific Information:

*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** setObjectForKey: object cannot be nil (key: NSFont)'

abort() called

terminate called throwing an exception

 

Application Specific Backtrace 1:

0   CoreFoundation                      0x00007fff946a3b06 __exceptionPreprocess + 198

1   libobjc.A.dylib                     0x00007fff8ec793f0 objc_exception_throw + 43

2   CoreFoundation                      0x00007fff947325b7 -[__NSDictionaryM setObject:forKey:] + 135

3   libcocoaui                          0x0000000108e3539d -[CharacterPage populateStyle] + 573

4   libcocoaui                          0x0000000108e3b415 -[CharacterPage updateData] + 1045

5   CoreFoundation                      0x00007fff94655eda _CFXNotificationPost + 2554

6   Affinity Photo                      0x0000000107f63117 Affinity Photo + 45335

7   CoreFoundation                      0x00007fff94655eda _CFXNotificationPost + 2554

8   libcocoaui                          0x000000010932e188 -[NotificationsController handleNewDocumentNotification:] + 2952

9   libcocoaui                          0x000000010932bc53 -[NotificationsController handleNotification:] + 1571

10  libcocoaui                          0x000000010932b39b -[NotificationsController receiveNotification:] + 1115

11  libdispatch.dylib                   0x00007fff91c64f01 _dispatch_call_block_and_release + 15

12  libdispatch.dylib                   0x00007fff91c610b6 _dispatch_client_callout + 8

13  libdispatch.dylib                   0x00007fff91c660c8 _dispatch_main_queue_callback_4CF + 275

14  CoreFoundation                      0x00007fff94645b4c __CFRunLoopRun + 1644

15  CoreFoundation                      0x00007fff946450e2 CFRunLoopRunSpecific + 290

16  HIToolbox                           0x00007fff9433eeb4 RunCurrentEventLoopInMode + 209

17  HIToolbox                           0x00007fff9433ec52 ReceiveNextEventCommon + 356

18  HIToolbox                           0x00007fff9433eae3 BlockUntilNextEventMatchingListInMode + 62

19  AppKit                              0x00007fff9a2a5533 _DPSNextEvent + 685

20  AppKit                              0x00007fff9a2a4df2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

21  AppKit                              0x00007fff9a29c1a3 -[NSApplication run] + 517

22  AppKit                              0x00007fff9a240bd6 NSApplicationMain + 869

23  Affinity Photo                      0x0000000107f5a404 Affinity Photo + 9220

24  ???                                 0x0000000000000002 0x0 + 2

Share this post


Link to post
Share on other sites

I managed to get both apps to load by disabling all my fonts and then re-enabling them in chunks. I was hoping I'd find a responsible corrupt font, but I re-enabled all of them and the apps still load, although a lot more of them are now showing warning triangles to do with duplicates needing to be resolved but there don't seem to be any problems as a result of that.

Share this post


Link to post
Share on other sites

That's very strange... I'm sorry you've run into problems - the crash report does indeed point towards issues with Fonts. If you encounter further issues then please let us know what fonts are installed on your system and ideally if there are any you're suspicious of (if you're able to work out any patterns!). We'll obviously try to fix anything asap!

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

I disabled all fonts and was able to get both apps to launch. I then re-enabled them in batches hoping to trace a broken font, but by the time they were all back on again everything was still working.

 

However, today both apps are crashing for the same reason. I've changed nothing about my fonts and I'm using the latest beta versions. Both apps broken and seemingly no way to downgrade.

 

Also, I don't like the new splash screens. They're dull compared to the old ones. ;)

Share this post


Link to post
Share on other sites

I spent ages (because Font Book kept hanging) going through and resolving all the duplicate font issues. In case it's significant I chose to resolve them all in favour of leaving a copy in the main library and deleting my user specific versions. Both apps seem stable now, at least I can now create new documents and open existing ones without a catastrophic failure.

So, I appear to be sorted for now but you may wish to do some testing around duplicate fonts.

Merry Christmas.

Lee

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×