Jump to content
Andy Somerfield

Affinity Designer Customer Beta (1.4.1 - Beta 1)

Recommended Posts

Purpose: Fixes

Status: Incremental bug-fix track on 1.4

Requirements: Purchased Affinity Designer

Mac App Store: Not submitted

Download: Here

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

This is an Incremental Bug-Fix release - it should be considered more stable than the current MAS version (1.4) and should be used in preference to that build, if you are experiencing any of the problems listed below.

 

Fixes

 

- Fixed crashes when loading a document which has been saved in Quick Mask mode.

- Fixed crashes when using documents in the ProPhoto colour space in Mac OS X 10.9.5.
- Fixed stroke clipping / invalidation issues.
- Fixed crashes when loading documents saved with “Delete Slices” history items.
- Fixed weird zombie-open-dialog when starting the app.
- Fixed crashes when using calibrated monitor profiles with high-accuracy LUTs.
- Fixed layer “Expand” buttons disappearing in Mac OS X 10.8.

Share this post


Link to post
Share on other sites

One more strange thing I've noticed on and off (in 1.4 and 1.4.1) is sometimes when dragging or resizing a containing shape with "Locked Children" selected, the interior objects will occasionally (randomly) jitter and then move, disappearing, even if I move the containing shape back to its original location. If I open up the parent shape folder, I can still see the child layers nested inside, but they've randomly moved around the canvas, hidden because they're not within the visible shape area. Stranger still, pressing undo does nothing to return the child objects to their proper place within the parent masking shape. Sorry I don't have an example of this I can share but just thought I would note it. This isn't an issue on every attempt, but it is happening.

Share this post


Link to post
Share on other sites

Don't forget your fish and ships.. We need you guys to stay alive.. Thank you.


Hardware
 Mac mini (late-2014), 2.6GHz, 16GB RAM, Intel Iris 5100 Graphics  iPad Air 16GB White

Software I love, and you should get :wink:
Affinity Desinger - Affinity Photo - Sketch - Coda - CodeKit - iA Writer - Dropbox - 1Password

 

Share this post


Link to post
Share on other sites

You guys are great! One feature request from something I just attempted to do for the first time—could support for gradients be added to global swatches?

 

You can add gradients to application palettes and document palettes. I believe you need to create it on the object first, and then you can either:

- right click and 'Add Fill from Selection'

- or on the swatches panel, there should be a button with a palette icon that should do the same thing.

Share this post


Link to post
Share on other sites

Matt, on a different topic:

 

I find that when working with placed images, often times I want to resize an image from one of the center (not corner) handles, and I lose the intuitive setting I have for scaling objects, meaning I can resize the image without constraining the proportions. I find this counter-intuitive. Now I am well aware of the Preference setting for Scaling behavior, but it feels inconsistent. I want to scale proportionally no matter which handle I use, not only when using the corner handles! What ends up happening is that I have to hold the Shift key to scale proportionally from the center handles. This ends up being confusing (muscle memory). Can we have another preference setting for this behavior, or can we just have the behavior be consistent?

 

Thanks for all you do, Matt, and congrats on all the amazing awards you've all earned!

 

UPDATE: Also when I have a bunch of images selected and I want to resize them all, AD ignores my Scaling preference, and again I have to use the Shift key to resize proportionally. Seems counterintuitive and inconsistent....

 

I'll try to replicate the transform bug - thanks for the heads-up :)


2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS High Sierra

Share this post


Link to post
Share on other sites

You can add gradients to application palettes and document palettes. I believe you need to create it on the object first, and then you can either:

- right click and 'Add Fill from Selection'

- or on the swatches panel, there should be a button with a palette icon that should do the same thing.

Wow! Is this a new feature? I've never seen it before.

Share this post


Link to post
Share on other sites

Weird this splash screen on Affinity Photo and Designer...

We've seen this on and off too in different betas - it seems to be an El Capitan issue, but we're having trouble pinpointing it right now, sorry...

Share this post


Link to post
Share on other sites

I'm not sure where to post this, as it seems a behavior change relative to fonts. I often find myself choosing a font in a design. So I will go through my list using the font pulldown, and then duplicate, choose another and at the end compare the fonts in situ. It used to be the case that when I duplicated a font, if I then went to the font pull down, the font would be highlighted in its place in the list of fonts (I have a few hundred). But now, it appears in the "recently used" font list at the top. This recently used list is very useful. But when duplicating, it was far better that the font is in its order, so I can keep tabbing down till I find the next font I like, continuing the process of narrowing down my font selection.

 

It's a minor but for me important change. The previous behavior was definitely better for me.

Share this post


Link to post
Share on other sites

One other thing maybe you can look at: when one gives a font kerning, if you then highlight the letters you gave kerning, the value of the kerning does not show up in the Character tab. It reverts to zero. Screenshot of this attached:

 

c2UBzSPOUh-3000x3000.png

Share this post


Link to post
Share on other sites

Sorry, one more strange one from me. For some reason, at least in my current working file, using the Artistic Text tool works fine, but using the Frame Text tool does absolutely nothing—I'm able to draw the frame and type, but the cursor simply stays at the beginning of the box, and won't input any characters.

 

Update: At first I thought this might be an issue with just my current working file. I attempted the same thing in a new file, same issue, but my keyboard has been acting strangely. Rebooted, and the issue only occurred in my current working file. I copied all layers over to a new file of the same dimensions and everything seems ok at the moment. Strange!

Share this post


Link to post
Share on other sites

But your last observation seems to be standard behaviour, ianrobertdouglas, as long as you select more than one characters within your text frame. Just put the cursor between two of them, and you will immediately see the applied kerning value …  :)

post-1198-0-43078300-1450111462_thumb.png

Share this post


Link to post
Share on other sites

A couple of bug I found:

 

- In layer fx the combo Gaussian blurColour overlay and Preserve alpha active makes Colour overlay disappear.

Guides Manager with multiple artboards is unreliable, and calculates values starting from first artboard, not for current (on screen position is correct)


The white dog, making tools for artists, illustrators and doodlers

Share this post


Link to post
Share on other sites

Will there be a beta soon that will have the "new" SVG export behavior?  With 1.4.1 beta, I get SVG files that look really lousy and are ~500KB+ in size.  This compares to about one tenth(!) of the size in the 1.3 betas, where the SVG exports were razor-sharp.

 

I would use the old 1.3 betas, but they no longer work: they all declare that I need a retail version installed for them to work.  Apparently having the retail version on 1.4 means I can no longer use 1.3 betas anymore.  The fact that I get unusable and gigantic SVG exports with 1.4 means I can't do my job anymore.  :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×