Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts


Since I installed the latest update my Publisher freezes with every click, literally every click. First, I have to double click in order to simply select another page and it takes at least 5 seconds (no joke) for the selected page to start loading, IF it loads. if I want to do anything in the top menu, like edit the document set up, same issue, it freezes. I've also had to end process in the task manager to be able to close the program. I tried restarting PC, cleaning storage, repairing the installation, uninstalling and downloading the software again and increasing the speed on the performance section of the preferences menu. Nothing works. Last night I spent 6 hours working on a document that would normally take me 45 minutes. It's really bad

Thank you

Windows 10 Pro 64-bit OS

Edited by vvh24
Link to comment
Share on other sites

You can try disabling OpelCL in Publisher and see if that works. My Publisher 1.10.4 also crashes every time I update a linked file, and while you'd think that this has nothing to do with OpenCL, this has solved the problem for me. :S No reaction from Serif staff on why and how, alas...

Link to comment
Share on other sites

  • Staff

Hi @vvh24and Welcome to the Forums,

To disable openCL as @Vosjehas suggested, click Edit>Preferences>Performance and untick openCL at the bottom of the window and close Preferences.  You'll be asked to restart Affinity and once restarted, try using the app again and let me know the results.

@VosjeMost issues caused by Hardware Acceleration (openCL) are related to the graphics card drivers.  Some users find doing a clean install of the latest version of the drivers for their card then allows them to enable H/A and run the app without any issues.  Sometimes that doesn't work and its' normally a bug with how the driver handles openCL commands.  

Link to comment
Share on other sites

Hi @stokerg, thanks for your reply. My graphic card is not on the list of the ones that have problems with Affinity software and by the way, it was working fine before version 1.10.4... of course it *could* be the fault of the driver, but it looks like lots of people report random crashing problems since updating to the newest version... It seems to me that it must have something to do with the newest release. :(

Link to comment
Share on other sites

11 hours ago, vvh24 said:

First, I have to double click in order to simply select another page

If you're talking about clicking in the Pages panel, it's correct that you have to double-click. The first click would select it in the Pages panel for operations there. The second click would select it as the active page for operations on the page itself.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.1.2, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.1.2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.